]> git.pld-linux.org Git - packages/webrtc-audio-processing1.git/blob - webrtc-audio-processing1.spec
c21cde5e3bf10ee11a1127bc63349917b80111eb
[packages/webrtc-audio-processing1.git] / webrtc-audio-processing1.spec
1 # NOTE:
2 # f.d.o source is meant to be a more Linux packaging friendly copy of the
3 # AudioProcessing module from the WebRTC[1] project. The ideal case is that we
4 # make no changes to the code to make tracking upstream code easy.
5 # [1] http://code.google.com/p/webrtc/
6 #
7 # Conditional build:
8 %bcond_without  neon            # ARM NEON instructions
9 %bcond_with     sse2            # SSE2 instructions
10
11 %ifnarch armv7l armv7hl armv7hnl armv8l armv8hl armv8hnl armv8hcnl
12 %undefine       with_neon
13 %endif
14 %ifarch pentium4 %{x8664} x32
15 %define         with_sse2       1
16 %endif
17
18 Summary:        WebRTC Audio Processing library
19 Summary(pl.UTF-8):      Biblioteka WebRTC Audio Processing
20 Name:           webrtc-audio-processing1
21 Version:        1.0
22 Release:        5
23 License:        BSD
24 Group:          Libraries
25 Source0:        https://freedesktop.org/software/pulseaudio/webrtc-audio-processing/webrtc-audio-processing-%{version}.tar.gz
26 # Source0-md5:  8ee1b2f3e615c6c2024951c559a9913a
27 Patch0:         %{name}-abseil.patch
28 Patch1:         %{name}-nosimd.patch
29 Patch2:         cxx17.patch
30 URL:            https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/
31 BuildRequires:  abseil-cpp-devel >= 20200923
32 BuildRequires:  libstdc++-devel >= 6:5
33 BuildRequires:  meson >= 0.54
34 BuildRequires:  ninja >= 1.5
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 WebRTC is an open source project that enables web browsers with
39 Real-Time Communications (RTC) capabilities via simple Javascript
40 APIs. The WebRTC components have been optimized to best serve this
41 purpose. WebRTC implements the W3C's proposal for video conferencing
42 on the web.
43
44 %description -l pl.UTF-8
45 WebRTC to projekt o otwartych źródłach dodający obsługę komunikacji
46 w czasie rzeczywistym (RTC - Real-Time Communications) poprzez proste
47 API JavaScriptu. Komponenty WebRTC zostały zoptymalizowane, aby jak
48 najlepiej sprawdzały się w tym zastosowaniu. WebRTC implementuje
49 propozycje W3C do wideokonferencji w sieci.
50
51 %package devel
52 Summary:        Header files for WebRTC Audio Processing library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WebRTC Audio Processing
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       abseil-cpp-devel >= 20200923
57 Requires:       libstdc++-devel >= 6:5
58
59 %description devel
60 This package contains the header files needed to develop programs
61 which make use of WebRTC Audio Processing library.
62
63 %description devel -l pl.UTF-8
64 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
65 wykorzystujących bibliotekę WebRTC Audio Processing.
66
67 %package static
68 Summary:        Static WebRTC Audio Processing library
69 Summary(pl.UTF-8):      Biblioteka statyczna WebRTC Audio Processing
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static WebRTC Audio Processing library.
75
76 %description static -l pl.UTF-8
77 Biblioteka statyczna WebRTC Audio Processing.
78
79 %prep
80 %setup -q -n webrtc-audio-processing-%{version}
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84
85 %ifarch %{ix86}
86 %if %{without sse2}
87 # add -DPFFFT_SIMD_DISABLE
88 %{__sed} -i -e 's/have_arm and not have_neon.*/& or true/' webrtc/third_party/pffft/meson.build
89 %endif
90 %endif
91
92 %build
93 %if %{with sse2}
94 CFLAGS="%{rpmcflags} -msse2"
95 CXXFLAGS="%{rpmcxxflags} -msse2"
96 %endif
97 %meson build \
98         -Dneon=%{?with_neon:runtime}%{!?with_neon:no}
99
100 %ninja_build -C build
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %ninja_install -C build
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS COPYING NEWS README.md webrtc/PATENTS
116 %attr(755,root,root) %{_libdir}/libwebrtc-audio-coding-1.so.0
117 %attr(755,root,root) %{_libdir}/libwebrtc-audio-processing-1.so.0
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libwebrtc-audio-coding-1.so
122 %attr(755,root,root) %{_libdir}/libwebrtc-audio-processing-1.so
123 %{_includedir}/webrtc-audio-processing-1
124 %{_pkgconfigdir}/webrtc-audio-coding-1.pc
125 %{_pkgconfigdir}/webrtc-audio-processing-1.pc
126
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libwebrtc-audio-coding-1.a
130 %{_libdir}/libwebrtc-audio-processing-1.a
This page took 0.208481 seconds and 2 git commands to generate.