]> git.pld-linux.org Git - packages/webrtc-audio-processing1.git/blob - webrtc-audio-processing1.spec
775ffa455c14b4b2f8c7b4d1b0efa11895392778
[packages/webrtc-audio-processing1.git] / webrtc-audio-processing1.spec
1 # NOTE:
2 # f.d.o source is meant to be a more Linux packaging friendly copy of the
3 # AudioProcessing module from the WebRTC[1] project. The ideal case is that we
4 # make no changes to the code to make tracking upstream code easy.
5 # [1] http://code.google.com/p/webrtc/
6 #
7 # Conditional build:
8 %bcond_without  neon            # ARM NEON instructions
9 %bcond_with     sse2            # SSE2 instructions
10
11 %ifnarch armv7l armv7hl armv7hnl armv8l armv8hl armv8hnl armv8hcnl aarch64
12 %undefine       with_neon
13 %endif
14 %ifarch pentium4 %{x8664} x32
15 %define         with_sse2       1
16 %endif
17
18 Summary:        WebRTC Audio Processing library
19 Summary(pl.UTF-8):      Biblioteka WebRTC Audio Processing
20 Name:           webrtc-audio-processing1
21 Version:        1.0
22 Release:        3
23 License:        BSD
24 Group:          Libraries
25 Source0:        https://freedesktop.org/software/pulseaudio/webrtc-audio-processing/webrtc-audio-processing-%{version}.tar.gz
26 # Source0-md5:  8ee1b2f3e615c6c2024951c559a9913a
27 Patch0:         %{name}-abseil.patch
28 Patch1:         %{name}-nosimd.patch
29 URL:            https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/
30 BuildRequires:  abseil-cpp-devel >= 20200923
31 BuildRequires:  libstdc++-devel >= 6:5
32 BuildRequires:  meson >= 0.54
33 BuildRequires:  ninja >= 1.5
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 WebRTC is an open source project that enables web browsers with
38 Real-Time Communications (RTC) capabilities via simple Javascript
39 APIs. The WebRTC components have been optimized to best serve this
40 purpose. WebRTC implements the W3C's proposal for video conferencing
41 on the web.
42
43 %description -l pl.UTF-8
44 WebRTC to projekt o otwartych źródłach dodający obsługę komunikacji
45 w czasie rzeczywistym (RTC - Real-Time Communications) poprzez proste
46 API JavaScriptu. Komponenty WebRTC zostały zoptymalizowane, aby jak
47 najlepiej sprawdzały się w tym zastosowaniu. WebRTC implementuje
48 propozycje W3C do wideokonferencji w sieci.
49
50 %package devel
51 Summary:        Header files for WebRTC Audio Processing library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WebRTC Audio Processing
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       abseil-cpp-devel >= 20200923
56 Requires:       libstdc++-devel >= 6:5
57
58 %description devel
59 This package contains the header files needed to develop programs
60 which make use of WebRTC Audio Processing library.
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
64 wykorzystujących bibliotekę WebRTC Audio Processing.
65
66 %package static
67 Summary:        Static WebRTC Audio Processing library
68 Summary(pl.UTF-8):      Biblioteka statyczna WebRTC Audio Processing
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static WebRTC Audio Processing library.
74
75 %description static -l pl.UTF-8
76 Biblioteka statyczna WebRTC Audio Processing.
77
78 %prep
79 %setup -q -n webrtc-audio-processing-%{version}
80 %patch0 -p1
81 %patch1 -p1
82
83 %ifarch %{ix86}
84 %if %{without sse2}
85 # add -DPFFFT_SIMD_DISABLE
86 %{__sed} -i -e 's/have_arm and not have_neon.*/& or true/' webrtc/third_party/pffft/meson.build
87 %endif
88 %endif
89
90 %build
91 %if %{with sse2}
92 CFLAGS="%{rpmcflags} -msse2"
93 CXXFLAGS="%{rpmcxxflags} -msse2"
94 %endif
95 %meson build \
96         -Dneon=%{?with_neon:runtime}%{!?with_neon:no}
97
98 %ninja_build -C build
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %ninja_install -C build
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS COPYING NEWS README.md webrtc/PATENTS
114 %attr(755,root,root) %{_libdir}/libwebrtc-audio-coding-1.so.0
115 %attr(755,root,root) %{_libdir}/libwebrtc-audio-processing-1.so.0
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libwebrtc-audio-coding-1.so
120 %attr(755,root,root) %{_libdir}/libwebrtc-audio-processing-1.so
121 %{_includedir}/webrtc-audio-processing-1
122 %{_pkgconfigdir}/webrtc-audio-coding-1.pc
123 %{_pkgconfigdir}/webrtc-audio-processing-1.pc
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libwebrtc-audio-coding-1.a
128 %{_libdir}/libwebrtc-audio-processing-1.a
This page took 0.100281 seconds and 2 git commands to generate.