]> git.pld-linux.org Git - packages/webrtc-audio-processing1.git/blob - webrtc-audio-processing.spec
disable neon on not applicable archs
[packages/webrtc-audio-processing1.git] / webrtc-audio-processing.spec
1 # NOTE:
2 # f.d.o source is meant to be a more Linux packaging friendly copy of the
3 # AudioProcessing module from the WebRTC[1] project. The ideal case is that we
4 # make no changes to the code to make tracking upstream code easy.
5 # [1] http://code.google.com/p/webrtc/
6 #
7 # Conditional build:
8 %bcond_without  neon            # without ARM NEON instructions
9
10 %ifnarch armv7l armv7hl armv7hnl armv8l armv8hl armv8hnl armv8hcnl aarch64
11 %undefine       with_neon
12 %endif
13
14 Summary:        WebRTC Audio Processing library
15 Summary(pl.UTF-8):      Biblioteka WebRTC Audio Processing
16 Name:           webrtc-audio-processing
17 Version:        0.3.1
18 Release:        1
19 License:        BSD
20 Group:          Libraries
21 Source0:        https://freedesktop.org/software/pulseaudio/webrtc-audio-processing/%{name}-%{version}.tar.xz
22 # Source0-md5:  6e10724ca34bcbc715a4c208273acb0c
23 URL:            https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake >= 1:1.11
26 BuildRequires:  libstdc++-devel >= 6:4.7
27 BuildRequires:  libtool
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 WebRTC is an open source project that enables web browsers with
34 Real-Time Communications (RTC) capabilities via simple Javascript
35 APIs. The WebRTC components have been optimized to best serve this
36 purpose. WebRTC implements the W3C's proposal for video conferencing
37 on the web.
38
39 %description -l pl.UTF-8
40 WebRTC to projekt o otwartych źródłach dodający obsługę komunikacji
41 w czasie rzeczywistym (RTC - Real-Time Communications) poprzez proste
42 API JavaScriptu. Komponenty WebRTC zostały zoptymalizowane, aby jak
43 najlepiej sprawdzały się w tym zastosowaniu. WebRTC implementuje
44 propozycje W3C do wideokonferencji w sieci.
45
46 %package devel
47 Summary:        Header files for WebRTC Audio Processing library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WebRTC Audio Processing
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libstdc++-devel
52
53 %description devel
54 This package contains the header files needed to develop programs
55 which make use of WebRTC Audio Processing library.
56
57 %description devel -l pl.UTF-8
58 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
59 wykorzystujących bibliotekę WebRTC Audio Processing.
60
61 %package static
62 Summary:        Static WebRTC Audio Processing library
63 Summary(pl.UTF-8):      Biblioteka statyczna WebRTC Audio Processing
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static WebRTC Audio Processing library.
69
70 %description static -l pl.UTF-8
71 Biblioteka statyczna WebRTC Audio Processing.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         %{!?with_neon:--disable-neon} \
83         --disable-silent-rules
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING NEWS README.md webrtc/PATENTS
103 %attr(755,root,root) %{_libdir}/libwebrtc_audio_processing.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libwebrtc_audio_processing.so.1
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libwebrtc_audio_processing.so
109 %{_includedir}/webrtc_audio_processing
110 %{_pkgconfigdir}/webrtc-audio-processing.pc
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libwebrtc_audio_processing.a
This page took 0.070968 seconds and 3 git commands to generate.