]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
eea71ef5ad0261e1f5ae516c752f3fa3db2c2a09
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.11.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  fccf680be066e234729d5b69e0bd0fa9
15 Patch1:         %{name}-man.patch
16 URL:            https://wayland.freedesktop.org/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  expat-devel >= 1.95
20 BuildRequires:  libffi-devel >= 3
21 BuildRequires:  libtool >= 2:2.2
22 # for DTD valudation
23 BuildRequires:  libxml2-devel >= 2.0
24 BuildRequires:  pkgconfig
25 %if %{with apidocs}
26 BuildRequires:  docbook-style-xsl
27 BuildRequires:  doxygen >= 1.6.0
28 BuildRequires:  graphviz >= 2.26.0
29 BuildRequires:  libxslt-progs
30 BuildRequires:  xmlto
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Wayland is a project to define a protocol for a compositor to talk to
36 its clients as well as a library implementation of the protocol. The
37 compositor can be a standalone display server running on Linux kernel
38 modesetting and evdev input devices, an X application, or a Wayland
39 client itself. The clients can be traditional applications, X servers
40 (rootless or fullscreen) or other display servers.
41
42 %description -l pl.UTF-8
43 Wayland to projekt definiujący protokół między serwerem składającym a
44 klientami, a także biblioteki implementujące ten protokół. Serwer
45 składający może być samodzielnym serwerem wyświetlającym działającym
46 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
47 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
48 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
49 wyświetlające.
50
51 %package devel
52 Summary:        Header files for Wayland libraries
53 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libffi-devel
57
58 %description devel
59 Header files for Wayland libraries.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe bibliotek Wayland.
63
64 %package static
65 Summary:        Static Wayland libraries
66 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static Wayland libraries.
72
73 %description static -l pl.UTF-8
74 Statyczne biblioteki Wayland.
75
76 %package apidocs
77 Summary:        Wayland API and protocol documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
79 Group:          Documentation
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description apidocs
85 Wayland API and protocol documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki oraz protokołu Wayland.
89
90 %prep
91 %setup -q
92 %patch1 -p1
93
94 # force regeneration (.so link is broken, double man3/)
95 %{__rm} doc/man/*.3
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_apidocs:--disable-documentation} \
105         --disable-silent-rules \
106         %{!?with_static_libs:--disable-static}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # referenced by some installed wl_*.3 man pages
117 cp -p doc/doxygen/man/man3/wayland-{client-core,server,server-core,util}.h.3 \
118         doc/doxygen/man/man3/wayland-{client,server,shm,util}.c.3 $RPM_BUILD_ROOT%{_mandir}/man3
119
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
122 %if %{with apidocs}
123 # packaged as %doc in -devel
124 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
125 %endif
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc COPYING README TODO
136 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
138 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
140 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/wayland-scanner
146 %attr(755,root,root) %{_libdir}/libwayland-client.so
147 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
148 %attr(755,root,root) %{_libdir}/libwayland-server.so
149 %{_includedir}/wayland-*.h
150 %dir %{_datadir}/wayland
151 %{_datadir}/wayland/wayland.dtd
152 %{_datadir}/wayland/wayland.xml
153 %{_datadir}/wayland/wayland-scanner.mk
154 %{_pkgconfigdir}/wayland-client.pc
155 %{_pkgconfigdir}/wayland-cursor.pc
156 %{_pkgconfigdir}/wayland-scanner.pc
157 %{_pkgconfigdir}/wayland-server.pc
158 %{_aclocaldir}/wayland-scanner.m4
159 %if %{with apidocs}
160 %{_mandir}/man3/wayland-*.c.3*
161 %{_mandir}/man3/wayland-*.h.3*
162 %{_mandir}/man3/wl_*.3*
163 %endif
164
165 %if %{with static_libs}
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libwayland-client.a
169 %{_libdir}/libwayland-cursor.a
170 %{_libdir}/libwayland-server.a
171 %endif
172
173 %if %{with apidocs}
174 %files apidocs
175 %defattr(644,root,root,755)
176 %doc doc/publican/Wayland/en-US/html/*
177 %endif
This page took 0.057395 seconds and 2 git commands to generate.