]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
9614ff127fcb4387da8e660fdbba6c4d3ade70a1
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.19.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://wayland.freedesktop.org/releases.html
14 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  5d59ac3d8a8f4e42de2ceb8bb19dfca9
16 URL:            https://wayland.freedesktop.org/
17 BuildRequires:  expat-devel >= 1.95
18 BuildRequires:  libffi-devel >= 3
19 # for DTD valudation
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  meson >= 0.52.1
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 %if %{with apidocs}
25 BuildRequires:  docbook-style-xsl-nons
26 BuildRequires:  doxygen >= 1.6.0
27 BuildRequires:  graphviz >= 2.26.0
28 BuildRequires:  libxslt-progs
29 BuildRequires:  rpmbuild(macros) >= 1.752
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xmlto
32 BuildRequires:  xz
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Wayland is a project to define a protocol for a compositor to talk to
38 its clients as well as a library implementation of the protocol. The
39 compositor can be a standalone display server running on Linux kernel
40 modesetting and evdev input devices, an X application, or a Wayland
41 client itself. The clients can be traditional applications, X servers
42 (rootless or fullscreen) or other display servers.
43
44 %description -l pl.UTF-8
45 Wayland to projekt definiujący protokół między serwerem składającym a
46 klientami, a także biblioteki implementujące ten protokół. Serwer
47 składający może być samodzielnym serwerem wyświetlającym działającym
48 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
49 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
50 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
51 wyświetlające.
52
53 %package devel
54 Summary:        Header files for Wayland libraries
55 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libffi-devel
59
60 %description devel
61 Header files for Wayland libraries.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe bibliotek Wayland.
65
66 %package static
67 Summary:        Static Wayland libraries
68 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static Wayland libraries.
74
75 %description static -l pl.UTF-8
76 Statyczne biblioteki Wayland.
77
78 %package egl
79 Summary:        Wayland EGL library
80 Summary(pl.UTF-8):      Biblioteka Wayland EGL
81 Group:          Libraries
82 Obsoletes:      Mesa-libwayland-egl
83
84 %description egl
85 Wayland EGL library.
86
87 %description egl -l pl.UTF-8
88 Biblioteka Wayland EGL.
89
90 %package egl-devel
91 Summary:        Header files for Wayland EGL library
92 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Wayland EGL
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Requires:       %{name}-egl = %{version}-%{release}
96 Obsoletes:      Mesa-libwayland-egl-devel
97
98 %description egl-devel
99 Header files for Wayland EGL library.
100
101 %description egl-devel -l pl.UTF-8
102 Pliki nagłówkowe biblioteki Wayland EGL.
103
104 %package egl-static
105 Summary:        Static Wayland EGL library
106 Summary(pl.UTF-8):      Statyczna biblioteka Wayland EGL
107 Group:          Development/Libraries
108 Requires:       %{name}-egl-devel = %{version}-%{release}
109
110 %description egl-static
111 Static Wayland EGL library.
112
113 %description egl-static -l pl.UTF-8
114 Statyczna biblioteka Wayland EGL.
115
116 %package apidocs
117 Summary:        Wayland API and protocol documentation
118 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
119 Group:          Documentation
120 %{?noarchpackage}
121
122 %description apidocs
123 Wayland API and protocol documentation.
124
125 %description apidocs -l pl.UTF-8
126 Dokumentacja API biblioteki oraz protokołu Wayland.
127
128 %prep
129 %setup -q
130
131 %build
132 %meson build \
133         %{!?with_apidocs:-Ddocumentation=false} \
134         %{!?with_static_libs:--default-library=shared}
135
136 %ninja_build -C build
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %ninja_install -C build
142
143 %if %{with apidocs}
144 # packaged as %doc in -devel
145 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
146 %endif
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc COPYING CONTRIBUTING.md README
157 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
159 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
161 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/wayland-scanner
167 %attr(755,root,root) %{_libdir}/libwayland-client.so
168 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
169 %attr(755,root,root) %{_libdir}/libwayland-server.so
170 %{_includedir}/wayland-client*.h
171 %{_includedir}/wayland-cursor.h
172 %{_includedir}/wayland-server*.h
173 %{_includedir}/wayland-util.h
174 %{_includedir}/wayland-version.h
175 %dir %{_datadir}/wayland
176 %{_datadir}/wayland/wayland.dtd
177 %{_datadir}/wayland/wayland.xml
178 %{_datadir}/wayland/wayland-scanner.mk
179 %{_pkgconfigdir}/wayland-client.pc
180 %{_pkgconfigdir}/wayland-cursor.pc
181 %{_pkgconfigdir}/wayland-scanner.pc
182 %{_pkgconfigdir}/wayland-server.pc
183 %{_aclocaldir}/wayland-scanner.m4
184 %if %{with apidocs}
185 %{_mandir}/man3/wl_*.3*
186 %endif
187 # NOTE: temporarily here because they're used but not included in Mesa 18.1.x
188 # TODO: move to -egl-devel after transition to Mesa 18.2.x
189 %{_includedir}/wayland-egl.h
190 %{_includedir}/wayland-egl-core.h
191
192 %if %{with static_libs}
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/libwayland-client.a
196 %{_libdir}/libwayland-cursor.a
197 %{_libdir}/libwayland-server.a
198 %endif
199
200 %if %{with apidocs}
201 %files apidocs
202 %defattr(644,root,root,755)
203 %doc build/doc/publican/html/* doc/publican/sources/{css,images}
204 %endif
205
206 %files egl
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
209 %attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
210
211 %files egl-devel
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libwayland-egl.so
214 %{_includedir}/wayland-egl-backend.h
215 %{_pkgconfigdir}/wayland-egl.pc
216 %{_pkgconfigdir}/wayland-egl-backend.pc
217
218 %if %{with static_libs}
219 %files egl-static
220 %defattr(644,root,root,755)
221 %{_libdir}/libwayland-egl.a
222 %endif
This page took 0.077361 seconds and 2 git commands to generate.