]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- updated to 1.0.6
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.0.6
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  936a2590aea69fa3c0cf234d54b9137c
15 Patch0:         %{name}-publican.patch
16 URL:            http://wayland.freedesktop.org/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  docbook-style-xsl
20 BuildRequires:  doxygen
21 BuildRequires:  expat-devel
22 BuildRequires:  libffi-devel
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  libxslt-progs
25 BuildRequires:  pkgconfig
26 BuildRequires:  pkgconfig(libffi)
27 %{?with_apidocs:BuildRequires:  publican >= 3}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Wayland is a project to define a protocol for a compositor to talk to
32 its clients as well as a library implementation of the protocol. The
33 compositor can be a standalone display server running on Linux kernel
34 modesetting and evdev input devices, an X application, or a Wayland
35 client itself. The clients can be traditional applications, X servers
36 (rootless or fullscreen) or other display servers.
37
38 %description -l pl.UTF-8
39 Wayland to projekt definiujący protokół między serwerem składającym a
40 klientami, a także biblioteki implementujące ten protokół. Serwer
41 składający może być samodzielnym serwerem wyświetlającym działającym
42 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
43 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
44 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
45 wyświetlające.
46
47 %package devel
48 Summary:        Header files for Wayland libraries
49 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libffi-devel
53
54 %description devel
55 Header files for Wayland libraries.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe bibliotek Wayland.
59
60 %package static
61 Summary:        Static Wayland libraries
62 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static Wayland libraries.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki Wayland.
71
72 %package apidocs
73 Summary:        Wayland API and protocol documentation
74 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
75 Group:          Documentation
76
77 %description apidocs
78 Wayland API and protocol documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki oraz protokołu Wayland.
82
83 %prep
84 %setup -q
85
86 # this file is required by publican 3.0; publican patch adds it in en-US dir
87 test ! -f doc/Wayland/en_US/Revision_History.xml
88
89 %patch0 -p1
90
91 %build
92 %{__libtoolize}
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         --disable-silent-rules \
99         %{!?with_static_libs:--disable-static}
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # obsoleted by pkg-config
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
110 # packaged as %doc in -devel
111 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc COPYING README TODO
122 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
124 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
126 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/wayland-scanner
132 %attr(755,root,root) %{_libdir}/libwayland-client.so
133 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
134 %attr(755,root,root) %{_libdir}/libwayland-server.so
135 %{_includedir}/wayland-*.h
136 %{_pkgconfigdir}/wayland-client.pc
137 %{_pkgconfigdir}/wayland-cursor.pc
138 %{_pkgconfigdir}/wayland-server.pc
139 %{_aclocaldir}/wayland-scanner.m4
140 %{_aclocaldir}/wayland-scanner.mk
141 %{_mandir}/man3/wl_display_connect.3*
142 %{_mandir}/man3/wl_display_connect_to_fd*
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libwayland-client.a
148 %{_libdir}/libwayland-cursor.a
149 %{_libdir}/libwayland-server.a
150 %endif
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %doc doc/Wayland/Wayland/en-US/html/*
156 %endif
This page took 0.075996 seconds and 3 git commands to generate.