]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
df7b374fce45009d4b7c3eadc14d80d7460c7ad0
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk4    # GTK+ 4 based library [doesn't build with 3.90]
4
5 Summary:        VTE terminal widget library
6 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
7 Name:           vte
8 Version:        0.58.3
9 Release:        1
10 # some files have LGPL v2.1+ signature, but some LGPL v3+
11 License:        LGPL v3+ (library), GPL v3+ (app)
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vte/0.58/%{name}-%{version}.tar.xz
14 # Source0-md5:  f59eb0784a361c0939c03d4566255916
15 Patch0:         %{name}-wordsep.patch
16 BuildRequires:  cairo-gobject-devel
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  fribidi-devel >= 1.0.0
19 BuildRequires:  gdk-pixbuf2-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 1:2.40.0
22 BuildRequires:  gnutls-devel >= 3.2.7
23 BuildRequires:  gobject-introspection-devel >= 0.10.0
24 BuildRequires:  gperf
25 BuildRequires:  gtk+3-devel >= 3.8.0
26 %{?with_gtk4:BuildRequires:     gtk+4-devel >= 4.0.0}
27 BuildRequires:  gtk-doc >= 1.13
28 BuildRequires:  intltool >= 0.40.0
29 # C++17 support (-std=gnu++17, with constexpr lambdas support)
30 BuildRequires:  libstdc++-devel >= 6:7.0
31 BuildRequires:  libxml2-progs >= 2
32 BuildRequires:  meson >= 0.49.0
33 BuildRequires:  ninja >= 1.5
34 BuildRequires:  pango-devel >= 1:1.22.0
35 BuildRequires:  pcre2-8-devel >= 10.21
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.736
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  vala >= 2:0.24
40 BuildRequires:  xz
41 BuildRequires:  zlib-devel
42 Requires:       fribidi >= 1.0.0
43 Requires:       glib2 >= 1:2.40.0
44 Requires:       gnutls >= 3.2.7
45 Requires:       gtk+3 >= 3.8.0
46 Requires:       pango >= 1:1.22.0
47 Obsoletes:      vte-common < 0.42.0
48 Obsoletes:      vte-glade < 0.58.0
49 # sr@Latn vs. sr@latin
50 Conflicts:      glibc-misc < 6:2.7
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 The vte package contains a terminal widget for GTK+ 3.x. It's used by
55 gnome-terminal among other programs.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera kontrolkę terminala dla GTK+ 3.x. Jest używany
59 przez gnome-terminal oraz inne programy.
60
61 %package devel
62 Summary:        Header files for VTE for GTK+ 3
63 Summary(pl.UTF-8):      Pliki nagłówkowe VTE dla GTK+ 3
64 License:        LGPL v3+
65 Group:          X11/Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       glib2-devel >= 1:2.40.0
68 Requires:       gtk+3-devel >= 3.8.0
69 Requires:       pango-devel >= 1:1.22.0
70 Conflicts:      gnome-libs-devel < 1.4.1.2
71
72 %description devel
73 This package contains header files for GTK+ 3 based vte library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe potrzebne do kompilowania programów używających
77 biblioteki vte opartej na GTK+ 3.
78
79 %package -n vala-vte
80 Summary:        Vala API for VTE library
81 Summary(pl.UTF-8):      API języka Vala dla biblioteki VTE
82 License:        LGPL v3+
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Requires:       vala >= 2:0.24
86 %if "%{_rpmversion}" >= "5"
87 BuildArch:      noarch
88 %endif
89
90 %description -n vala-vte
91 Vala API for VTE library.
92
93 %description -n vala-vte -l pl.UTF-8
94 API języka Vala dla biblioteki VTE.
95
96 %package apidocs
97 Summary:        VTE API documentation (GTK+ 3 version)
98 Summary(pl.UTF-8):      Dokumentacja API VTE (wersja dla GTK+ 3)
99 Group:          Documentation
100 Requires:       gtk-doc-common
101 %if "%{_rpmversion}" >= "5"
102 BuildArch:      noarch
103 %endif
104
105 %description apidocs
106 VTE API documentation (GTK+ 3 version).
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API VTE (wersja dla GTK+ 3).
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 %meson build \
117         -Ddocs=true \
118         -Dgtk3=true \
119         -Dgtk4=%{__true_false gtk4}
120
121 %ninja_build -C build
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %ninja_install -C build
127
128 %find_lang %{name}-2.91
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f vte-2.91.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README.md
139 %attr(755,root,root) %{_bindir}/vte-2.91
140 %attr(755,root,root) %{_libdir}/libvte-2.91.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libvte-2.91.so.0
142 %{_libdir}/girepository-1.0/Vte-2.91.typelib
143 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/vte.sh
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libvte-2.91.so
148 %{_includedir}/vte-2.91
149 %{_pkgconfigdir}/vte-2.91.pc
150 %{_datadir}/gir-1.0/Vte-2.91.gir
151
152 %files -n vala-vte
153 %defattr(644,root,root,755)
154 %{_datadir}/vala/vapi/vte-2.91.deps
155 %{_datadir}/vala/vapi/vte-2.91.vapi
156
157 %files apidocs
158 %defattr(644,root,root,755)
159 %{_gtkdocdir}/vte-2.91
This page took 0.052253 seconds and 2 git commands to generate.