]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
- updated to 0.5.5
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk2    # use GTK+ 2.x instead of GTK+ 3.x
4 %bcond_without  spice   # SPICE support
5 %bcond_without  plugin  # Mozilla plugin (doesn't work with GTK+ 3)
6 #
7 %if %{without gtk2}
8 # plugin is not ready for GTK+ 3
9 %undefine       with_plugin
10 %endif
11 Summary:        Virtual Machine Viewer
12 Summary(pl.UTF-8):      Przeglądarka maszyny wirtualnej
13 Name:           virt-viewer
14 Version:        0.5.5
15 Release:        1
16 License:        GPL v2+
17 Group:          X11/Applications/Networking
18 Source0:        http://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.gz
19 # Source0-md5:  a5516d33a29df5d135611c4667c03f77
20 Patch0:         %{name}-plugin.patch
21 URL:            http://virt-manager.org/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  gettext-devel >= 0.14.1
25 BuildRequires:  glib2-devel >= 1:2.22.0
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  libvirt-devel >= 0.10.0
29 BuildRequires:  libxml2-devel >= 1:2.6.0
30 BuildRequires:  perl-tools-pod
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  spice-protocol >= 0.10.1
33 %if %{with gtk2}
34 BuildRequires:  gtk+2-devel >= 2:2.18.0
35 BuildRequires:  gtk-vnc-devel >= 0.4.3
36 %{?with_spice:BuildRequires: spice-gtk2-devel >= 0.16.26}
37 %else
38 BuildRequires:  gtk+3-devel >= 3.0.0
39 BuildRequires:  gtk3-vnc-devel >= 0.4.3
40 %{?with_spice:BuildRequires: spice-gtk-devel >= 0.16.26}
41 %endif
42 %if %{with plugin}
43 BuildRequires:  nspr-devel >= 4.0.0
44 BuildRequires:  xulrunner-devel >= 1.8
45 %endif
46 Requires(post,postun):  gtk-update-icon-cache
47 Requires:       glib2 >= 1:2.22.0
48 Requires:       hicolor-icon-theme
49 Requires:       libvirt >= 0.10.0
50 Requires:       libxml2 >= 1:2.6.0
51 %if %{with gtk2}
52 Requires:       gtk+2 >= 2:2.18.0
53 Requires:       gtk-vnc >= 0.4.3
54 %{?with_spice:Requires: spice-gtk2 >= 0.16.26}
55 %else
56 BuildRequires:  gtk+3 >= 3.0.0
57 BuildRequires:  gtk3-vnc >= 0.4.3
58 %{?with_spice:BuildRequires: spice-gtk >= 0.16.26}
59 %endif
60 Suggests:       openssh-clients
61 Suggests:       gnome-keyring >= 0.4.9
62 ExclusiveArch:  %{ix86} %{x8664} ia64
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Virtual Machine Viewer provides a graphical console client for
67 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
68 widgets to provide the display, and libvirt for looking up VNC/SPICE
69 server details.
70
71 %description -l pl.UTF-8
72 Virtual Machine Viewer udostępnia klienta graficznej konsoli do
73 łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
74 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
75 serwera VNC/SPICE.
76
77 %package plugin
78 Summary:        Mozilla plugin for the gtk-vnc library
79 Summary(pl.UTF-8):      Wtyczka Mozilli do biblioteki gtk-vnc
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description plugin
84 Virtual Machine Viewer provides a graphical
85 console client for connecting to virtual machines. It uses the GTK-VNC
86 or SPICE-GTK widgets to provide the display, and libvirt for looking
87 up VNC/SPICE server details.
88
89 This package provides a web browser plugin for Mozilla compatible
90 browsers.
91
92 %description plugin -l pl.UTF-8
93 Virtual Machine Viewer udostępnia klienta graficznej konsoli do
94 łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
95 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
96 serwera VNC/SPICE.
97
98 Ten pakiet dostarcza wtyczkę dla przeglądarek WWW zgodnych z Mozillą.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --disable-silent-rules \
114         %{__enable_disable plugin} \
115         %{__with_without spice spice-gtk} \
116         --with-gtk=%{?with_gtk2:2.0}%{!?with_gtk2:3.0}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         plugindir=%{_libdir}/browser-plugins
126
127 %find_lang %{name}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 %update_icon_cache hicolor
134
135 %postun
136 %update_icon_cache hicolor
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README
141 %attr(755,root,root) %{_bindir}/virt-viewer
142 %attr(755,root,root) %{_bindir}/remote-viewer
143 %dir %{_datadir}/%{name}
144 %dir %{_datadir}/%{name}/ui
145 %{_datadir}/%{name}/ui/*.xml
146 %{_desktopdir}/remote-viewer.desktop
147 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
148 %{_mandir}/man1/virt-viewer.1*
149 %{_mandir}/man1/remote-viewer.1*
150
151 %if %{with plugin}
152 %files plugin
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/browser-plugins/virt-viewer-plugin.so
155 %endif
This page took 0.084266 seconds and 3 git commands to generate.