]> git.pld-linux.org Git - packages/vim-plugin-fugitive.git/blob - vim-plugin-fugitive.spec
up to 2.5
[packages/vim-plugin-fugitive.git] / vim-plugin-fugitive.spec
1 %define         plugin  fugitive
2 Summary:        Vim plugin: A Git wrapper so awesome, it should be illegal
3 Name:           vim-plugin-%{plugin}
4 Version:        2.5
5 Release:        1
6 License:        Vim
7 Group:          Applications/Editors/Vim
8 Source0:        https://github.com/tpope/vim-fugitive/archive/v%{version}.tar.gz
9 # Source0-md5:  c08ebeea230d82a65400163c52b5e94f
10 URL:            http://majutsushi.github.com/fugitive/
11 Requires:       vim-rt >= 4:7.4.0
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _vimdatadir     %{_datadir}/vim
16
17 %description
18 View any blob, tree, commit, or tag in the repository with :Gedit (and
19 :Gsplit, :Gvsplit, :Gtabedit, ...). Edit a file in the index and write
20 to it to stage the changes. Use :Gdiff to bring up the staged version
21 of the file side by side with the working tree version and use Vim's
22 diff handling capabilities to stage a subset of the file's changes.
23
24 Bring up the output of git-status with :Gstatus. Press `-` to
25 add/reset a file's changes, or `p` to add/reset --patch. And guess
26 what :Gcommit does!
27
28 :Gblame brings up an interactive vertical split with git-blame output.
29 Press enter on a line to reblame the file as it stood in that commit,
30 or`o` to open that commit in a split.
31
32 :Gmove does a git-mv on a file and simultaneously renames the buffer.
33 :Gremove does a git-rm on a file and simultaneously deletes the
34 buffer.
35
36 Use :Ggrep to search the work tree (or any arbitrary commit) with
37 git-grep, skipping over that which is not tracked in the repository.
38 :Glog loads all previous revisions of a file into the quickfix list so
39 you can iterate over them and watch the file evolve!
40
41 :Gread is a variant of `git checkout -- filename` that operates on the
42 buffer rather than the filename. This means you can use `u` to undo it
43 and you never get any warnings about the file changing outside Vim.
44 :Gwrite writes to both the work tree and index versions of a file,
45 making it like git-add when called from a work tree file and like
46 git-checkout when called from the index or a blob in history.
47
48 %package doc
49 Summary:        Documentation for fugitive Vim plugin
50 Requires(post,postun):  /usr/bin/vim
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       vim-rt >= 4:7.4.2054-2
53
54 %description doc
55 Documentation for fugitive Vim plugin.
56
57 %prep
58 %setup -qn vim-fugitive-%{version}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_vimdatadir}/
63 cp -pr autoload doc ftdetect plugin $RPM_BUILD_ROOT%{_vimdatadir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post doc
69 %vim_doc_helptags
70
71 %postun doc
72 %vim_doc_helptags
73
74 %files
75 %defattr(644,root,root,755)
76 %{_vimdatadir}/autoload/fugitive.vim
77 %{_vimdatadir}/ftdetect/fugitive.vim
78 %{_vimdatadir}/plugin/fugitive.vim
79
80 %files doc
81 %defattr(644,root,root,755)
82 %{_vimdatadir}/doc/fugitive.txt
This page took 0.065713 seconds and 3 git commands to generate.