]> git.pld-linux.org Git - packages/vim-plugin-fugitive.git/blob - vim-plugin-fugitive.spec
36f48c9311af5744bab0d39179d4a9b268921809
[packages/vim-plugin-fugitive.git] / vim-plugin-fugitive.spec
1 %define         plugin  fugitive
2 Summary:        Vim plugin: A Git wrapper so awesome, it should be illegal
3 Name:           vim-plugin-%{plugin}
4 Version:        3.3
5 Release:        1
6 License:        Vim
7 Group:          Applications/Editors/Vim
8 Source0:        https://github.com/tpope/vim-fugitive/archive/v%{version}.tar.gz
9 # Source0-md5:  3b370f7e99adf35efffa0fef1ae04fb8
10 URL:            http://majutsushi.github.com/fugitive/
11 Requires:       git-core >= 1.8.5
12 Requires:       vim-rt >= 4:7.4.0
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _vimdatadir     %{_datadir}/vim
17
18 %description
19 View any blob, tree, commit, or tag in the repository with :Gedit (and
20 :Gsplit, :Gvsplit, :Gtabedit, ...). Edit a file in the index and write
21 to it to stage the changes. Use :Gdiff to bring up the staged version
22 of the file side by side with the working tree version and use Vim's
23 diff handling capabilities to stage a subset of the file's changes.
24
25 Bring up the output of git-status with :Gstatus. Press `-` to
26 add/reset a file's changes, or `p` to add/reset --patch. And guess
27 what :Gcommit does!
28
29 :Gblame brings up an interactive vertical split with git-blame output.
30 Press enter on a line to reblame the file as it stood in that commit,
31 or`o` to open that commit in a split.
32
33 :Gmove does a git-mv on a file and simultaneously renames the buffer.
34 :Gremove does a git-rm on a file and simultaneously deletes the
35 buffer.
36
37 Use :Ggrep to search the work tree (or any arbitrary commit) with
38 git-grep, skipping over that which is not tracked in the repository.
39 :Glog loads all previous revisions of a file into the quickfix list so
40 you can iterate over them and watch the file evolve!
41
42 :Gread is a variant of `git checkout -- filename` that operates on the
43 buffer rather than the filename. This means you can use `u` to undo it
44 and you never get any warnings about the file changing outside Vim.
45 :Gwrite writes to both the work tree and index versions of a file,
46 making it like git-add when called from a work tree file and like
47 git-checkout when called from the index or a blob in history.
48
49 %package doc
50 Summary:        Documentation for fugitive Vim plugin
51 Requires(post,postun):  /usr/bin/vim
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       vim-rt >= 4:7.4.2054-2
54
55 %description doc
56 Documentation for fugitive Vim plugin.
57
58 %prep
59 %setup -qn vim-fugitive-%{version}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_vimdatadir}/
64 cp -pr autoload doc ftdetect ftplugin plugin syntax $RPM_BUILD_ROOT%{_vimdatadir}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post doc
70 %vim_doc_helptags
71
72 %postun doc
73 %vim_doc_helptags
74
75 %files
76 %defattr(644,root,root,755)
77 %{_vimdatadir}/autoload/fugitive.vim
78 %{_vimdatadir}/ftdetect/fugitive.vim
79 %{_vimdatadir}/ftplugin/fugitiveblame.vim
80 %{_vimdatadir}/plugin/fugitive.vim
81 %{_vimdatadir}/syntax/fugitive.vim
82 %{_vimdatadir}/syntax/fugitiveblame.vim
83
84 %files doc
85 %defattr(644,root,root,755)
86 %{_vimdatadir}/doc/fugitive.txt
This page took 0.084718 seconds and 2 git commands to generate.