]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- release 4 (by relup.sh)
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
3 Name:           vigra
4 Version:        1.9.0
5 Release:        4
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://hci.iwr.uni-heidelberg.de/vigra/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  b6155afe1ea967917d2be16d98a85404
10 URL:            http://hci.iwr.uni-heidelberg.de/vigra/
11 BuildRequires:  boost-python-devel >= 1.40.0
12 BuildRequires:  cmake >= 2.6.0
13 BuildRequires:  doxygen
14 BuildRequires:  fftw3-single-devel
15 BuildRequires:  hdf5-devel >= 1.8
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  libpng-devel >= 1.4.0
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtiff-devel
20 BuildRequires:  pkgconfig
21 BuildRequires:  python
22 BuildRequires:  python-devel
23 BuildRequires:  python-numpy-devel
24 BuildRequires:  rpmbuild(macros) >= 1.586
25 BuildRequires:  sphinx-pdg
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 VIGRA stands for "Vision with Generic Algorithms". It's a novel
31 computer vision library that puts its main emphasize on customizable
32 algorithms and data structures. By using template techniques similar
33 to those in the C++ Standard Template Library, you can easily adapt
34 any VIGRA component to the needs of your application, without thereby
35 giving up execution speed.
36
37 %description -l pl.UTF-8
38 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
39 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
40 główny nacisk na algorytmy i struktury danych z możliwością
41 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
42 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
43 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
44 bez poświęcania szybkości wykonywania.
45
46 %package devel
47 Summary:        Header files for vigra library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       fftw3-single-devel
52 Requires:       hdf5-devel >= 1.8
53 Requires:       libjpeg-devel
54 Requires:       libpng-devel
55 Requires:       libstdc++-devel
56 Requires:       libtiff-devel
57 Obsoletes:      vigra-static
58
59 %description devel
60 Header files needed to compile programs with vigra.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe potrzebne do budowania programów używających
64 biblioteki vigra.
65
66 %package -n python-vigra
67 Summary:        VIGRA Python bindings
68 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
69 Group:          Libraries/Python
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       python-numpy
72 Suggests:       python-PyQt4
73
74 %description -n python-vigra
75 VIGRA Python bindings.
76
77 %description -n python-vigra -l pl.UTF-8
78 Wiązania Pythona do biblioteki VIGRA.
79
80 %package doc
81 Summary:        Development documentation for vigra library
82 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
83 Group:          Documentation
84
85 %description doc
86 Development documentation for vigra library.
87
88 %description doc -l pl.UTF-8
89 Dokumentacja programisty do biblioteki vigra.
90
91 %prep
92 %setup -q
93
94 %build
95 %cmake . \
96         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG"
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
107 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
108 %py_postclean
109
110 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc LICENSE.txt README.txt
121 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.4
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/vigra-config
127 %attr(755,root,root) %{_libdir}/libvigraimpex.so
128 %{_includedir}/vigra
129 %dir %{_libdir}/vigra
130 %{_libdir}/vigra/VigraConfig*.cmake
131 %{_libdir}/vigra/vigra-targets*.cmake
132
133 %files -n python-vigra
134 %defattr(644,root,root,755)
135 %dir %{py_sitedir}/vigra
136 %attr(755,root,root) %{py_sitedir}/vigra/*.so
137 %{py_sitedir}/vigra/*.py[co]
138 %dir %{py_sitedir}/vigra/pyqt
139 %{py_sitedir}/vigra/pyqt/*.py[co]
140
141 %files doc
142 %defattr(644,root,root,755)
143 %doc doc/{vigra,vigranumpy}
This page took 0.124929 seconds and 4 git commands to generate.