]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- release 3
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
3 Name:           vigra
4 Version:        1.6.0
5 Release:        3
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/%{name}%{version}.tar.gz
9 # Source0-md5:  d62650a6f908e85643e557a236ea989c
10 Patch0:         %{name}-ac.patch
11 URL:            http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  fftw3-devel
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  libpng-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  libtool >= 2:1.5
20 #BuildRequires: python
21 #BuildRequires: python-devel
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 VIGRA stands for "Vision with Generic Algorithms". It's a novel
27 computer vision library that puts its main emphasize on customizable
28 algorithms and data structures. By using template techniques similar
29 to those in the C++ Standard Template Library, you can easily adapt
30 any VIGRA component to the needs of your application, without thereby
31 giving up execution speed.
32
33 %description -l pl.UTF-8
34 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
35 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
36 główny nacisk na algorytmy i struktury danych z możliwością
37 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
38 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
39 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
40 bez poświęcania szybkości wykonywania.
41
42 %package devel
43 Summary:        Header files for vigra library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libjpeg-devel
48 Requires:       libpng-devel
49 Requires:       libstdc++-devel
50 Requires:       libtiff-devel
51
52 %description devel
53 Header files needed to compile programs with vigra.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe potrzebne do budowania programów używających
57 biblioteki vigra.
58
59 %package static
60 Summary:        vigra - static library
61 Summary(pl.UTF-8):      Statyczna biblioteka vigra
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static version of vigra library.
67
68 %description static -l pl.UTF-8
69 Statyczna wersja biblioteki vigra.
70
71 %package doc
72 Summary:        Development documentation for vigra library
73 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
74 Group:          Documentation
75
76 %description doc
77 Development documentation for vigra library.
78
79 %description doc -l pl.UTF-8
80 Dokumentacja programisty do biblioteki vigra.
81
82 %prep
83 %setup -q -n %{name}%{version}
84 %patch0 -p1
85
86 tail -n +510 config/acinclude.m4 > acinclude.m4
87 ln -sf config/configure.in .
88
89 %build
90 cp -f /usr/share/automake/config.* config
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %configure \
95         --with-fftw \
96         --with-jpeg \
97         --with-png \
98         --with-tiff \
99         --with-zlib
100
101 #       --with-python requires src/pythonbindings (missing in sources)
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         prefix=$RPM_BUILD_ROOT%{_prefix} \
110         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
111         bindir=$RPM_BUILD_ROOT%{_bindir} \
112         includedir=$RPM_BUILD_ROOT%{_includedir} \
113         libdir=$RPM_BUILD_ROOT%{_libdir} \
114         docdir=`pwd`/docs
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc LICENSE.txt README.txt
125 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.2
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/vigra-config
131 %attr(755,root,root) %{_libdir}/libvigraimpex.so
132 %{_libdir}/libvigraimpex.la
133 %{_includedir}/vigra
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libvigraimpex.a
138
139 %files doc
140 %defattr(644,root,root,755)
141 %doc docs/[!L]*
This page took 0.077436 seconds and 4 git commands to generate.