]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
6eb4c1b0eaaee1c022644318fd1b1a0a495a33ca
[packages/vigra.git] / vigra.spec
1 # TODO: [lib]lemon, WITH_LEMON
2 Summary:        Generic Programming for Computer Vision
3 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
4 Name:           vigra
5 Version:        1.10.0
6 Release:        11
7 License:        MIT
8 Group:          Libraries
9 #Source0Download: http://ukoethe.github.io/vigra/#download
10 Source0:        https://github.com/ukoethe/vigra/releases/download/Version-1-10-0/%{name}-%{version}-src-with-docu.tar.gz
11 # Source0-md5:  85e2968e4ee5f9541b5dd8b3fb9cc433
12 Patch0:         python-install.patch
13 URL:            http://hci.iwr.uni-heidelberg.de/vigra/
14 BuildRequires:  OpenEXR-devel
15 BuildRequires:  boost-python-devel >= 1.40.0
16 BuildRequires:  cmake >= 2.6.0
17 BuildRequires:  doxygen
18 BuildRequires:  fftw3-single-devel
19 BuildRequires:  hdf5-devel >= 1.8
20 BuildRequires:  libjpeg-devel
21 BuildRequires:  libpng-devel >= 2:1.4.0
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtiff-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  python
26 BuildRequires:  python-devel
27 BuildRequires:  python-numpy-devel
28 BuildRequires:  rpmbuild(macros) >= 1.586
29 BuildRequires:  sphinx-pdg
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 VIGRA stands for "Vision with Generic Algorithms". It's a novel
35 computer vision library that puts its main emphasize on customizable
36 algorithms and data structures. By using template techniques similar
37 to those in the C++ Standard Template Library, you can easily adapt
38 any VIGRA component to the needs of your application, without thereby
39 giving up execution speed.
40
41 %description -l pl.UTF-8
42 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
43 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
44 główny nacisk na algorytmy i struktury danych z możliwością
45 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
46 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
47 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
48 bez poświęcania szybkości wykonywania.
49
50 %package devel
51 Summary:        Header files for vigra library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       fftw3-single-devel
56 Requires:       hdf5-devel >= 1.8
57 Requires:       libjpeg-devel
58 Requires:       libpng-devel >= 2:1.4.0
59 Requires:       libstdc++-devel
60 Requires:       libtiff-devel
61 Obsoletes:      vigra-static
62
63 %description devel
64 Header files needed to compile programs with vigra.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe potrzebne do budowania programów używających
68 biblioteki vigra.
69
70 %package -n python-vigra
71 Summary:        VIGRA Python bindings
72 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
73 Group:          Libraries/Python
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       python-numpy
76 Suggests:       python-PyQt4
77
78 %description -n python-vigra
79 VIGRA Python bindings.
80
81 %description -n python-vigra -l pl.UTF-8
82 Wiązania Pythona do biblioteki VIGRA.
83
84 %package -n python-vigra-devel
85 Summary:        Development file for VIGRA Python bindings
86 Summary(pl.UTF-8):      Plik programistyczny wiązań Pythona do biblioteki VIGRA
87 Group:          Development/Libraries
88 Requires:       cmake
89 Requires:       python-vigra = %{version}-%{release}
90
91 %description -n python-vigra-devel
92 Development (cmake config) file for VIGRA Python bindings.
93
94 %description -n python-vigra-devel -l pl.UTF-8
95 Plik programistyczny (konfiguracja cmake'a) dla wiązań Pythona do
96 biblioteki VIGRA.
97
98 %package doc
99 Summary:        Development documentation for vigra library
100 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
101 Group:          Documentation
102
103 %description doc
104 Development documentation for vigra library.
105
106 %description doc -l pl.UTF-8
107 Dokumentacja programisty do biblioteki vigra.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %build
114 %cmake . \
115         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
116         -DWITH_BOOST_GRAPH=ON \
117         -DWITH_OPENEXR=ON
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
128 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
129 %py_postclean
130
131 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc LICENSE.txt README.md
142 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.5
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/vigra-config
148 %attr(755,root,root) %{_libdir}/libvigraimpex.so
149 %{_includedir}/vigra
150 %dir %{_libdir}/vigra
151 %{_libdir}/vigra/VigraConfig*.cmake
152 %{_libdir}/vigra/vigra-targets*.cmake
153
154 %files -n python-vigra
155 %defattr(644,root,root,755)
156 %dir %{py_sitedir}/vigra
157 %attr(755,root,root) %{py_sitedir}/vigra/*.so
158 %{py_sitedir}/vigra/*.py[co]
159 %dir %{py_sitedir}/vigra/pyqt
160 %{py_sitedir}/vigra/pyqt/*.py[co]
161
162 %files -n python-vigra-devel
163 %defattr(644,root,root,755)
164 %dir %{_libdir}/vigranumpy
165 %{_libdir}/vigranumpy/VigranumpyConfig.cmake
166
167 %files doc
168 %defattr(644,root,root,755)
169 %doc doc/{vigra,vigranumpy}
This page took 0.059172 seconds and 2 git commands to generate.