]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
690e07b5035b5c0fcb1324e523c45dd02c60ed28
[packages/vigra.git] / vigra.spec
1 # TODO: lemon support, WITH_LEMON
2 Summary:        Generic Programming for Computer Vision
3 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
4 Name:           vigra
5 Version:        1.11.1
6 Release:        5
7 License:        MIT
8 Group:          Libraries
9 #Source0Download: http://ukoethe.github.io/vigra/#download
10 Source0:        https://github.com/ukoethe/vigra/releases/download/Version-1-11-1/%{name}-%{version}-src.tar.gz
11 # Source0-md5:  e72faf9fb82fa71fa63ba064bb63b703
12 Patch0:         python-install.patch
13 Patch1:         boost-python.patch
14 # https://src.fedoraproject.org/rpms/vigra/raw/master/f/81958d302494e137f98a8b1d7869841532f90388.patch
15 Patch2:         %{name}-multi_convolution.patch
16 URL:            http://ukoethe.github.io/vigra/
17 BuildRequires:  OpenEXR-devel
18 BuildRequires:  boost-python-devel >= 1.40.0
19 BuildRequires:  cmake >= 2.6.0
20 BuildRequires:  doxygen
21 BuildRequires:  fftw3-single-devel
22 BuildRequires:  hdf5-devel >= 1.8
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel >= 2:1.4.0
25 BuildRequires:  libstdc++-devel >= 6:4.4
26 BuildRequires:  libtiff-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python
29 BuildRequires:  python-devel
30 BuildRequires:  python-numpy-devel
31 BuildRequires:  rpmbuild(macros) >= 1.586
32 BuildRequires:  sphinx-pdg
33 BuildRequires:  zlib-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 VIGRA stands for "Vision with Generic Algorithms". It's a novel
38 computer vision library that puts its main emphasize on customizable
39 algorithms and data structures. By using template techniques similar
40 to those in the C++ Standard Template Library, you can easily adapt
41 any VIGRA component to the needs of your application, without thereby
42 giving up execution speed.
43
44 %description -l pl.UTF-8
45 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
46 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
47 główny nacisk na algorytmy i struktury danych z możliwością
48 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
49 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
50 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
51 bez poświęcania szybkości wykonywania.
52
53 %package devel
54 Summary:        Header files for vigra library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       fftw3-single-devel
59 Requires:       hdf5-devel >= 1.8
60 Requires:       libjpeg-devel
61 Requires:       libpng-devel >= 2:1.4.0
62 Requires:       libstdc++-devel
63 Requires:       libtiff-devel
64 Obsoletes:      vigra-static
65
66 %description devel
67 Header files needed to compile programs with vigra.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe potrzebne do budowania programów używających
71 biblioteki vigra.
72
73 %package -n python-vigra
74 Summary:        VIGRA Python bindings
75 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
76 Group:          Libraries/Python
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       python-numpy
79 Suggests:       python-PyQt4
80
81 %description -n python-vigra
82 VIGRA Python bindings.
83
84 %description -n python-vigra -l pl.UTF-8
85 Wiązania Pythona do biblioteki VIGRA.
86
87 %package -n python-vigra-devel
88 Summary:        Development file for VIGRA Python bindings
89 Summary(pl.UTF-8):      Plik programistyczny wiązań Pythona do biblioteki VIGRA
90 Group:          Development/Libraries
91 Requires:       cmake
92 Requires:       python-vigra = %{version}-%{release}
93
94 %description -n python-vigra-devel
95 Development (cmake config) file for VIGRA Python bindings.
96
97 %description -n python-vigra-devel -l pl.UTF-8
98 Plik programistyczny (konfiguracja cmake'a) dla wiązań Pythona do
99 biblioteki VIGRA.
100
101 %package doc
102 Summary:        Development documentation for vigra library
103 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
104 Group:          Documentation
105
106 %description doc
107 Development documentation for vigra library.
108
109 %description doc -l pl.UTF-8
110 Dokumentacja programisty do biblioteki vigra.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117
118 %build
119 %cmake . \
120         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
121         -DWITH_BOOST_GRAPH=ON \
122         -DWITH_OPENEXR=ON
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
133 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
134 %py_postclean
135
136 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc LICENSE.txt README.md
147 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.11
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/vigra-config
153 %attr(755,root,root) %{_libdir}/libvigraimpex.so
154 %{_includedir}/vigra
155 %dir %{_libdir}/vigra
156 %{_libdir}/vigra/VigraConfig*.cmake
157 %{_libdir}/vigra/vigra-targets*.cmake
158
159 %files -n python-vigra
160 %defattr(644,root,root,755)
161 %dir %{py_sitedir}/vigra
162 %attr(755,root,root) %{py_sitedir}/vigra/*.so
163 %{py_sitedir}/vigra/*.py[co]
164 %dir %{py_sitedir}/vigra/pyqt
165 %{py_sitedir}/vigra/pyqt/*.py[co]
166
167 %files -n python-vigra-devel
168 %defattr(644,root,root,755)
169 %dir %{_libdir}/vigranumpy
170 %{_libdir}/vigranumpy/VigranumpyConfig.cmake
171
172 %files doc
173 %defattr(644,root,root,755)
174 %doc doc/{vigra,vigranumpy}
This page took 0.059334 seconds and 2 git commands to generate.