]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- release 9 (by relup.sh)
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
3 Name:           vigra
4 Version:        1.8.0
5 Release:        9
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://hci.iwr.uni-heidelberg.de/vigra/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  15c5544448e529ee60020758ab6be264
10 URL:            http://hci.iwr.uni-heidelberg.de/vigra/
11 Patch0:         %{name}-lib_suffix.patch
12 Patch1:         %{name}-gcc47.patch
13 BuildRequires:  boost-python-devel >= 1.40.0
14 BuildRequires:  cmake >= 2.6.0
15 BuildRequires:  doxygen
16 BuildRequires:  fftw3-single-devel
17 BuildRequires:  hdf5-devel >= 1.8
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel >= 1.4.0
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  python
24 BuildRequires:  python-devel
25 BuildRequires:  python-numpy-devel
26 BuildRequires:  rpmbuild(macros) >= 1.586
27 BuildRequires:  sphinx-pdg
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 VIGRA stands for "Vision with Generic Algorithms". It's a novel
33 computer vision library that puts its main emphasize on customizable
34 algorithms and data structures. By using template techniques similar
35 to those in the C++ Standard Template Library, you can easily adapt
36 any VIGRA component to the needs of your application, without thereby
37 giving up execution speed.
38
39 %description -l pl.UTF-8
40 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
41 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
42 główny nacisk na algorytmy i struktury danych z możliwością
43 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
44 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
45 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
46 bez poświęcania szybkości wykonywania.
47
48 %package devel
49 Summary:        Header files for vigra library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       fftw3-single-devel
54 Requires:       hdf5-devel >= 1.8
55 Requires:       libjpeg-devel
56 Requires:       libpng-devel
57 Requires:       libstdc++-devel
58 Requires:       libtiff-devel
59 Obsoletes:      vigra-static
60
61 %description devel
62 Header files needed to compile programs with vigra.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe potrzebne do budowania programów używających
66 biblioteki vigra.
67
68 %package -n python-vigra
69 Summary:        VIGRA Python bindings
70 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
71 Group:          Libraries/Python
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       python-numpy
74 Suggests:       python-PyQt4
75
76 %description -n python-vigra
77 VIGRA Python bindings.
78
79 %description -n python-vigra -l pl.UTF-8
80 Wiązania Pythona do biblioteki VIGRA.
81
82 %package doc
83 Summary:        Development documentation for vigra library
84 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
85 Group:          Documentation
86
87 %description doc
88 Development documentation for vigra library.
89
90 %description doc -l pl.UTF-8
91 Dokumentacja programisty do biblioteki vigra.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97
98 %build
99 %cmake . \
100         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG"
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
111 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
112 %py_postclean
113
114 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc LICENSE.txt README.txt
125 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.4
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/vigra-config
131 %attr(755,root,root) %{_libdir}/libvigraimpex.so
132 %{_includedir}/vigra
133 %dir %{_libdir}/vigra
134 %{_libdir}/vigra/VigraConfig*.cmake
135 %{_libdir}/vigra/vigra-targets*.cmake
136
137 %files -n python-vigra
138 %defattr(644,root,root,755)
139 %dir %{py_sitedir}/vigra
140 %attr(755,root,root) %{py_sitedir}/vigra/*.so
141 %{py_sitedir}/vigra/*.py[co]
142 %dir %{py_sitedir}/vigra/pyqt
143 %{py_sitedir}/vigra/pyqt/*.py[co]
144
145 %files doc
146 %defattr(644,root,root,755)
147 %doc doc/{vigra,vigranumpy}
This page took 0.078254 seconds and 3 git commands to generate.