]> git.pld-linux.org Git - packages/vice.git/blob - vice.spec
89facb702c31110355c9e39bd4770c58530ae391
[packages/vice.git] / vice.spec
1 # TODO
2 # - fonts-TTF-CBM subpackage:
3 #   %{_fontsdir}/TTF/CBM.ttf
4 #
5 # Conditional build:
6 %bcond_without  pulseaudio      # pulseaudio support
7 #
8 Summary:        Versatile Commodore Emulator
9 Summary(pl.UTF-8):      Uniwersalny emulator Commodore
10 Name:           vice
11 Version:        3.3
12 Release:        2
13 License:        GPL v2+
14 Group:          Applications/Emulators
15 Source0:        http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/%{name}-%{version}.tar.gz
16 # Source0-md5:  b0797f534b33f638220418207d606cf5
17 Source1:        %{name}-c128.desktop
18 Source2:        %{name}-c64.desktop
19 Source3:        %{name}-cbm2.desktop
20 Source4:        %{name}-pet.desktop
21 Source5:        %{name}-plus4.desktop
22 Source6:        %{name}-vic20.desktop
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-fonts.patch
25 URL:            http://vice-emu.sourceforge.net/
26 BuildRequires:  OpenGL-GLX-devel
27 BuildRequires:  SDL-devel >= 1.2.0
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  bison
32 BuildRequires:  ffmpeg-devel
33 BuildRequires:  flac-devel
34 BuildRequires:  flex
35 BuildRequires:  fontconfig-devel
36 BuildRequires:  giflib-devel
37 BuildRequires:  gtk+3-devel
38 BuildRequires:  gtkglext-devel
39 BuildRequires:  lame-libs-devel
40 BuildRequires:  libieee1284-devel
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libmpg123-devel
43 BuildRequires:  libogg-devel
44 BuildRequires:  libpng-devel
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libvorbis-devel
47 BuildRequires:  linux-libc-headers
48 BuildRequires:  perl-base
49 BuildRequires:  pkgconfig
50 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
51 BuildRequires:  readline-devel
52 BuildRequires:  texinfo
53 BuildRequires:  vte-devel
54 BuildRequires:  xa
55 BuildRequires:  xorg-app-bdftopcf
56 BuildRequires:  xorg-app-mkfontdir
57 BuildRequires:  xorg-lib-libX11-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXrandr-devel
60 BuildRequires:  xorg-lib-libXv-devel
61 BuildRequires:  xorg-lib-libXxf86dga-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 Requires(post,postun):  fontpostinst >= 0.1-6
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 VICE is a Versatile Commodore Emulator, i.e. a program that runs on a
68 Unix, MS-DOS, Win95/NT, OS/2, RiscOS or BeOS machine and executes
69 programs intended for the old 8-bit Commodore computers. The current
70 version emulates the C64, the C128 (80 column screen is included now),
71 the VIC20, all the PET models (except the SuperPET 9000, which is out
72 of line anyway), CBM-II (aka C610) and the Plus4.
73
74 %description -l pl.UTF-8
75 VICE jest wszechstronnym emulatorem 8-bitowego komputera Commodore.
76 Aktualna wersja emuluje C64, C128 (wraz z trybem pracy 80 kolumnowym),
77 VIC20, wszystkie modele PET (poza SuperPET 9000, który zresztą nie
78 pasował do tej linii), CBM-II (C610) oraz Plus4.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %{__perl} -i -pe 's@\$\(VICEDIR\)/fonts@%{_fontsdir}/misc@' data/fonts/Makefile.am
85
86 %build
87 %{__aclocal} -I m4
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 cd src/resid
92 %{__autoconf}
93 cd ../..
94 export CFLAGS="%{rpmcflags} -fcommon"
95 %configure \
96         DOS2UNIX=/usr/bin/dos2unix \
97         --libdir=%{_datadir} \
98         %{?with_pulseaudio:--with-pulse} \
99         --enable-libieee1284 \
100         --enable-native-gtk3ui \
101         --with-sdlsound \
102         --enable-external-ffmpeg \
103         --enable-ethernet \
104         --with-x
105
106 # contains some C++ code included as "old" library (.a), so libtool can't detect it
107 %{__make} \
108         CCLD="%{__cxx}"
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
113
114 %{__perl} -i -pe 's/SUBDIRS = html\n//' doc/Makefile
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT \
117         VICEDIR="%{_datadir}/%{name}"
118
119 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/vice/doc
120 # ?
121 #ln -sf %{_docdir}/%{name}-%{version}/html $RPM_BUILD_ROOT%{_datadir}/vice/doc
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
124 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
125 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
126 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
127 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
128 install %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}
129
130 install -d $RPM_BUILD_ROOT%{_fontsdir}/TTF
131 mv $RPM_BUILD_ROOT%{_fontsdir}/{misc,TTF}/CBM.ttf
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 fontpostinst TTF
138 fontpostinst misc
139 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
140
141 %postun
142 fontpostinst TTF
143 fontpostinst misc
144 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog FEEDBACK NEWS README doc/iec-bus.txt doc/html
149 %attr(755,root,root) %{_bindir}/c1541
150 %attr(755,root,root) %{_bindir}/cartconv
151 %attr(755,root,root) %{_bindir}/petcat
152 %attr(755,root,root) %{_bindir}/vsid
153 %attr(755,root,root) %{_bindir}/x128
154 %attr(755,root,root) %{_bindir}/x64
155 %attr(755,root,root) %{_bindir}/x64dtv
156 %attr(755,root,root) %{_bindir}/x64sc
157 %attr(755,root,root) %{_bindir}/xcbm2
158 %attr(755,root,root) %{_bindir}/xcbm5x0
159 %attr(755,root,root) %{_bindir}/xpet
160 %attr(755,root,root) %{_bindir}/xplus4
161 %attr(755,root,root) %{_bindir}/xscpu64
162 %attr(755,root,root) %{_bindir}/xvic
163 %{_datadir}/vice
164 %{_fontsdir}/misc/vice-cbm.bdf
165 %{_fontsdir}/TTF/CBM.ttf
166 %{_mandir}/man1/cartconv.1*
167 %{_mandir}/man1/c1541.1*
168 %{_mandir}/man1/petcat.1*
169 %{_mandir}/man1/vice.1*
170 %{_infodir}/vice.info*
171 %{_desktopdir}/vice-*.desktop
This page took 0.037996 seconds and 2 git commands to generate.