]> git.pld-linux.org Git - packages/varnish-libvmod-crashhandler.git/blob - varnish-libvmod-crashhandler.spec
up to 1.1.0
[packages/varnish-libvmod-crashhandler.git] / varnish-libvmod-crashhandler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define vmod    crashhandler
6 Summary:        Crash handler for Varnish
7 Name:           varnish-libvmod-%{vmod}
8 Version:        1.1.0
9 Release:        1
10 License:        BSD
11 Group:          Daemons
12 Source0:        https://github.com/varnish/libvmod-crashhandler/archive/%{version}/%{vmod}-%{version}.tar.gz
13 # Source0-md5:  4e0541f405565b2c91f2bc7c1393e1e3
14 URL:            https://github.com/varnish/libvmod-crashhandler
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  python-docutils
19 BuildRequires:  varnish-source
20 %{?with_tests:BuildRequires:    varnish}
21 %requires_eq_to varnish varnish-source
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         vmoddir %(pkg-config --variable=vmoddir varnishapi || echo ERROR)
25
26 %description
27 Varnish 3.0 Module that catches segfaults (SIGSEGV) and issues the
28 regular panic code to get a back trace.
29
30 Also includes a function to trigger a segfault forcibly. Use at your
31 own peril.
32
33 %prep
34 %setup -qc
35 mv libvmod-%{vmod}-*/* .
36
37 %build
38 %{__aclocal} -I m4
39 %{__libtoolize}
40 %{__autoheader}
41 %{__automake}
42 %{__autoconf}
43
44 VARNISHSRC=$(pkg-config --variable=srcdir varnishapi)
45 %configure \
46         VARNISHSRC=$VARNISHSRC \
47         VMODDIR=%{vmoddir} \
48         --disable-static
49
50 %{__make} -j1
51 %{?with_tests:%{__make} check}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %{__rm} $RPM_BUILD_ROOT%{_libdir}/varnish/vmods/libvmod_%{vmod}.la
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README.rst LICENSE
66 %attr(755,root,root) %{vmoddir}/libvmod_%{vmod}.so
67 %{_mandir}/man3/vmod_%{vmod}.3*
This page took 0.068119 seconds and 3 git commands to generate.