]> git.pld-linux.org Git - packages/vapoursynth.git/blob - vapoursynth.spec
- updated to 65 (C++17 now)
[packages/vapoursynth.git] / vapoursynth.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # documentation
4 %bcond_with     sse             # use SSE/SSE2 instructions on x86 (no runtime detection)
5 %bcond_without  static_libs     # static libraries
6 #
7 %ifarch pentium4 %{x8664}
8 # x32 asm is not supported (as of 38)
9 %define with_sse        1
10 %endif
11 Summary:        A video processing framework with simplicity in mind
12 Summary(pl.UTF-8):      Szkielet do przetwarzania obrazu stworzony z myślą o prostocie
13 Name:           vapoursynth
14 Version:        65
15 Release:        1
16 License:        LGPL v2.1+
17 Group:          Libraries
18 #Source0Download: https://github.com/vapoursynth/vapoursynth/releases
19 Source0:        https://github.com/vapoursynth/vapoursynth/archive/R%{version}/%{name}-R%{version}.tar.gz
20 # Source0-md5:  705d8451764faceec82752ebbabdc643
21 Patch0:         %{name}-sse2.patch
22 URL:            http://www.vapoursynth.com/
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  libstdc++-devel >= 6:7
26 BuildRequires:  libtool >= 2:2
27 %if %{with sse}
28 BuildRequires:  nasm
29 %endif
30 BuildRequires:  pkgconfig
31 BuildRequires:  python3-Cython
32 BuildRequires:  python3-devel >= 1:3.2
33 BuildRequires:  rpm-build >= 4.6
34 BuildRequires:  rpmbuild(macros) >= 1.752
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  zimg-devel >= 2.5
37 %if %{with doc}
38 BuildRequires:  python3-sphinx_rtd_theme
39 BuildRequires:  sphinx-pdg-3
40 %endif
41 %if %{with sse}
42 Requires:       cpuinfo(sse2)
43 %endif
44 Requires:       python3-libs >= 1:3.2
45 Requires:       zimg >= 2.5
46 Obsoletes:      vapoursynth-plugin-imwri < 54-5
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 # non-function std::__once_call, std::__once_callable symbols
50 %define         skip_post_check_so      libvapoursynth-script.so.*
51
52 %description
53 VapourSynth is an application for video manipulation. Or a plugin. Or
54 a library. It's hard to tell  because it has a core library written in
55 C++ and a Python module to allow video scripts to be created.
56
57 %description -l pl.UTF-8
58 VapourSynth to aplikacja do obróbki obrazu. Albo wtyczka. Albo
59 biblioteka. Trudno stwierdzić, ponieważ ma główną bibliotekę napisaną
60 w C++ oraz moduł Pythona pozwalający na tworzenie skryptów do obrazu.
61
62 %package devel
63 Summary:        Header files for VapourSynth libraries
64 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek VapourSynth
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       python3-devel >= 1:3.2
68 Requires:       zimg-devel >= 2.5
69
70 %description devel
71 Header files for VapourSynth libraries.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe bibliotek VapourSynth.
75
76 %package static
77 Summary:        Static VapourSynth libraries
78 Summary(pl.UTF-8):      Statyczne biblioteki VapourSynth
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static VapourSynth libraries.
84
85 %description static -l pl.UTF-8
86 Statyczne biblioteki VapourSynth.
87
88 %package doc
89 Summary:        Documentation for VapourSynth library
90 Summary(pl.UTF-8):      Dokumentacja do biblioteki VapourSynth
91 Group:          Documentation
92 BuildArch:      noarch
93
94 %description doc
95 Documentation for VapourSynth library.
96
97 %description doc -l pl.UTF-8
98 Dokumentacja do biblioteki VapourSynth.
99
100 %prep
101 %setup -q -n %{name}-R%{version}
102 %patch0 -p1
103
104 %if %{without sse}
105 %{__sed} -i -e 's/"-mfpmath=sse -msse2"/""/' configure.ac
106 %endif
107
108 %build
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoconf}
112 %{__automake}
113 %configure \
114         --disable-silent-rules \
115         %{!?with_static_libs:--disable-static} \
116         %{!?with_sse:--disable-x86-asm}
117 %{__make}
118
119 %if %{with doc}
120 sphinx-build-3 -b html doc doc/_build/html
121 %endif
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_libdir}/vapoursynth
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/vapoursynth.la
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvapoursynth*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc ChangeLog README.md
143 %attr(755,root,root) %{_bindir}/vspipe
144 %attr(755,root,root) %{_libdir}/libvapoursynth.so
145 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libvapoursynth-script.so.0
147 %attr(755,root,root) %{py3_sitedir}/vapoursynth.so
148 %dir %{_libdir}/vapoursynth
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so
153 %{_includedir}/vapoursynth
154 %{_pkgconfigdir}/vapoursynth.pc
155 %{_pkgconfigdir}/vapoursynth-script.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libvapoursynth.a
161 %{_libdir}/libvapoursynth-script.a
162 %endif
163
164 %if %{with doc}
165 %files doc
166 %defattr(644,root,root,755)
167 %doc doc/_build/html/{_static,functions,*.html,*.js}
168 %endif
This page took 0.072288 seconds and 4 git commands to generate.