]> git.pld-linux.org Git - packages/vapoursynth.git/blob - vapoursynth.spec
- rel 1
[packages/vapoursynth.git] / vapoursynth.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # documentation
4 %bcond_without  ffmpeg          # subtext plugin (libass+ffmpeg based)
5 %bcond_with     im              # imwri plugin (requires ImageMagick with Q16 or Q32 and HDRI support)
6 %bcond_with     sse             # use SSE/SSE2 instructions on x86 (no runtime detection)
7 %bcond_without  static_libs     # static libraries
8 #
9 %ifarch pentium4 %{x8664}
10 # x32 asm is not supported (as of 38)
11 %define with_sse        1
12 %endif
13 Summary:        A video processing framework with simplicity in mind
14 Summary(pl.UTF-8):      Szkielet do przetwarzania obrazu stworzony z myślą o prostocie
15 Name:           vapoursynth
16 Version:        47.2
17 Release:        1
18 License:        LGPL v2.1+
19 Group:          Libraries
20 #Source0Download: https://github.com/vapoursynth/vapoursynth/releases
21 Source0:        https://github.com/vapoursynth/vapoursynth/archive/R%{version}/%{name}-%{version}.tar.gz
22 # Source0-md5:  14425426a841d34d303620537b19eee3
23 Patch0:         %{name}-genericarch.patch
24 Patch1:         python-3.8.patch
25 URL:            http://www.vapoursynth.com/
26 %{?with_im:BuildRequires:       ImageMagick-c++-devel >= 1:7}
27 BuildRequires:  autoconf >= 2.50
28 BuildRequires:  automake >= 1:1.11
29 # libavcodec libavformat libavutil
30 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
31 %{?with_ffmpeg:BuildRequires:   libass-devel}
32 BuildRequires:  libstdc++-devel >= 6:4.8
33 BuildRequires:  libtool >= 2:2
34 %if %{with sse}
35 BuildRequires:  nasm
36 %endif
37 BuildRequires:  pkgconfig
38 BuildRequires:  python3-Cython
39 BuildRequires:  python3-devel >= 1:3.2
40 BuildRequires:  sed >= 4.0
41 %{?with_doc:BuildRequires:      sphinx-pdg}
42 BuildRequires:  tesseract-devel >= 3
43 BuildRequires:  zimg-devel >= 2.5
44 %if %{with sse}
45 Requires:       cpuinfo(sse2)
46 %endif
47 Requires:       python3-libs >= 1:3.2
48 Requires:       zimg >= 2.5
49 %if %{without im}
50 Obsoletes:      vapoursynth-plugin-imwri
51 %endif
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 # non-function std::__once_call, std::__once_callable symbols
55 %define         skip_post_check_so      libvapoursynth-script.so.*
56
57 %description
58 VapourSynth is an application for video manipulation. Or a plugin. Or
59 a library. It's hard to tell  because it has a core library written in
60 C++ and a Python module to allow video scripts to be created.
61
62 %description -l pl.UTF-8
63 VapourSynth to aplikacja do obróbki obrazu. Albo wtyczka. Albo
64 biblioteka. Trudno stwierdzić, ponieważ ma główną bibliotekę napisaną
65 w C++ oraz moduł Pythona pozwalający na tworzenie skryptów do obrazu.
66
67 %package plugin-imwri
68 Summary:        Image reader/writer plugin for VapourSynth
69 Summary(pl.UTF-8):      Wtyczka VapourSynth odczytująca i zapisują obrazy
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description plugin-imwri
74 Image reader/writer plugin for VapourSynth.
75
76 %description plugin-imwri -l pl.UTF-8
77 Wtyczka VapourSynth odczytująca i zapisują obrazy.
78
79 %package plugin-ocr
80 Summary:        OCR plugin for VapourSynth
81 Summary(pl.UTF-8):      Wtyczka OCR dla VapourSyntha
82 Group:          Libraries
83 Requires:       %{name} = %{version}-%{release}
84
85 %description plugin-ocr
86 OCR plugin for VapourSynth.
87
88 %description plugin-ocr -l pl.UTF-8
89 Wtyczka OCR dla VapourSyntha.
90
91 %package plugin-subtext
92 Summary:        Subtitle rendering plugin for VapourSynth
93 Summary(pl.UTF-8):      Wtyczka VapourSynth nanosząca podpisy
94 Group:          Libraries
95 Requires:       %{name} = %{version}-%{release}
96
97 %description plugin-subtext
98 Subtitle rendering plugin for VapourSynth.
99
100 %description plugin-subtext -l pl.UTF-8
101 Wtyczka VapourSynth nanosząca podpisy.
102
103 %package devel
104 Summary:        Header files for VapourSynth libraries
105 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek VapourSynth
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       python3-devel >= 1:3.2
109 Requires:       zimg-devel >= 2.5
110
111 %description devel
112 Header files for VapourSynth libraries.
113
114 %description devel -l pl.UTF-8
115 Pliki nagłówkowe bibliotek VapourSynth.
116
117 %package static
118 Summary:        Static VapourSynth libraries
119 Summary(pl.UTF-8):      Statyczne biblioteki VapourSynth
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Static VapourSynth libraries.
125
126 %description static -l pl.UTF-8
127 Statyczne biblioteki VapourSynth.
128
129 %package doc
130 Summary:        Documentation for VapourSynth library
131 Summary(pl.UTF-8):      Dokumentacja do biblioteki VapourSynth
132 Group:          Documentation
133 %if "%{_rpmversion}" >= "5"
134 BuildArch:      noarch
135 %endif
136
137 %description doc
138 Documentation for VapourSynth library.
139
140 %description doc -l pl.UTF-8
141 Dokumentacja do biblioteki VapourSynth.
142
143 %prep
144 %setup -q -n %{name}-R%{version}
145 %patch0 -p1
146 %patch1 -p1
147
148 %if %{without sse}
149 %{__sed} -i -e 's/"-mfpmath=sse -msse2"/""/' configure.ac
150 %endif
151
152 %build
153 %{__libtoolize}
154 %{__aclocal}
155 %{__autoconf}
156 %{__automake}
157 %configure \
158         %{!?with_im:--disable-imwri} \
159         --disable-silent-rules \
160         %{!?with_ffmpeg:--disable-subtext} \
161         %{!?with_static_libs:--disable-static} \
162         %{!?with_sse:--disable-x86-asm}
163 %{__make}
164
165 %if %{with doc}
166 %{__make} -C doc html
167 %endif
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/vapoursynth.la
176 # obsoleted by pkg-config
177 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvapoursynth*.la
178 # dlopened modules
179 %{__rm} $RPM_BUILD_ROOT%{_libdir}/vapoursynth/*.la
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc ChangeLog ofl.txt
190 %attr(755,root,root) %{_bindir}/vspipe
191 %attr(755,root,root) %{_libdir}/libvapoursynth.so
192 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so.*.*.*
193 %attr(755,root,root) %ghost %{_libdir}/libvapoursynth-script.so.0
194 %attr(755,root,root) %{py3_sitedir}/vapoursynth.so
195 %dir %{_libdir}/vapoursynth
196 %attr(755,root,root) %{_libdir}/vapoursynth/libeedi3.so
197 %attr(755,root,root) %{_libdir}/vapoursynth/libmiscfilters.so
198 %attr(755,root,root) %{_libdir}/vapoursynth/libmorpho.so
199 %attr(755,root,root) %{_libdir}/vapoursynth/libremovegrain.so
200 %attr(755,root,root) %{_libdir}/vapoursynth/libvinverse.so
201 %attr(755,root,root) %{_libdir}/vapoursynth/libvivtc.so
202
203 %if %{with im}
204 %files plugin-imwri
205 %defattr(644,root,root,755)
206 # R: ImageMagick-c++ >= 1:7
207 %attr(755,root,root) %{_libdir}/vapoursynth/libimwri.so
208 %endif
209
210 %files plugin-ocr
211 %defattr(644,root,root,755)
212 # R: tesseract
213 %attr(755,root,root) %{_libdir}/vapoursynth/libocr.so
214
215 %if %{with ffmpeg}
216 %files plugin-subtext
217 %defattr(644,root,root,755)
218 # R: libass ffmpeg
219 %attr(755,root,root) %{_libdir}/vapoursynth/libsubtext.so
220 %endif
221
222 %files devel
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so
225 %{_includedir}/vapoursynth
226 %{_pkgconfigdir}/vapoursynth.pc
227 %{_pkgconfigdir}/vapoursynth-script.pc
228
229 %if %{with static_libs}
230 %files static
231 %defattr(644,root,root,755)
232 %{_libdir}/libvapoursynth.a
233 %{_libdir}/libvapoursynth-script.a
234 %endif
235
236 %if %{with doc}
237 %files doc
238 %defattr(644,root,root,755)
239 %doc doc/_build/html/{_static,api,functions,plugins,*.html,*.js}
240 %endif
This page took 0.138536 seconds and 3 git commands to generate.