]> git.pld-linux.org Git - packages/vapoursynth.git/blob - vapoursynth.spec
5a99453bcbdda0464a5e5382c9402d7d226233d1
[packages/vapoursynth.git] / vapoursynth.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # documentation
4 %bcond_without  ffmpeg          # subtext plugin (libass+ffmpeg based)
5 %bcond_with     sse             # use SSE/SSE2 instructions on x86 (no runtime detection)
6 %bcond_without  static_libs     # static libraries
7 #
8 %ifarch pentium4 %{x8664}
9 # x32 asm is not supported (as of 38)
10 %define with_sse        1
11 %endif
12 Summary:        A video processing framework with simplicity in mind
13 Summary(pl.UTF-8):      Szkielet do przetwarzania obrazu stworzony z myślą o prostocie
14 Name:           vapoursynth
15 Version:        38
16 Release:        6
17 License:        LGPL v2.1+
18 Group:          Libraries
19 #Source0Download: https://github.com/vapoursynth/vapoursynth/releases
20 Source0:        https://github.com/vapoursynth/vapoursynth/archive/R%{version}/%{name}-%{version}.tar.gz
21 # Source0-md5:  78d0183f0afd3702f3edc176b2491f5d
22 Patch0:         %{name}-genericarch.patch
23 URL:            http://www.vapoursynth.com/
24 BuildRequires:  ImageMagick-c++-devel >= 1:7
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake >= 1:1.11
27 # libavcodec libavformat libavutil
28 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
29 %{?with_ffmpeg:BuildRequires:   libass-devel}
30 BuildRequires:  libstdc++-devel >= 6:4.8
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  pkgconfig
33 BuildRequires:  python3-Cython
34 BuildRequires:  python3-devel >= 1:3.2
35 BuildRequires:  sed >= 4.0
36 %{?with_doc:BuildRequires:      sphinx-pdg}
37 BuildRequires:  tesseract-devel >= 3
38 %if %{with sse}
39 BuildRequires:  yasm
40 %endif
41 BuildRequires:  zimg-devel >= 2.5
42 %if %{with sse}
43 Requires:       cpuinfo(sse2)
44 %endif
45 Requires:       python3-libs >= 1:3.2
46 Requires:       zimg >= 2.5
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 # non-function std::__once_call, std::__once_callable symbols
50 %define         skip_post_check_so      libvapoursynth-script.so.*
51
52 %description
53 VapourSynth is an application for video manipulation. Or a plugin. Or
54 a library. It's hard to tell  because it has a core library written in
55 C++ and a Python module to allow video scripts to be created.
56
57 %description -l pl.UTF-8
58 VapourSynth to aplikacja do obróbki obrazu. Albo wtyczka. Albo
59 biblioteka. Trudno stwierdzić, ponieważ ma główną bibliotekę napisaną
60 w C++ oraz moduł Pythona pozwalający na tworzenie skryptów do obrazu.
61
62 %package plugin-imwri
63 Summary:        Image reader/writer plugin for VapourSynth
64 Summary(pl.UTF-8):      Wtyczka VapourSynth odczytująca i zapisują obrazy
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description plugin-imwri
69 Image reader/writer plugin for VapourSynth.
70
71 %description plugin-imwri -l pl.UTF-8
72 Wtyczka VapourSynth odczytująca i zapisują obrazy.
73
74 %package plugin-ocr
75 Summary:        OCR plugin for VapourSynth
76 Summary(pl.UTF-8):      Wtyczka OCR dla VapourSyntha
77 Group:          Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description plugin-ocr
81 OCR plugin for VapourSynth.
82
83 %description plugin-ocr -l pl.UTF-8
84 Wtyczka OCR dla VapourSyntha.
85
86 %package plugin-subtext
87 Summary:        Subtitle rendering plugin for VapourSynth
88 Summary(pl.UTF-8):      Wtyczka VapourSynth nanosząca podpisy
89 Group:          Libraries
90 Requires:       %{name} = %{version}-%{release}
91
92 %description plugin-subtext
93 Subtitle rendering plugin for VapourSynth.
94
95 %description plugin-subtext -l pl.UTF-8
96 Wtyczka VapourSynth nanosząca podpisy.
97
98 %package devel
99 Summary:        Header files for VapourSynth libraries
100 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek VapourSynth
101 Group:          Development/Libraries
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       python3-devel >= 1:3.2
104 Requires:       zimg-devel >= 2.5
105
106 %description devel
107 Header files for VapourSynth libraries.
108
109 %description devel -l pl.UTF-8
110 Pliki nagłówkowe bibliotek VapourSynth.
111
112 %package static
113 Summary:        Static VapourSynth libraries
114 Summary(pl.UTF-8):      Statyczne biblioteki VapourSynth
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117
118 %description static
119 Static VapourSynth libraries.
120
121 %description static -l pl.UTF-8
122 Statyczne biblioteki VapourSynth.
123
124 %package doc
125 Summary:        Documentation for VapourSynth library
126 Summary(pl.UTF-8):      Dokumentacja do biblioteki VapourSynth
127 Group:          Documentation
128 %if "%{_rpmversion}" >= "5"
129 BuildArch:      noarch
130 %endif
131
132 %description doc
133 Documentation for VapourSynth library.
134
135 %description doc -l pl.UTF-8
136 Dokumentacja do biblioteki VapourSynth.
137
138 %prep
139 %setup -q -n %{name}-R%{version}
140 %patch0 -p1
141
142 %if %{without sse}
143 %{__sed} -i -e 's/"-mfpmath=sse -msse2"/""/' configure.ac
144 %endif
145
146 %build
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__automake}
151 %configure \
152         --disable-silent-rules \
153         %{!?with_ffmpeg:--disable-subtext} \
154         %{!?with_static_libs:--disable-static} \
155         %{!?with_sse:--disable-x86-asm}
156 %{__make}
157
158 %if %{with doc}
159 %{__make} -C doc html
160 %endif
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/vapoursynth.la
169 # obsoleted by pkg-config
170 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvapoursynth*.la
171 # dlopened modules
172 %{__rm} $RPM_BUILD_ROOT%{_libdir}/vapoursynth/*.la
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc ChangeLog ofl.txt
183 %attr(755,root,root) %{_bindir}/vspipe
184 %attr(755,root,root) %{_libdir}/libvapoursynth.so
185 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libvapoursynth-script.so.0
187 %attr(755,root,root) %{py3_sitedir}/vapoursynth.so
188 %dir %{_libdir}/vapoursynth
189 %attr(755,root,root) %{_libdir}/vapoursynth/libeedi3.so
190 %attr(755,root,root) %{_libdir}/vapoursynth/libmiscfilters.so
191 %attr(755,root,root) %{_libdir}/vapoursynth/libmorpho.so
192 %attr(755,root,root) %{_libdir}/vapoursynth/libremovegrain.so
193 %attr(755,root,root) %{_libdir}/vapoursynth/libvinverse.so
194 %attr(755,root,root) %{_libdir}/vapoursynth/libvivtc.so
195
196 %files plugin-imwri
197 %defattr(644,root,root,755)
198 # R: ImageMagick-c++ >= 1:7
199 %attr(755,root,root) %{_libdir}/vapoursynth/libimwri.so
200
201 %files plugin-ocr
202 %defattr(644,root,root,755)
203 # R: tesseract
204 %attr(755,root,root) %{_libdir}/vapoursynth/libocr.so
205
206 %if %{with ffmpeg}
207 %files plugin-subtext
208 %defattr(644,root,root,755)
209 # R: libass ffmpeg
210 %attr(755,root,root) %{_libdir}/vapoursynth/libsubtext.so
211 %endif
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so
216 %{_includedir}/vapoursynth
217 %{_pkgconfigdir}/vapoursynth.pc
218 %{_pkgconfigdir}/vapoursynth-script.pc
219
220 %if %{with static_libs}
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libvapoursynth.a
224 %{_libdir}/libvapoursynth-script.a
225 %endif
226
227 %if %{with doc}
228 %files doc
229 %defattr(644,root,root,755)
230 %doc doc/_build/html/{_static,api,functions,plugins,*.html,*.js}
231 %endif
This page took 0.066338 seconds and 2 git commands to generate.