]> git.pld-linux.org Git - packages/vapoursynth.git/blob - vapoursynth.spec
31deb0038cb29f46163456f5dbb7b241a8578a66
[packages/vapoursynth.git] / vapoursynth.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # documentation
4 %bcond_without  ffmpeg          # subtext plugin (libass+ffmpeg based)
5 %bcond_with     sse             # use SSE/SSE2 instructions on x86 (no runtime detection)
6 %bcond_without  static_libs     # static libraries
7 #
8 %ifarch pentium4 %{x8664} x32
9 %define with_sse        1
10 %endif
11 Summary:        A video processing framework with simplicity in mind
12 Summary(pl.UTF-8):      Szkielet do przetwarzania obrazu stworzony z myślą o prostocie
13 Name:           vapoursynth
14 Version:        38
15 Release:        1
16 License:        LGPL v2.1+
17 Group:          Libraries
18 #Source0Download: https://github.com/vapoursynth/vapoursynth/releases
19 Source0:        https://github.com/vapoursynth/vapoursynth/archive/R%{version}/%{name}-%{version}.tar.gz
20 # Source0-md5:  78d0183f0afd3702f3edc176b2491f5d
21 Patch0:         %{name}-genericarch.patch
22 URL:            http://www.vapoursynth.com/
23 BuildRequires:  ImageMagick-c++-devel >= 1:7
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake >= 1:1.11
26 # libavcodec libavformat libavutil
27 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
28 %{?with_ffmpeg:BuildRequires:   libass-devel}
29 BuildRequires:  libstdc++-devel >= 6:4.8
30 BuildRequires:  libtool >= 2:2
31 BuildRequires:  pkgconfig
32 BuildRequires:  python3-Cython
33 BuildRequires:  python3-devel >= 1:3.2
34 BuildRequires:  sed >= 4.0
35 %{?with_doc:BuildRequires:      sphinx-pdg}
36 BuildRequires:  tesseract-devel >= 3
37 %if %{with sse}
38 BuildRequires:  yasm
39 %endif
40 BuildRequires:  zimg-devel >= 2.5
41 %if %{with sse}
42 Requires:       cpuinfo(sse2)
43 %endif
44 Requires:       python3-libs >= 1:3.2
45 Requires:       zimg >= 2.5
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 # non-function std::__once_call, std::__once_callable symbols
49 %define         skip_post_check_so      libvapoursynth-script.so.*
50
51 %description
52 VapourSynth is an application for video manipulation. Or a plugin. Or
53 a library. It's hard to tell  because it has a core library written in
54 C++ and a Python module to allow video scripts to be created.
55
56 %description -l pl.UTF-8
57 VapourSynth to aplikacja do obróbki obrazu. Albo wtyczka. Albo
58 biblioteka. Trudno stwierdzić, ponieważ ma główną bibliotekę napisaną
59 w C++ oraz moduł Pythona pozwalający na tworzenie skryptów do obrazu.
60
61 %package plugin-imwri
62 Summary:        Image reader/writer plugin for VapourSynth
63 Summary(pl.UTF-8):      Wtyczka VapourSynth odczytująca i zapisują obrazy
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description plugin-imwri
68 Image reader/writer plugin for VapourSynth.
69
70 %description plugin-imwri -l pl.UTF-8
71 Wtyczka VapourSynth odczytująca i zapisują obrazy.
72
73 %package plugin-ocr
74 Summary:        OCR plugin for VapourSynth
75 Summary(pl.UTF-8):      Wtyczka OCR dla VapourSyntha
76 Group:          Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description plugin-ocr
80 OCR plugin for VapourSynth.
81
82 %description plugin-ocr -l pl.UTF-8
83 Wtyczka OCR dla VapourSyntha.
84
85 %package plugin-subtext
86 Summary:        Subtitle rendering plugin for VapourSynth
87 Summary(pl.UTF-8):      Wtyczka VapourSynth nanosząca podpisy
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description plugin-subtext
92 Subtitle rendering plugin for VapourSynth.
93
94 %description plugin-subtext -l pl.UTF-8
95 Wtyczka VapourSynth nanosząca podpisy.
96
97 %package devel
98 Summary:        Header files for VapourSynth libraries
99 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek VapourSynth
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       python3-devel >= 1:3.2
103 Requires:       zimg-devel >= 2.5
104
105 %description devel
106 Header files for VapourSynth libraries.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe bibliotek VapourSynth.
110
111 %package static
112 Summary:        Static VapourSynth libraries
113 Summary(pl.UTF-8):      Statyczne biblioteki VapourSynth
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description static
118 Static VapourSynth libraries.
119
120 %description static -l pl.UTF-8
121 Statyczne biblioteki VapourSynth.
122
123 %package doc
124 Summary:        Documentation for VapourSynth library
125 Summary(pl.UTF-8):      Dokumentacja do biblioteki VapourSynth
126 Group:          Documentation
127 %if "%{_rpmversion}" >= "5"
128 BuildArch:      noarch
129 %endif
130
131 %description doc
132 Documentation for VapourSynth library.
133
134 %description doc -l pl.UTF-8
135 Dokumentacja do biblioteki VapourSynth.
136
137 %prep
138 %setup -q -n %{name}-R%{version}
139 %patch0 -p1
140
141 %if %{without sse}
142 %{__sed} -i -e 's/"-mfpmath=sse -msse2"/""/' configure.ac
143 %endif
144
145 %build
146 %{__libtoolize}
147 %{__aclocal}
148 %{__autoconf}
149 %{__automake}
150 %configure \
151         --disable-silent-rules \
152         %{!?with_ffmpeg:--disable-subtext} \
153         %{!?with_static_libs:--disable-static} \
154         %{!?with_sse:--disable-x86-asm}
155 %{__make}
156
157 %if %{with doc}
158 %{__make} -C doc html
159 %endif
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/vapoursynth.la
168 # obsoleted by pkg-config
169 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvapoursynth*.la
170 # dlopened modules
171 %{__rm} $RPM_BUILD_ROOT%{_libdir}/vapoursynth/*.la
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc ChangeLog ofl.txt
182 %attr(755,root,root) %{_bindir}/vspipe
183 %attr(755,root,root) %{_libdir}/libvapoursynth.so
184 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libvapoursynth-script.so.0
186 %attr(755,root,root) %{py3_sitedir}/vapoursynth.so
187 %dir %{_libdir}/vapoursynth
188 %attr(755,root,root) %{_libdir}/vapoursynth/libeedi3.so
189 %attr(755,root,root) %{_libdir}/vapoursynth/libmiscfilters.so
190 %attr(755,root,root) %{_libdir}/vapoursynth/libmorpho.so
191 %attr(755,root,root) %{_libdir}/vapoursynth/libremovegrain.so
192 %attr(755,root,root) %{_libdir}/vapoursynth/libvinverse.so
193 %attr(755,root,root) %{_libdir}/vapoursynth/libvivtc.so
194
195 %files plugin-imwri
196 %defattr(644,root,root,755)
197 # R: ImageMagick-c++ >= 1:7
198 %attr(755,root,root) %{_libdir}/vapoursynth/libimwri.so
199
200 %files plugin-ocr
201 %defattr(644,root,root,755)
202 # R: tesseract
203 %attr(755,root,root) %{_libdir}/vapoursynth/libocr.so
204
205 %if %{with ffmpeg}
206 %files plugin-subtext
207 %defattr(644,root,root,755)
208 # R: libass ffmpeg
209 %attr(755,root,root) %{_libdir}/vapoursynth/libsubtext.so
210 %endif
211
212 %files devel
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/libvapoursynth-script.so
215 %{_includedir}/vapoursynth
216 %{_pkgconfigdir}/vapoursynth.pc
217 %{_pkgconfigdir}/vapoursynth-script.pc
218
219 %if %{with static_libs}
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/libvapoursynth.a
223 %{_libdir}/libvapoursynth-script.a
224 %endif
225
226 %if %{with doc}
227 %files doc
228 %defattr(644,root,root,755)
229 %doc doc/_build/html/{_static,api,functions,plugins,*.html,*.js}
230 %endif
This page took 0.059407 seconds and 2 git commands to generate.