]> git.pld-linux.org Git - packages/v8.git/blob - v8.spec
- updated URLs, dropped upstream-tracker.org note (this domain is dead now)
[packages/v8.git] / v8.spec
1 # TODO
2 # - readline not working in d8 (at least arrows)
3 #
4 # Conditional build:
5 %bcond_without  verbose                 # verbose build (V=1)
6
7 Summary:        JavaScript Engine by Google
8 Summary(pl.UTF-8):      Silnik JavaScript firmy Google
9 Name:           v8
10 Version:        3.15.11.18
11 Release:        2
12 License:        BSD
13 Group:          Development/Languages
14 #Source0Download: https://github.com/v8/v8/releases
15 #Source0: https://github.com/v8/v8/archive/%{version}/%{name}-%{version}.tar.gz
16 Source0:        %{name}-%{version}.tar.bz2
17 # Source0-md5:  a08c74de1f8d71d309077cb7a640583f
18 Patch0:         %{name}-cstdio.patch
19 Patch1:         %{name}-strndup.patch
20 Patch3:         %{name}-dynlink.patch
21 Patch4:         abort-uncaught-exception.patch
22 URL:            https://github.com/v8/v8/wiki
23 BuildRequires:  gyp
24 BuildRequires:  libstdc++-devel >= 5:4.0
25 BuildRequires:  python >= 1:2.5
26 BuildRequires:  readline-devel
27 BuildRequires:  sed >= 4.0
28 Requires:       %{name}-libs = %{version}-%{release}
29 ExclusiveArch:  %{ix86} %{x8664} arm mips
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         sover   %(echo %{version} | cut -d. -f1-2)
33
34 %description
35 V8 is Google's open source JavaScript engine. V8 is written in C++ and
36 is used in Google Chrome, the open source browser from Google. V8
37 implements ECMAScript as specified in ECMA-262, 3rd edition.
38
39 This package contains the V8 developer shell.
40
41 %description -l pl.UTF-8
42 V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
43 napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
44 Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
45 ECMA-262, edycja 3.
46
47 Ten pakiet zawiera powłokę programistyczną V8.
48
49 %package libs
50 Summary:        V8 JavaScript Engine shared library
51 Summary(pl.UTF-8):      Biblioteka współdzielona silnika JavaScriptu V8
52 Group:          Libraries
53 Conflicts:      v8 < 2.0.0
54
55 %description libs
56 V8 is Google's open source JavaScript engine. V8 is written in C++ and
57 is used in Google Chrome, the open source browser from Google. V8
58 implements ECMAScript as specified in ECMA-262, 3rd edition.
59
60 This package contains the shared library.
61
62 %description libs -l pl.UTF-8
63 V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
64 napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
65 Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
66 ECMA-262, edycja 3.
67
68 Ten pakiet zawiera bibliotekę współdzieloną.
69
70 %package devel
71 Summary:        Development headers for V8 JavaScript engine
72 Summary(pl.UTF-8):      Pliki nagłówkowe silnika JavaScriptu V8
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       libstdc++-devel
76
77 %description devel
78 Development headers for V8 JavaScript engine.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe silnika JavaScriptu V8.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch3 -p1
88 %patch4 -p1
89
90 install -d build/gyp
91 ln -s %{_bindir}/gyp build/gyp/gyp
92
93 %build
94 # -Wno-unused-local-typedefs is gcc 4.8 workaround: http://code.google.com/p/v8/issues/detail?id=2149
95 %{__make} -r native \
96         component=shared_library \
97         soname_version=%{sover} \
98         console=readline \
99         CC="%{__cc}" \
100         CXX="%{__cxx}" \
101         LINK="%{__cxx} -fuse-ld=gold" \
102         CFLAGS="%{rpmcflags}" \
103         CXXFLAGS="%{rpmcxxflags} -Wno-unused-local-typedefs" \
104         LDFLAGS="%{rpmldflags}" \
105         %{?with_verbose:V=1}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
110
111 install -p out/native/lib.target/libv8.so.%{sover} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{version}
112 ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{sover}
113 ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so
114 cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}
115
116 install -p out/native/d8 $RPM_BUILD_ROOT%{_bindir}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   libs -p /sbin/ldconfig
122 %postun libs -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog LICENSE LICENSE.strongtalk LICENSE.valgrind
127 %attr(755,root,root) %{_bindir}/d8
128
129 %files libs
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libv8.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libv8.so.%{sover}
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libv8.so
137 %{_includedir}/v8*.h
This page took 0.065435 seconds and 3 git commands to generate.