]> git.pld-linux.org Git - packages/v8.git/blob - v8.spec
1ca4541519a74c784a5b541d23f7a8b617c6eb1d
[packages/v8.git] / v8.spec
1 # NOTES
2 # - see this page for deciding switching branch: http://upstream-tracker.org/versions/v8.html
3 # TODO
4 # - readline not working in d8 (at least arrows)
5 #
6 # Conditional build:
7 %bcond_without  verbose                 # verbose build (V=1)
8
9 Summary:        JavaScript Engine by Google
10 Summary(pl.UTF-8):      Silnik JavaScript firmy Google
11 Name:           v8
12 Version:        3.15.11.17
13 Release:        1
14 License:        BSD
15 Group:          Development/Languages
16 # Source0Download: http://gsdview.appspot.com/chromium-browser-official/?marker=v8-3.15.11.17.tar.bz2
17 Source0:        http://commondatastorage.googleapis.com/chromium-browser-official/%{name}-%{version}.tar.bz2
18 # Source0-md5:  0930164aa73e5ce94565ae1b85fac19b
19 Patch0:         %{name}-cstdio.patch
20 Patch1:         %{name}-strndup.patch
21 Patch3:         %{name}-dynlink.patch
22 URL:            http://code.google.com/p/v8/
23 BuildRequires:  libstdc++-devel >= 5:4.0
24 BuildRequires:  python >= 1:2.5
25 BuildRequires:  readline-devel
26 BuildRequires:  sed >= 4.0
27 Requires:       %{name}-libs = %{version}-%{release}
28 ExclusiveArch:  %{ix86} %{x8664} arm mips
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         sover   %(echo %{version} | cut -d. -f1-2)
32
33 %description
34 V8 is Google's open source JavaScript engine. V8 is written in C++ and
35 is used in Google Chrome, the open source browser from Google. V8
36 implements ECMAScript as specified in ECMA-262, 3rd edition.
37
38 This package contains the V8 developer shell.
39
40 %description -l pl.UTF-8
41 V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
42 napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
43 Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
44 ECMA-262, edycja 3.
45
46 Ten pakiet zawiera powłokę programistyczną V8.
47
48 %package libs
49 Summary:        V8 JavaScript Engine shared library
50 Summary(pl.UTF-8):      Biblioteka współdzielona silnika JavaScriptu V8
51 Group:          Libraries
52 Conflicts:      v8 < 2.0.0
53
54 %description libs
55 V8 is Google's open source JavaScript engine. V8 is written in C++ and
56 is used in Google Chrome, the open source browser from Google. V8
57 implements ECMAScript as specified in ECMA-262, 3rd edition.
58
59 This package contains the shared library.
60
61 %description libs -l pl.UTF-8
62 V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
63 napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
64 Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
65 ECMA-262, edycja 3.
66
67 Ten pakiet zawiera bibliotekę współdzieloną.
68
69 %package devel
70 Summary:        Development headers for V8 JavaScript engine
71 Summary(pl.UTF-8):      Pliki nagłówkowe silnika JavaScriptu V8
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       libstdc++-devel
75
76 %description devel
77 Development headers for V8 JavaScript engine.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe silnika JavaScriptu V8.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch3 -p1
87
88
89 %build
90 # -Wno-unused-local-typedefs is gcc 4.8 workaround: http://code.google.com/p/v8/issues/detail?id=2149
91 %{__make} -r native \
92         component=shared_library \
93         soname_version=%{sover} \
94         console=readline \
95         CC="%{__cc}" \
96         CXX="%{__cxx}" \
97         LINK="%{__cxx} -fuse-ld=gold" \
98         CFLAGS="%{rpmcflags}" \
99         CXXFLAGS="%{rpmcxxflags} -Wno-unused-local-typedefs" \
100         LDFLAGS="%{rpmldflags}" \
101         %{?with_verbose:V=1}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
106
107 install -p out/native/lib.target/libv8.so.%{sover} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{version}
108 ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{sover}
109 ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so
110 cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}
111
112 install -p out/native/d8 $RPM_BUILD_ROOT%{_bindir}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   libs -p /sbin/ldconfig
118 %postun libs -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog LICENSE LICENSE.strongtalk LICENSE.valgrind
123 %attr(755,root,root) %{_bindir}/d8
124
125 %files libs
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libv8.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libv8.so.%{sover}
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libv8.so
133 %{_includedir}/v8*.h
This page took 0.076537 seconds and 2 git commands to generate.