]> git.pld-linux.org Git - packages/unqlite.git/blob - unqlite.spec
new, version 1.1.6
[packages/unqlite.git] / unqlite.spec
1 Summary:        An Embeddable NoSQL Database Engine
2 Name:           unqlite
3 Version:        1.1.6
4 Release:        1
5 License:        BSD
6 Group:          Libraries
7 # Source0Download: http://unqlite.org/downloads.html
8 Source0:        http://unqlite.org/db/%{name}-db-20130825-116.zip
9 # Source0-md5:  a48b7409414cc4a9ff8f7ccce81f40c5
10 URL:            http://unqlite.org/
11 BuildRequires:  unzip
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         soname libunqlite.so.0
15
16 %description
17 UnQLite is a in-process software library which implements a
18 self-contained, serverless, zero-configuration, transactional NoSQL
19 database engine. UnQLite is a document store database similar to
20 MongoDB, Redis, CouchDB etc. as well a standard Key/Value store
21 similar to BerkeleyDB, LevelDB, etc.
22
23 %package devel
24 Summary:        Header file for UnQLite development
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27
28 %description devel
29 Header file for UnQLite development.
30
31 %prep
32 %setup -qc
33
34 %build
35 %{__cc} %{rpmcppflags} %{rpmcflags} -c unqlite.c -fPIC
36 %{__cc} %{rpmldflags} -Wl,-soname,%{soname} -shared *.o -o %{soname}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
41 cp -p unqlite.h $RPM_BUILD_ROOT%{_includedir}
42 install -p %{soname} $RPM_BUILD_ROOT%{_libdir}
43 ln -s %{soname} $RPM_BUILD_ROOT%{_libdir}/libunqlite.so
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post   -p /sbin/ldconfig
49 %postun -p /sbin/ldconfig
50
51 %files
52 %defattr(644,root,root,755)
53 %doc license.txt
54 %attr(755,root,root) %{_libdir}/libunqlite.so.0
55
56 %files devel
57 %defattr(644,root,root,755)
58 %{_includedir}/unqlite.h
59 %{_libdir}/libunqlite.so
This page took 0.060946 seconds and 3 git commands to generate.