]> git.pld-linux.org Git - packages/unittest-cpp.git/blob - unittest-cpp.spec
- initial
[packages/unittest-cpp.git] / unittest-cpp.spec
1 %bcond_without  tests
2 Summary:        Lightweight unit testing framework for C++
3 Name:           unittest-cpp
4 Version:        1.6.1
5 Release:        1
6 Group:          Libraries
7 License:        MIT
8 URL:            https://github.com/unittest-cpp/unittest-cpp
9 Source0:        https://github.com/unittest-cpp/unittest-cpp/releases/download/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  b4849a686b78ba198a51a49966b8ddba
11 BuildRequires:  autoconf
12 BuildRequires:  libtool
13
14 %description
15 %{name} is a lightweight unit testing framework for C++. Simplicity,
16 portability, speed, and small footprint are all very important aspects
17 of %{name}.
18
19 %package devel
20 Summary:        Object files for development using %{name}
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}-%{release}
23
24 %description devel
25 The %{name}-devel package contains the object files necessary for
26 developing test programs.
27
28 %package static
29 Summary:        Static library for %{name}
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description static
34 The %{name}-static package contains the object files necessary for
35 statically linking test programs.
36
37 %prep
38 %setup -q
39
40 %build
41 %configure
42 %{__make}
43
44 %{?with_tests:%{__make} check}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 rm -f $RPM_BUILD_ROOT%{_libdir}/libUnitTest++.la
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS
63 %attr(755,root,root) %{_libdir}/libUnitTest++.so.*.*
64 %attr(755,root,root) %ghost %{_libdir}/libUnitTest++.so.1
65
66 %files devel
67 %defattr(644,root,root,755)
68 %{_includedir}/UnitTest++
69 %attr(755,root,root) %{_libdir}/libUnitTest++.so
70 %{_pkgconfigdir}/UnitTest++.pc
71
72 %files static
73 %defattr(644,root,root,755)
74 %{_libdir}/libUnitTest++.a
This page took 0.124849 seconds and 3 git commands to generate.