]> git.pld-linux.org Git - packages/unibilium.git/blob - unibilium.spec
c28a7baab5841fbe06638e69000d8be94494a179
[packages/unibilium.git] / unibilium.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # build without tests
4 %bcond_without  doc             # build doc
5
6 Summary:        Terminfo parsing library
7 Name:           unibilium
8 Version:        1.2.0
9 Release:        1
10 License:        LGPLv3+
11 Group:          Libraries
12 Source0:        https://github.com/mauke/unibilium/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  9b1c97839a880a373da6c097443b43c4
14 URL:            https://github.com/mauke/unibilium
15 BuildRequires:  gcc
16 BuildRequires:  libtool
17 %if %{with doc}
18 BuildRequires:  /usr/bin/pod2man
19 %endif
20 %if %{with tests}
21 BuildRequires:  /usr/bin/prove
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Unibilium is a very basic terminfo library. It doesn't depend on
27 curses or any other library. It also doesn't use global variables, so
28 it should be thread-safe.
29
30 %package devel
31 Summary:        Development files needed for %{name}
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Development files needed for %{name}.
37
38 %prep
39 %setup -q
40
41 %build
42 %{__make} \
43         CC="%{__cc}" \
44         PREFIX=%{_prefix} \
45         LIBDIR=%{_libdir}
46
47 %if %{with tests}
48 %{__make} test
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} install \
54         PREFIX=%{_prefix} \
55         LIBDIR=%{_libdir} \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 rm -vf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes
69 %attr(755,root,root) %{_libdir}/libunibilium.so.*.*.*
70 %ghost %{_libdir}/libunibilium.so.0
71
72 %files devel
73 %defattr(644,root,root,755)
74 %{_libdir}/libunibilium.so
75 %{_pkgconfigdir}/unibilium.pc
76 %{_includedir}/%{name}.h
77 %{_mandir}/man3/unibi_*.3*
78 %{_mandir}/man3/unibilium.h.3*
This page took 0.258856 seconds and 2 git commands to generate.