]> git.pld-linux.org Git - packages/unibilium.git/blob - unibilium.spec
904fa52fe224a2c7dce15481a3a9fffb6f87c3a9
[packages/unibilium.git] / unibilium.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # build without tests
4 %bcond_without  doc             # build doc
5
6 Summary:        Terminfo parsing library
7 Name:           unibilium
8 Version:        2.0.0
9 Release:        2
10 License:        LGPLv3+
11 Group:          Libraries
12 Source0:        https://github.com/mauke/unibilium/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  a89b8ef6e752cc76098e1863ff4b5457
14 URL:            https://github.com/mauke/unibilium
15 BuildRequires:  gcc
16 BuildRequires:  libtool
17 BuildRequires:  pkgconfig
18 %if %{with doc}
19 BuildRequires:  /usr/bin/pod2man
20 %endif
21 %if %{with tests}
22 BuildRequires:  /usr/bin/prove
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Unibilium is a very basic terminfo library. It doesn't depend on
28 curses or any other library. It also doesn't use global variables, so
29 it should be thread-safe.
30
31 %package devel
32 Summary:        Development files needed for %{name}
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Development files needed for %{name}.
38
39 %prep
40 %setup -q
41
42 %build
43 %{__make} \
44         CC="%{__cc}" \
45         CFLAGS="%{rpmcflags}" \
46         LDFLAGS="%{rpmldflags}" \
47         PREFIX=%{_prefix} \
48         LIBDIR=%{_libdir}
49
50 %if %{with tests}
51 %{__make} test
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %{__make} install \
57         PREFIX=%{_prefix} \
58         LIBDIR=%{_libdir} \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 rm -vf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes
72 %attr(755,root,root) %{_libdir}/libunibilium.so.*.*.*
73 %ghost %{_libdir}/libunibilium.so.4
74
75 %files devel
76 %defattr(644,root,root,755)
77 %{_libdir}/libunibilium.so
78 %{_pkgconfigdir}/unibilium.pc
79 %{_includedir}/%{name}.h
80 %{_mandir}/man3/unibi_*.3*
81 %{_mandir}/man3/unibilium.h.3*
This page took 0.053028 seconds and 2 git commands to generate.