]> git.pld-linux.org Git - packages/ulauncher.git/blob - ulauncher.spec
rebuild with python 3.10
[packages/ulauncher.git] / ulauncher.spec
1 Summary:        Linux Application Launcher
2 Name:           ulauncher
3 Version:        5.8.0
4 Release:        3
5 License:        GPL v3+
6 Group:          X11/Applications
7 Source0:        https://github.com/Ulauncher/Ulauncher/releases/download/%{version}/%{name}_%{version}.tar.gz
8 # Source0-md5:  49599615189481e06973e1c59fc9ff5c
9 URL:            https://ulauncher.io
10 BuildRequires:  python3-distutils-extra
11 BuildRequires:  python3-modules
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.714
14 Requires(post,postun):  desktop-file-utils
15 Requires(post,postun):  gtk-update-icon-cache
16 Requires:       gdk-pixbuf2
17 Requires:       glib2
18 Requires:       gtk+3
19 Requires:       gtk-webkit4
20 Requires:       keybinder3
21 Requires:       libappindicator-gtk3
22 Requires:       libnotify
23 Requires:       python3-Levenshtein
24 Requires:       python3-dbus
25 Requires:       python3-pyinotify
26 Requires:       python3-pyxdg
27 Requires:       python3-websocket-client
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Ulauncher is a fast application launcher for Linux. It's is written in
33 Python, using GTK+.
34
35 %prep
36 %setup -q -n %{name}
37
38 # no py3_build: DistutilsExtra does not like being built twice
39 # and py3_install invokes build too
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %py3_install
45
46 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/ulauncher
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %update_icon_cache hicolor
53 %update_desktop_database_post
54
55 %postun
56 %update_icon_cache hicolor
57 %update_desktop_database_postun
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS README.md
62 %attr(755,root,root) %{_bindir}/ulauncher
63 %attr(755,root,root) %{_bindir}/ulauncher-toggle
64 %{_datadir}/ulauncher
65 %{_desktopdir}/ulauncher.desktop
66 %{_iconsdir}/hicolor/scalable/apps/ulauncher.svg
67 %{_iconsdir}/hicolor/scalable/apps/ulauncher-indicator.svg
68 %{py3_sitescriptdir}/ulauncher
69 %{py3_sitescriptdir}/ulauncher-*-py*.egg-info
This page took 0.059849 seconds and 3 git commands to generate.