]> git.pld-linux.org Git - packages/ufraw.git/blob - ufraw.spec
- added openmp patch (fix gcc 9+ OpenMP compatibility); release 12
[packages/ufraw.git] / ufraw.spec
1 #
2 # Conditional build:
3 %bcond_without  gimp            # GIMP plugin
4 %bcond_without  openmp          # OpenMP support
5 #
6 Summary:        RAW photo loader
7 Summary(pl.UTF-8):      Narzędzie do wczytywania zdjęć w formacie RAW
8 Name:           ufraw
9 Version:        0.22
10 Release:        13
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 Source0:        http://downloads.sourceforge.net/ufraw/%{name}-%{version}.tar.gz
14 # Source0-md5:  c30767cae2c44310f2a3d67d7a76f2c3
15 Patch0:         05_fix_build_due_to_unsigned_char.patch
16 Patch1:         ufraw-find_green.patch
17 Patch2:         ufraw-lf-destroy.patch
18 Patch3:         ufraw-multipliers.patch
19 Patch4:         exiv2-0.27.patch
20 Patch5:         %{name}-include.patch
21 Patch6:         %{name}-openmp.patch
22 URL:            http://ufraw.sourceforge.net/
23 BuildRequires:  automake
24 BuildRequires:  bzip2-devel
25 BuildRequires:  cfitsio-devel
26 BuildRequires:  exiv2-devel >= 0.20
27 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
28 BuildRequires:  gettext-tools
29 %{?with_gimp:BuildRequires:     gimp-devel >= 2.6.0}
30 BuildRequires:  glib2-devel >= 1:2.12
31 BuildRequires:  gtk+2-devel >= 2:2.12
32 BuildRequires:  gtkimageview-devel >= 1.6
33 BuildRequires:  jasper-devel
34 BuildRequires:  lcms2-devel >= 2
35 BuildRequires:  lensfun-devel >= 0.2.5
36 %{?with_openmp:BuildRequires:   libgomp-devel}
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel >= 1.2
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel >= 4
41 BuildRequires:  perl-tools-pod
42 BuildRequires:  pkgconfig >= 1:0.9.0
43 BuildRequires:  zlib-devel
44 Requires(post,postun):  desktop-file-utils
45 Requires(post,postun):  shared-mime-info >= 0.21
46 Requires(post,preun):   GConf2 >= 2.16.0
47 Requires:       exiv2-libs >= 0.20
48 Requires:       glib2 >= 1:2.12
49 Requires:       gtk+2 >= 1:2.12
50 Requires:       gtkimageview >= 1.6
51 Requires:       lcms2 >= 2
52 Requires:       lensfun >= 0.2.5
53 Obsoletes:      cinepaint-plugin-ufraw
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %if %{with gimp}
57 %define         gimp_plugindir          %(gimptool --gimpplugindir)/plug-ins
58 %endif
59
60 %description
61 UFRaw is a utility to read and manipulate raw images from digital
62 cameras. It can be used by itself or as a GIMP plug-in. It reads raw
63 images using Dave Coffin's raw conversion utility DCRaw. And it
64 supports basic color management using Little CMS, allowing the user to
65 apply color profiles.
66
67 %description -l pl.UTF-8
68 UFRaw to narzędzie do czytania i przetwarzania zdjęć w formacie RAW
69 różnych aparatów cyfrowych. Może być używane samodzielnie lub jako
70 wtyczka programu GIMP. Zdjęcia w formacie RAW są wczytywane za pomocą
71 programu DCRaw Dave'a Coffina. Użytkownik ma możliwość stosowania
72 profili kolorów dzięki bibliotece Little CMS.
73
74 %package batch
75 Summary:        RAW photo loader batch software
76 Summary(pl.UTF-8):      Program do wsadowego przetwarzania zdjęć w formacie RAW
77 Group:          Applications/Graphics
78 Requires:       exiv2 >= 0.20
79 Requires:       glib2 >= 1:2.12
80 Requires:       lcms2 >= 2
81 Requires:       lensfun >= 0.2.5
82
83 %description batch
84 RAW photo loader batch software.
85
86 %description batch -l pl.UTF-8
87 Program do wsadowego przetwarzania zdjęć w formacie RAW.
88
89 %package -n gimp-plugin-ufraw
90 Summary:        RAW photo loader GIMP plugin
91 Summary(pl.UTF-8):      Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW
92 Group:          Applications/Graphics
93 Requires:       exiv2 >= 0.20
94 Requires:       gimp >= 2.6.0
95 Requires:       glib2 >= 1:2.12
96 Requires:       gtk+2 >= 1:2.12
97 Requires:       gtkimageview >= 1.6
98 Requires:       lcms2 >= 2
99 Requires:       lensfun >= 0.2.5
100
101 %description -n gimp-plugin-ufraw
102 RAW photo loader GIMP plugin.
103
104 %description -n gimp-plugin-ufraw -l pl.UTF-8
105 Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112 %patch3 -p1
113 %patch4 -p1
114 %patch5 -p1
115 %patch6 -p1
116
117 %build
118 cp -f /usr/share/automake/mkinstalldirs .
119 %configure \
120         --disable-silent-rules \
121         %{!?with_openmp:--disable-openmp} \
122         --enable-contrast \
123         --enable-dst-correction \
124         --enable-extras \
125         --enable-mime \
126         --with-gimp%{!?with_gimp:=no} \
127         --with-gtk
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_desktopdir}
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT \
137         schemasdir=%{_sysconfdir}/gconf/schemas
138
139 install ufraw.desktop $RPM_BUILD_ROOT%{_desktopdir}
140 %{__rm} $RPM_BUILD_ROOT%{_bindir}/dcraw
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %gconf_schema_install ufraw.schemas
149 %update_desktop_database_post
150
151 %preun
152 %gconf_schema_uninstall ufraw.schemas
153
154 %postun
155 %update_desktop_database_postun
156
157 %files -f %{name}.lang
158 %defattr(644,root,root,755)
159 %doc README TODO
160 %attr(755,root,root) %{_bindir}/nikon-curve
161 %attr(755,root,root) %{_bindir}/ufraw
162 %{_desktopdir}/ufraw.desktop
163 %{_pixmapsdir}/ufraw.png
164 %{_sysconfdir}/gconf/schemas/%{name}.schemas
165 %{_datadir}/appdata/ufraw.appdata.xml
166 %{_mandir}/man1/ufraw.1*
167
168 %files batch
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/ufraw-batch
171
172 %if %{with gimp}
173 %files -n gimp-plugin-ufraw
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{gimp_plugindir}/ufraw-gimp
176 %endif
This page took 0.064194 seconds and 3 git commands to generate.