]> git.pld-linux.org Git - packages/ufraw.git/blob - ufraw.spec
- fix building with exiv2 0.27
[packages/ufraw.git] / ufraw.spec
1 #
2 # Conditional build:
3 %bcond_without  gimp            # GIMP plugin
4 %bcond_without  openmp          # OpenMP support
5 #
6 Summary:        RAW photo loader
7 Summary(pl.UTF-8):      Narzędzie do wczytywania zdjęć w formacie RAW
8 Name:           ufraw
9 Version:        0.22
10 Release:        11
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 Source0:        http://downloads.sourceforge.net/ufraw/%{name}-%{version}.tar.gz
14 # Source0-md5:  c30767cae2c44310f2a3d67d7a76f2c3
15 Patch0:         05_fix_build_due_to_unsigned_char.patch
16 Patch1:         ufraw-find_green.patch
17 Patch2:         ufraw-lf-destroy.patch
18 Patch3:         ufraw-multipliers.patch
19 Patch4:         exiv2-0.27.patch
20 URL:            http://ufraw.sourceforge.net/
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel
23 BuildRequires:  cfitsio-devel
24 BuildRequires:  exiv2-devel >= 0.20
25 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
26 BuildRequires:  gettext-tools
27 %{?with_gimp:BuildRequires:     gimp-devel >= 2.6.0}
28 BuildRequires:  glib2-devel >= 1:2.12
29 BuildRequires:  gtk+2-devel >= 2:2.12
30 BuildRequires:  gtkimageview-devel >= 1.6
31 BuildRequires:  jasper-devel
32 BuildRequires:  lcms2-devel >= 2
33 BuildRequires:  lensfun-devel >= 0.2.5
34 %{?with_openmp:BuildRequires:   libgomp-devel}
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel >= 1.2
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtiff-devel >= 4
39 BuildRequires:  perl-tools-pod
40 BuildRequires:  pkgconfig >= 1:0.9.0
41 BuildRequires:  zlib-devel
42 Requires(post,postun):  desktop-file-utils
43 Requires(post,postun):  shared-mime-info >= 0.21
44 Requires(post,preun):   GConf2 >= 2.16.0
45 Requires:       exiv2-libs >= 0.20
46 Requires:       glib2 >= 1:2.12
47 Requires:       gtk+2 >= 1:2.12
48 Requires:       gtkimageview >= 1.6
49 Requires:       lcms2 >= 2
50 Requires:       lensfun >= 0.2.5
51 Obsoletes:      cinepaint-plugin-ufraw
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %if %{with gimp}
55 %define         gimp_plugindir          %(gimptool --gimpplugindir)/plug-ins
56 %endif
57
58 %description
59 UFRaw is a utility to read and manipulate raw images from digital
60 cameras. It can be used by itself or as a GIMP plug-in. It reads raw
61 images using Dave Coffin's raw conversion utility DCRaw. And it
62 supports basic color management using Little CMS, allowing the user to
63 apply color profiles.
64
65 %description -l pl.UTF-8
66 UFRaw to narzędzie do czytania i przetwarzania zdjęć w formacie RAW
67 różnych aparatów cyfrowych. Może być używane samodzielnie lub jako
68 wtyczka programu GIMP. Zdjęcia w formacie RAW są wczytywane za pomocą
69 programu DCRaw Dave'a Coffina. Użytkownik ma możliwość stosowania
70 profili kolorów dzięki bibliotece Little CMS.
71
72 %package batch
73 Summary:        RAW photo loader batch software
74 Summary(pl.UTF-8):      Program do wsadowego przetwarzania zdjęć w formacie RAW
75 Group:          Applications/Graphics
76 Requires:       exiv2 >= 0.20
77 Requires:       glib2 >= 1:2.12
78 Requires:       lcms2 >= 2
79 Requires:       lensfun >= 0.2.5
80
81 %description batch
82 RAW photo loader batch software.
83
84 %description batch -l pl.UTF-8
85 Program do wsadowego przetwarzania zdjęć w formacie RAW.
86
87 %package -n gimp-plugin-ufraw
88 Summary:        RAW photo loader GIMP plugin
89 Summary(pl.UTF-8):      Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW
90 Group:          Applications/Graphics
91 Requires:       exiv2 >= 0.20
92 Requires:       gimp >= 2.6.0
93 Requires:       glib2 >= 1:2.12
94 Requires:       gtk+2 >= 1:2.12
95 Requires:       gtkimageview >= 1.6
96 Requires:       lcms2 >= 2
97 Requires:       lensfun >= 0.2.5
98
99 %description -n gimp-plugin-ufraw
100 RAW photo loader GIMP plugin.
101
102 %description -n gimp-plugin-ufraw -l pl.UTF-8
103 Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p1
111 %patch4 -p1
112
113 %build
114 cp -f /usr/share/automake/mkinstalldirs .
115 %configure \
116         --disable-silent-rules \
117         %{!?with_openmp:--disable-openmp} \
118         --enable-contrast \
119         --enable-dst-correction \
120         --enable-extras \
121         --enable-mime \
122         --with-gimp%{!?with_gimp:=no} \
123         --with-gtk
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_desktopdir}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         schemasdir=%{_sysconfdir}/gconf/schemas
134
135 install ufraw.desktop $RPM_BUILD_ROOT%{_desktopdir}
136 %{__rm} $RPM_BUILD_ROOT%{_bindir}/dcraw
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %gconf_schema_install ufraw.schemas
145 %update_desktop_database_post
146
147 %preun
148 %gconf_schema_uninstall ufraw.schemas
149
150 %postun
151 %update_desktop_database_postun
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc README TODO
156 %attr(755,root,root) %{_bindir}/nikon-curve
157 %attr(755,root,root) %{_bindir}/ufraw
158 %{_desktopdir}/ufraw.desktop
159 %{_pixmapsdir}/ufraw.png
160 %{_sysconfdir}/gconf/schemas/%{name}.schemas
161 %{_datadir}/appdata/ufraw.appdata.xml
162 %{_mandir}/man1/ufraw.1*
163
164 %files batch
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/ufraw-batch
167
168 %if %{with gimp}
169 %files -n gimp-plugin-ufraw
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{gimp_plugindir}/ufraw-gimp
172 %endif
This page took 0.037948 seconds and 3 git commands to generate.