]> git.pld-linux.org Git - packages/ucommon.git/blob - ucommon.spec
- updated to 6.2.3
[packages/ucommon.git] / ucommon.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
5
6 Summary:        GNU uCommon C++ - very light-weight C++ framework
7 Summary(pl.UTF-8):      GNU uCommon C++ - bardzo lekki szkielet C++
8 Name:           ucommon
9 Version:        6.2.3
10 Release:        1
11 License:        LGPL v3+ (libucommon and secure component), GPL v3+ with runtime exception (commoncpp2)
12 Group:          Libraries
13 Source0:        http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
14 # Source0-md5:  610bf2d10cf9abefeb4a50a3bdba2023
15 URL:            http://www.gnu.org/software/commoncpp/
16 %{?with_apidocs:BuildRequires:  doxygen}
17 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0.0}
18 BuildRequires:  libstdc++-devel >= 5:3.0
19 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7}
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 GNU uCommon C++ is meant as a very light-weight C++ library to
25 facilitate using C++ design patterns even for very deeply embedded
26 applications, such as for systems using uClibc along with POSIX
27 threading support. For this reason, uCommon disables language features
28 that consume memory or introduce runtime overhead, such as rtti and
29 exception handling, and assumes one will mostly be linking
30 applications with other pure C based libraries rather than using the
31 overhead of the standard C++ library and other class frameworks.
32
33 %description -l pl.UTF-8
34 GNU uCommon C++ ma być bardzo lekką biblioteką C++ ułatwiającą
35 wykorzystywanie wzorców projektowych C++, nawet w bardzo wbudowanych
36 zastosowaniach, takich jak systemy wykorzystujące uClibc, wraz z
37 obsługą wątków POSIX. Z tego powodu uCommon wyłącza elementy języka
38 pochłaniające pamięć lub wprowadzające narzut w czasie działania,
39 takie jak rtti czy obsługa wyjątków i zakłada, że aplikacje będą
40 linkowane z innymi bibliotekami opartymi na czystym C zamiast narzutu
41 pełnej biblioteki standardowej C++ czy innych szkieletów klas.
42
43 %package devel
44 Summary:        Header files for uCommon C++ library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki uCommon C++
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 %{?with_gnutls:Requires:        gnutls-devel >= 3.0.0}
49 Requires:       libstdc++-devel >= 5:3.0
50 %{!?with_gnutls:Requires:       openssl-devel >= 0.9.7}
51
52 %description devel
53 Header files for uCommon C++ library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki uCommon C++.
57
58 %package static
59 Summary:        Static uCommon C++ library
60 Summary(pl.UTF-8):      Statyczna biblioteka uCommon C++
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static uCommon C++ library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka uCommon C++.
69
70 %package apidocs
71 Summary:        uCommon C++ API documentation
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki uCommon C++
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API and internal documentation for uCommon C++ library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki uCommon C++.
83
84 %package tools
85 Summary:        uCommon system and support applications
86 Summary(pl.UTF-8):      uCommon - aplikacje systemowe i pomocnicze
87 Group:          Applications/System
88 Requires:       %{name} = %{version}-%{release}
89
90 %description tools
91 uCommon system and support applications.
92
93 %description tools -l pl.UTF-8
94 uCommon - aplikacje systemowe i pomocnicze.
95
96 %prep
97 %setup -q
98
99 %build
100 %configure \
101         --with-sslstack=%{?with_gnutls:gnutls}%{!?with_gnutls:openssl}
102 %{__make}
103
104 %if %{with apidocs}
105 %{__make} doxy
106 %endif
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYRIGHT ChangeLog NEWS README README.secure SUPPORT TODO
123 %attr(755,root,root) %{_libdir}/libcommoncpp.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libcommoncpp.so.7
125 %attr(755,root,root) %{_libdir}/libucommon.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libucommon.so.7
127 %attr(755,root,root) %{_libdir}/libusecure.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libusecure.so.7
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/commoncpp-config
133 %attr(755,root,root) %{_bindir}/ucommon-config
134 %attr(755,root,root) %{_libdir}/libcommoncpp.so
135 %attr(755,root,root) %{_libdir}/libucommon.so
136 %attr(755,root,root) %{_libdir}/libusecure.so
137 %{_libdir}/libcommoncpp.la
138 %{_libdir}/libucommon.la
139 %{_libdir}/libusecure.la
140 %{_includedir}/commoncpp
141 %{_includedir}/ucommon
142 %{_pkgconfigdir}/commoncpp.pc
143 %{_pkgconfigdir}/ucommon.pc
144 %{_mandir}/man1/commoncpp-config.1*
145 %{_mandir}/man1/ucommon-config.1*
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libcommoncpp.a
150 %{_libdir}/libucommon.a
151 %{_libdir}/libusecure.a
152
153 %if %{with apidocs}
154 %files apidocs
155 %defattr(644,root,root,755)
156 %doc doc/html/*
157 %endif
158
159 %files tools
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/args
162 %attr(755,root,root) %{_bindir}/car
163 %attr(755,root,root) %{_bindir}/keywait
164 %attr(755,root,root) %{_bindir}/mdsum
165 %attr(755,root,root) %{_bindir}/pdetach
166 %attr(755,root,root) %{_bindir}/scrub-files
167 %attr(755,root,root) %{_bindir}/sockaddr
168 %attr(755,root,root) %{_bindir}/zerofill
169 %{_mandir}/man1/args.1*
170 %{_mandir}/man1/car.1*
171 %{_mandir}/man1/keywait.1*
172 %{_mandir}/man1/mdsum.1*
173 %{_mandir}/man1/pdetach.1*
174 %{_mandir}/man1/scrub-files.1*
175 %{_mandir}/man1/sockaddr.1*
176 %{_mandir}/man1/zerofill.1*
This page took 0.052497 seconds and 3 git commands to generate.