]> git.pld-linux.org Git - packages/ttembed.git/blob - ttembed.spec
- pl, pass CC
[packages/ttembed.git] / ttembed.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Remove embedding limitations from TrueType fonts
6 Summary(pl.UTF-8):      Usuwanie ograniczeń osadzania z fontów TrueType
7 Name:           ttembed
8 Version:        1.1
9 Release:        2
10 License:        Public Domain
11 Group:          Applications
12 Source0:        https://github.com/hisdeedsaredust/ttembed/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  1eccad30e260d4ccd2a1f8a9b1a165ce
14 URL:            https://github.com/hisdeedsaredust/ttembed
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Remove embedding limitations from TrueType fonts, by setting the
19 fsType field in the OS/2 table to zero. That's it; this program is a
20 one-trick pony.
21
22 %description -l pl.UTF-8
23 Usuwanie ograniczeń osadzania z fontów TrueType poprzez ustawienie
24 pola fsType w tablicy OS/2 na zero. To wszystko - ten program służy
25 do jednej prostej czynności.
26
27 %prep
28 %setup -q
29
30 %build
31 CC="%{__cc}" \
32 CFLAGS="%{rpmcflags}" \
33 %{__make}
34
35 %if %{with tests}
36 # smoke test - fail on not font file
37 echo 'not a font' > test
38 if [ "$(./ttembed test 2>&1)" != "test: Not TTF/OTF" ]; then
39         echo "TEST FAIL: not a font input test" 1>&2
40         exit 1
41 fi
42 rm test
43 %endif
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
48 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
49 cp -p %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc LICENSE README.md
57 %attr(755,root,root) %{_bindir}/ttembed
58 %{_mandir}/man1/ttembed.1*
This page took 0.06635 seconds and 4 git commands to generate.