]> git.pld-linux.org Git - packages/truecrypt.git/blob - truecrypt.spec
- refetch sources
[packages/truecrypt.git] / truecrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # build without GUI
4 %if "%{pld_release}" == "ac"
5 %bcond_without          gcc4    # use gcc4* packages for building
6 %else
7 %bcond_with             gcc4    # use gcc4* packages for building
8 %endif
9
10 %define         wx_ver  2.8.12
11 Summary:        TrueCrypt - Free Open-Source Disk Encryption Software
12 Summary(pl.UTF-8):      TrueCrypt - wolnodostępne oprogramowanie do szyfrowania dysków
13 Name:           truecrypt
14 Version:        7.1a
15 Release:        1
16 License:        TrueCrypt License Version 3.0
17 Group:          Base/Kernel
18 Source0:        http://www.truecrypt.org/download/transient/0d3fab254298c015e75a/TrueCrypt%20%{version}%20Source.tar.gz
19 # Source0-md5:  102d9652681db11c813610882332ae48
20 Source1:        http://downloads.sourceforge.net/wxwindows/wxWidgets-%{wx_ver}.tar.bz2
21 # Source1-md5:  4103e37e277abeb8aee607b990c215c4
22 Source2:        ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11.h
23 # Source2-md5:  713ac88786b436a5df02bface7dfce45
24 Source3:        ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11f.h
25 # Source3-md5:  652434a5793eb14aae7b5baa07f6cfc7
26 Source4:        ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/pkcs11t.h
27 # Source4-md5:  aeebc839b98e672982abf566e6a25525
28 URL:            http://www.truecrypt.org/
29 BuildRequires:  gcc >= 5:4.0.0
30 %{?with_gui:BuildRequires:      gtk+2-devel}
31 BuildRequires:  libfuse-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpm >= 4.4.9-56
35 BuildRequires:  rpmbuild(macros) >= 1.379
36 %{?with_gui:BuildRequires:      xorg-lib-libSM-devel}
37 Requires:       device-mapper
38 Requires:       losetup
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %if %{with gcc4}
42 # add suffix, but allow ccache, etc in ~/.rpmmacros
43 %{expand:%%define       __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
44 %{expand:%%define       __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
45 %{expand:%%define       __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
46 %endif
47
48 %description
49 Main Features:
50 - Creates a virtual encrypted disk within a file and mounts it as a
51   real disk.
52 - Encrypts an entire hard disk partition or a storage device such as
53   USB flash drive.
54 - Encryption is automatic, real-time (on-the-fly) and transparent.
55 - Provides two levels of plausible deniability, in case an adversary
56   forces you to reveal the password:
57   1) Hidden volume (steganography).
58   2) No TrueCrypt volume can be identified (volumes cannot be
59   distinguished from random data).
60 - Encryption algorithms: AES-256, Blowfish (448-bit key), CAST5,
61   Serpent, Triple DES, and Twofish. Mode of operation: LRW (CBC
62   supported as legacy).
63
64 %description -l pl.UTF-8
65 Główne cechy:
66 - Tworzenie wirtualnego szyfrowanego dysku w pliku i montowanie go
67   jako prawdziwego dysku.
68 - Szyfrowanie całej partycji twardego dysku lub urządzenia takiego jak
69   dysk flash USB.
70 - Szyfrowanie automatyczne, w czasie rzeczywistym i przezroczyste.
71 - Dwa poziomy prawdopodobnych utrudnień, w przypadku, gdy wróg zmusza
72   do wyjawienia hasła:
73   1) Ukryty wolumen (steganografia).
74   2) Żaden wolumen TrueCrypt nie może być zidentyfikowany (wolumeny
75   nie dadzą się odróżnić od losowych danych).
76 - Algorytmy szyfrowania: AES-256, Blowfish (klucz 448-bitowy), CAST5,
77   Serpent, Triple DES oraz Twofish. Tryby działania: LRW (CBC
78   obsługiwane dla wstecznej kompatybilności).
79
80 %prep
81 %setup -q -n %{name}-%{version}-source -a1
82 cp %{SOURCE2} %{SOURCE3} %{SOURCE4} .
83
84
85 %build
86 %{__make} wxbuild \
87         CC="%{__cc}" \
88         CXX="%{__cxx}" \
89         CFLAGS="%{rpmcflags}" \
90         CXXFLAGS="%{rpmcxxflags}" \
91         WX_ROOT=%{_builddir}/%{name}-%{version}-source/wxWidgets-%{wx_ver} \
92         %{!?with_gui:NOGUI=1} \
93         VERBOSE=1
94 %{__make} \
95         %{!?with_gui:NOGUI=1} \
96         WXSTATIC=1
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
101
102 install Main/truecrypt $RPM_BUILD_ROOT%{_bindir}/truecrypt
103 mv -f Release/Setup\ Files/TrueCrypt\ User\ Guide.pdf TrueCrypt-User-Guide.pdf
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc License.txt Readme.txt TrueCrypt-User-Guide.pdf
111 %attr(755,root,root) %{_bindir}/%{name}
112 ##%%{_mandir}/man1/*
This page took 0.116987 seconds and 3 git commands to generate.