]> git.pld-linux.org Git - packages/tripwire.git/blob - tripwire.spec
ba26a187824a22087ee1c3ccb59c134ef26d2f89
[packages/tripwire.git] / tripwire.spec
1 # TODO:
2 # - post install
3 # - cron scripts (contrib)
4 #
5 # Conditional build:
6 %bcond_without  static  # don't link statically
7 #
8 Summary:        Verifies file integrity
9 Summary(pl.UTF-8):      Program sprawdza poprawność plików
10 Name:           tripwire
11 Version:        2.4.2.1
12 Release:        0.2
13 License:        GPL v2
14 Group:          Applications/System
15 Source0:        http://downloads.sourceforge.net/tripwire/%{name}-%{version}-src.tar.bz2
16 # Source0-md5:  2463cde5c75adbab2ce5fdb64aec94f1
17 Source1:        %{name}.verify
18 Source2:        %{name}-tw.cfg
19 Source3:        README.SuSE
20 Patch0:         %{name}-sec.patch
21 Patch1:         off_t.patch
22 Patch2:         policyconfig.patch
23 Patch3:         %{name}-gcc47.patch
24 URL:            http://sourceforge.net/projects/tripwire/
25 %{?with_static:BuildRequires:   glibc-static}
26 BuildRequires:  libstdc++-devel
27 Requires:       crondaemon
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _cron           %{_sysconfdir}/cron.daily
31
32 %description
33 Tripwire is a file integrity checker - a utility that compares a
34 designated set of files and directories against information stored in
35 a previously generated database. Added or deleted files are flagged
36 and reported, as are any files that have changed from their previously
37 recorded state in the database. When run against system files on a
38 regular basis, any file changes would be spotted when Tripwire is next
39 run, giving system administrators information to enact damage control
40 measures immediately.
41
42 %prep
43 %setup -q
44 %patch1 -p1
45 %patch2 -p1
46 %patch3 -p1
47 install %{SOURCE3} .
48
49 %build
50 %configure --sysconfdir=/etc/tripwire
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/{man4,man5,man8},%{_sysconfdir}/%{name}}
56 install -d $RPM_BUILD_ROOT{%{_var}/{spool/%{name},lib/%{name}},%{_cron}}
57
58 install bin/* $RPM_BUILD_ROOT%{_sbindir}
59 install man/man4/*.4 $RPM_BUILD_ROOT%{_mandir}/man4
60 install man/man5/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
61 install man/man8/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
62 install policy/twpol-Linux.txt $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/twpol.txt
63 install %{SOURCE1} $RPM_BUILD_ROOT%{_cron}
64 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/twcfg.txt
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc MAINTAINERS ChangeLog README.SuSE TRADEMARK policy/policyguide.txt
72 %attr(700,root,root) %{_sbindir}/*
73 %dir %attr(700,root,root) %{_sysconfdir}/%{name}
74 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/twpol.txt
75 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/twcfg.txt
76 %attr(700,root,root) %{_var}/spool/%{name}
77 %attr(700,root,root) %{_var}/lib/%{name}
78 %attr(700,root,root) %{_cron}/%{name}.verify
79 %{_mandir}/man*/*
This page took 0.043256 seconds and 2 git commands to generate.