]> git.pld-linux.org Git - packages/tre.git/blob - tre.spec
af722746eefb0744a1052e4349c466fd997dcc14
[packages/tre.git] / tre.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static lirbary
4
5 Summary:        TRE: approximate regex matching
6 Summary(pl.UTF-8):      TRE - przybliżone dopasowywanie wyrażeń regularnych
7 Name:           tre
8 Version:        0.8.0
9 Release:        3
10 License:        BSD
11 Group:          Applications/Text
12 #Source0Download: http://laurikari.net/tre/download/
13 Source0:        http://laurikari.net/tre/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b4d3232593dadf6746f4727bdda20b41
15 URL:            http://laurikari.net/tre/
16 Provides:       agrep
17 Obsoletes:      agrep
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 TRE is a lightweight, robust, and efficient POSIX compliant regexp
22 matching library with some exciting features such as approximate
23 (fuzzy) matching.
24
25 This package also contains agrep (approximate grep) tool for
26 approximate regexp matching in the style of grep.
27
28 %description -l pl.UTF-8
29 TRE jest lekką i wydajną biblioteką dopasowań przy użyciu wyrażeń
30 regularnych, zgodną ze standardem POSIX oraz oferującą kilka
31 przydatnych funkcji, jak np. dopasowywanie przybliżone (rozmyte).
32
33 Pakiet zawiera także narzędzie agrep (przybliżony grep) do
34 przybliżonego dopasowywania przy użyciu wyrażeń regularnych w stylu
35 grepa.
36
37 %package devel
38 Summary:        Header files for tre library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki tre
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for tre library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki tre.
48
49 %package static
50 Summary:        Static tre library
51 Summary(pl.UTF-8):      Statyczna bibloteka tre
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static tre library.
57
58 %description static -l pl.UTF-8
59 Statyczna bibloteka tre.
60
61 %prep
62 %setup -q
63
64 %build
65 %configure \
66         %{?with_static_libs:--enable-static}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %find_lang %{name}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{name}.lang
84 %defattr(644,root,root,755)
85 %doc AUTHORS ChangeLog NEWS README THANKS TODO
86 %attr(755,root,root) %{_bindir}/agrep
87 %attr(755,root,root) %{_libdir}/libtre.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libtre.so.5
89 %{_mandir}/man1/agrep.1*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_libdir}/libtre.so
94 %{_libdir}/libtre.la
95 %{_includedir}/tre
96 %{_pkgconfigdir}/tre.pc
97
98 %if %{with static_libs}
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libtre.a
102 %endif
This page took 0.110997 seconds and 2 git commands to generate.