]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- fix x86_64 again (are we there yet ?)
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 #
7 # Conditional build:
8 %bcond_without  avifile         # disable avifile module
9 %bcond_without  gtk                     # disable GTK+ dependent stuff
10 %bcond_without  im                      # disable imagemagick module
11 %bcond_without  libmpeg2        # disable libmpeg2 support
12 %bcond_without  libmpeg3        # disable libmpeg3 support
13 %bcond_without  lzo                     # disable lzo support
14 %bcond_without  mjpeg           # disable mjpegtools support
15 %bcond_without  sdl                     # disable SDL support
16 %bcond_with     jpegmmx         # jpeg-mmx
17 %bcond_with     pvm3            # pvm3
18
19 # no jpeg-mmx there (doesn't compile)
20 %ifnarch i586 i686 athlon
21 %undefine       with_jpegmmx
22 %endif
23 # pvm3 needs recompiled with -fPIC
24 %ifarch %{x8664} alpha
25 %undefine       with_pvm3
26 %endif
27 #
28 Summary:        Video stream converter
29 Summary(pl):    Konwerter strumieni video
30 Name:           transcode
31 Version:        1.0.2
32 Release:        1.2
33 License:        GPL
34 Group:          Applications
35 Source0:        http://www.jakemsr.com/transcode/%{name}-%{version}.tar.gz
36 # Source0-md5:  e353c0ab7e927a8672528e05a9ae960b
37 Patch0:         %{name}-ac.patch
38 Patch1:         %{name}-lzo2.patch
39 Patch2:         %{name}-bigdir.patch
40 Patch3:         %{name}-mpeg3.patch
41 Patch4:         %{name}-libx86_64.patch
42 URL:            http://www.transcoding.org/
43 BuildRequires:  xorg-lib-libXaw-devel
44 BuildRequires:  xorg-lib-libXpm-devel
45 %{?with_im:BuildRequires:       ImageMagick-devel >= 5.4.3}
46 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
47 BuildRequires:  a52dec-libs-devel
48 BuildRequires:  autoconf
49 BuildRequires:  automake >= 1.3
50 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
51 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
52 BuildRequires:  freetype-devel >= 2.1.2
53 %{?with_gtk:BuildRequires:      gtk+-devel}
54 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
55 BuildRequires:  lame-libs-devel >= 3.89
56 BuildRequires:  libdv-devel >= 0.104-3
57 BuildRequires:  libdvdread-devel
58 BuildRequires:  libfame-devel
59 BuildRequires:  libjpeg-devel
60 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
61 BuildRequires:  libogg-devel
62 BuildRequires:  libpng-devel
63 %{?with_quicktime:BuildRequires:        libquicktime-devel}
64 BuildRequires:  libstdc++-devel
65 BuildRequires:  libtheora-devel
66 BuildRequires:  libtool >= 2:1.5
67 BuildRequires:  libvorbis-devel
68 BuildRequires:  libxml2-devel
69 %{?with_lzo:BuildRequires:      lzo-devel}
70 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
71 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
72 %ifarch %{ix86}
73 BuildRequires:  nasm >= 0.98.34
74 %endif
75 BuildRequires:  pkgconfig
76 %{?with_pvm3:BuildRequires:     pvm-devel}
77 BuildRequires:  xvid-devel
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         specflags       -fomit-frame-pointer
81
82 %description
83 Linux Video Stream Processing Tool.
84
85 %description -l pl
86 Linuksowe narzêdzie do obróbki strumieni video.
87
88 %package avilib
89 Summary:        library to handle avi files from transcode
90 Summary(pl):    biblioteka do obróbki plików avi pochodz±ca z transcode
91 Group:          Development/Libraries
92
93 %description avilib
94 Avilib is part of transcode made accessible for other programs that
95 require it. So far I know of one such program - ogmtools.
96
97 %description avilib -l pl
98 Avifile jest czê¶ci± programu transcode udostêpnion± dla innych
99 programów, które jej wymagaj±. Jak na razie znam jeden taki program -
100 ogmtools.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p0
107 %patch3 -p0
108 %patch4 -p0
109
110 %build
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
117 # or divx4linux itself (make bcond_with if you want it)
118 %configure \
119         ac_cv_header_decore_h=no \
120         ac_cv_header_encore2_h=no \
121 %ifarch ppc
122         --disable-altivec \
123 %endif
124 %ifarch %{ix86} %{x8664}
125         --enable-mmx \
126         --enable-3dnow \
127         --enable-sse \
128         --enable-sse2 \
129 %endif
130 %ifarch %{ix86}
131 %ifarch i386 i486 i586 \
132         --disable-cmov-extension \
133 %else
134         --enable-cmov-extension \
135 %endif
136 %endif
137         --disable-bktr \
138         --disable-bsdav \
139         --disable-sunau \
140         --enable-a52 \
141         --enable-a52-default-decoder \
142         --enable-freetype2 \
143         --%{!?with_gtk:dis}%{?with_gtk:en}able-gtk \
144         --enable-ibp \
145         --enable-iconv \
146         --enable-imagemagick \
147         --enable-lame \
148         --enable-libavcodec \
149         --enable-libdv \
150         --enable-libdvdread \
151         --enable-libfame \
152         --enable-libjpeg \
153         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
154         --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
155         --enable-libpostproc \
156         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
157         --enable-libxml2 \
158         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
159         --with-lzo-includes=%{_includedir}/lzo \
160         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
161         --enable-netstream \
162         --enable-ogg \
163         --enable-oss \
164         --enable-sdl \
165         --enable-statbuffer \
166         --enable-theora \
167         --enable-v4l \
168         --enable-vorbis \
169         --enable-xio \
170         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
171         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
172         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
173         --with-libpostproc-includes=%{_includedir}/postproc \
174         --with-x
175
176 %{__make}
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180
181 %{__make} install \
182         DESTDIR=$RPM_BUILD_ROOT
183
184 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
185
186 # duplicate
187 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc README ChangeLog docs/README* docs/*.txt docs/html
195 %attr(755,root,root) %{_bindir}/*
196 # TODO: split it into subpackages export-*, import-* and filter-*
197 %dir %{_libdir}/%{name}
198 %attr(755,root,root) %{_libdir}/%{name}/*.so*
199 %attr(755,root,root) %{_libdir}/%{name}/*.awk
200 %{_libdir}/%{name}/*.la
201 %{_libdir}/%{name}/*.conf
202 %{_libdir}/%{name}/*.cfg
203 %{_mandir}/man1/*
204
205 %files avilib
206 %defattr(644,root,root,755)
207 %doc avilib/README.avilib
208 %{_includedir}/avilib.h
This page took 0.053398 seconds and 3 git commands to generate.