]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
- rel up
[packages/transcode.git] / transcode.spec
1 # TODO:
2 # - split plugins into subpackages. (how? splitting criteria? perhaps by external deps, not by functionality (import/export/..?)
3 # - disable building of libraries which exist in system (libdv?,libmpeg2 etc.)
4 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
5 # - pvm3 needs recompiled with -fPIC, then it can be used here
6 # - --enable-xio requires some libs from http://loci.cs.utk.edu/
7 # - rm Makefiles from htmldir
8 #
9 # Conditional build:
10 %bcond_without  avifile         # disable avifile module
11 %bcond_without  gtk                     # disable GTK+ dependent stuff
12 %bcond_without  im                      # disable imagemagick module
13 %bcond_without  libmpeg2        # disable libmpeg2 support
14 %bcond_without  libmpeg3        # disable libmpeg3 support
15 %bcond_without  lzo                     # disable lzo support
16 %bcond_without  mjpeg           # disable mjpegtools support
17 %bcond_without  quicktime       # disable libquicktime support
18 %bcond_without  sdl                     # disable SDL support
19 %bcond_with     jpegmmx         # jpeg-mmx
20 %bcond_with     pvm3            # pvm3
21
22 # no jpeg-mmx there (doesn't compile)
23 %ifnarch i586 i686 athlon
24 %undefine       with_jpegmmx
25 %endif
26 # pvm3 needs recompiled with -fPIC
27 %ifarch %{x8664} alpha
28 %undefine       with_pvm3
29 %endif
30 #
31 Summary:        Video stream converter
32 Summary(pl.UTF-8):      Konwerter strumieni video
33 Name:           transcode
34 Version:        1.0.5
35 Release:        4
36 License:        GPL
37 Group:          Applications
38 Source0:        http://fromani.exit1.org/%{name}-%{version}.tar.bz2
39 # Source0-md5:  124a6055d304fa2d8577d7380e2bcb0c
40 Patch0:         %{name}-lzo2.patch
41 Patch1:         %{name}-bigdir.patch
42 Patch2:         %{name}-libx86_64.patch
43 Patch3:         %{name}-mm_accel.patch
44 Patch4:         %{name}-compile_nuv.patch
45 Patch5:         %{name}-ImageMagick.patch
46 URL:            http://www.transcoding.org/
47 %{?with_im:BuildRequires:       ImageMagick-devel >= 6.4.1-2}
48 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
49 BuildRequires:  a52dec-libs-devel
50 BuildRequires:  autoconf
51 BuildRequires:  automake >= 1.3
52 %{?with_avifile:BuildRequires:  avifile-devel > 3:0.7.43-1}
53 BuildRequires:  ffmpeg-devel >= 0.4.9-0.pre1
54 BuildRequires:  freetype-devel >= 2.1.2
55 %{?with_gtk:BuildRequires:      gtk+-devel}
56 %{?with_jpegmmx:BuildRequires:  jpeg-mmx}
57 BuildRequires:  lame-libs-devel >= 3.89
58 BuildRequires:  libdv-devel >= 0.104-3
59 BuildRequires:  libdvdread-devel
60 BuildRequires:  libfame-devel >= 0.9.1
61 BuildRequires:  libjpeg-devel
62 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
63 BuildRequires:  libogg-devel
64 BuildRequires:  libpng-devel
65 %{?with_quicktime:BuildRequires:        libquicktime-devel}
66 BuildRequires:  libstdc++-devel
67 BuildRequires:  libtheora-devel
68 BuildRequires:  libtool >= 2:1.5
69 BuildRequires:  libvorbis-devel
70 BuildRequires:  libxml2-devel
71 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
72 %{?with_mjpeg:BuildRequires:    mjpegtools-devel}
73 %{?with_libmpeg2:BuildRequires: mpeg2dec-devel >= 0.4.0b}
74 %ifarch %{ix86}
75 BuildRequires:  nasm >= 0.98.34
76 %endif
77 BuildRequires:  pkgconfig
78 %{?with_pvm3:BuildRequires:     pvm-devel}
79 BuildRequires:  xorg-lib-libXaw-devel
80 BuildRequires:  xorg-lib-libXpm-devel
81 BuildRequires:  xvid-devel
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         specflags       -fomit-frame-pointer
85
86 %description
87 Linux Video Stream Processing Tool.
88
89 %description -l pl.UTF-8
90 Linuksowe narzędzie do obróbki strumieni video.
91
92 %package avilib
93 Summary:        library to handle avi files from transcode
94 Summary(pl.UTF-8):      biblioteka do obróbki plików avi pochodząca z transcode
95 Group:          Development/Libraries
96
97 %description avilib
98 Avilib is part of transcode made accessible for other programs that
99 require it. So far I know of one such program - ogmtools.
100
101 %description avilib -l pl.UTF-8
102 Avifile jest częścią programu transcode udostępnioną dla innych
103 programów, które jej wymagają. Jak na razie znam jeden taki program -
104 ogmtools.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p0
110 %patch2 -p0
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114
115 %build
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
122 # or divx4linux itself (make bcond_with if you want it)
123 %configure \
124         ac_cv_header_decore_h=no \
125         ac_cv_header_encore2_h=no \
126 %ifarch ppc
127         --enable-altivec \
128 %endif
129 %ifarch %{ix86} %{x8664}
130         --enable-mmx \
131         --enable-3dnow \
132         --enable-sse \
133         --enable-sse2 \
134 %endif
135 %ifarch %{ix86}
136 %ifarch i386 i486 i586 \
137         --disable-cmov-extension \
138 %else
139         --enable-cmov-extension \
140 %endif
141 %endif
142         --disable-bktr \
143         --disable-bsdav \
144         --disable-sunau \
145         --enable-a52 \
146         --enable-a52-default-decoder \
147         --enable-freetype2 \
148         --%{!?with_gtk:dis}%{?with_gtk:en}able-gtk \
149         --enable-ibp \
150         --enable-iconv \
151         --%{!?with_im:dis}%{?with_im:en}able-imagemagick \
152         --enable-lame \
153         --enable-libavcodec \
154         --enable-libdv \
155         --enable-libdvdread \
156         --enable-libfame \
157         --enable-libjpeg \
158         --%{!?with_libmpeg2:dis}%{?with_libmpeg2:en}able-libmpeg2 \
159         --%{!?with_libmpeg3:dis}%{?with_libmpeg3:en}able-libmpeg3 \
160         --enable-libpostproc \
161         --%{!?with_quicktime:dis}%{?with_quicktime:en}able-libquicktime \
162         --enable-libxml2 \
163         --%{!?with_lzo:dis}%{?with_lzo:en}able-lzo \
164         --with-lzo-includes=%{_includedir}/lzo \
165         --%{!?with_mjpeg:dis}%{?with_mjpeg:en}able-mjpegtools \
166         --enable-netstream \
167         --enable-ogg \
168         --enable-oss \
169         --enable-sdl \
170         --enable-statbuffer \
171         --enable-theora \
172         --enable-v4l \
173         --enable-vorbis \
174         --disable-xio \
175         --%{!?with_avifile:dis}%{?with_avifile:en}able-avifile \
176         --%{!?with_jpegmmx:dis}%{?with_jpegmmx:en}able-libjpegmmx \
177         --%{!?with_pvm3:dis}%{?with_pvm3:en}able-pvm3 \
178         --with-libpostproc-includes=%{_includedir}/postproc \
179         --with-x
180
181 %{__make}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT
188
189 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
190
191 # duplicate
192 rm -rf $RPM_BUILD_ROOT%{_docdir}/transcode
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files
198 %defattr(644,root,root,755)
199 %doc README ChangeLog docs/README* docs/*.txt docs/html
200 %attr(755,root,root) %{_bindir}/*
201 # TODO: split it into subpackages export-*, import-* and filter-*
202 %dir %{_libdir}/%{name}
203 %attr(755,root,root) %{_libdir}/%{name}/*.so*
204 %attr(755,root,root) %{_libdir}/%{name}/*.awk
205 %{_libdir}/%{name}/*.la
206 %{_libdir}/%{name}/*.conf
207 %{_libdir}/%{name}/*.cfg
208 %{_mandir}/man1/*
209
210 %files avilib
211 %defattr(644,root,root,755)
212 %doc avilib/README.avilib
213 %{_includedir}/avilib.h
This page took 0.046289 seconds and 3 git commands to generate.