]> git.pld-linux.org Git - packages/transcode.git/blob - transcode.spec
9162251a73ba16a1a4dec4fde1d95fda571d10a1
[packages/transcode.git] / transcode.spec
1 #
2 # todo:
3 # - split plugins into subpackages
4 # - disable building of libraries which exist in system (libdv,libmpeg2 etc.)
5 # - cmov test is broken, ignores --enable-cmov-extension and tries to read /proc/cpuinfo
6 #
7 # Conditional build:
8 %bcond_without gtk              # disable GTK+ dependent stuff
9 %bcond_without avifile          # disable avifile module
10 %bcond_without sdl              # disable SDL support
11 %bcond_without im               # disable imagemagick module
12 %bcond_without libmpeg3         # disable libmpeg3 support
13 %bcond_without quicktime        # disable quicktime support
14 #
15 Summary:        Video stream converter
16 Summary(pl):    Konwerter strumieni video
17 Name:           transcode
18 Version:        0.6.12
19 Release:        6
20 License:        GPL
21 Group:          Applications
22 Source0:        http://www.zebra.fh-weingarten.de/~transcode/pre/%{name}-%{version}.tar.gz
23 # Source0-md5:  550214ed9f85224423ca8c7308ed96ce
24 Patch0:         %{name}-altivec.patch
25 Patch1:         %{name}-pic.patch
26 Patch2:         %{name}-amfix.patch
27 URL:            http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/
28 %{?with_im:BuildRequires:       ImageMagick-devel >= 5.4.3}
29 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.6}
30 BuildRequires:  XFree86-devel
31 BuildRequires:  a52dec-libs-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake >= 1.3
34 %{?with_avifile:BuildRequires:  avifile-devel >= 3:0.7.32-0.20030219}
35 BuildRequires:  freetype-devel >= 2.1.2
36 BuildRequires:  glib-devel >= 0.99.7
37 %{?with_gtk:BuildRequires:      gtk+-devel}
38 BuildRequires:  lame-libs-devel >= 3.89
39 BuildRequires:  libdv-devel
40 BuildRequires:  libdvdread-devel
41 BuildRequires:  libfame-devel
42 BuildRequires:  libjpeg-devel
43 %{?with_libmpeg3:BuildRequires: libmpeg3-devel}
44 # liblve-devel ???
45 BuildRequires:  libogg-devel
46 BuildRequires:  libtheora-devel
47 BuildRequires:  libtool >= 2:1.5
48 BuildRequires:  libvorbis-devel
49 BuildRequires:  libxml2-devel
50 BuildRequires:  lzo-devel
51 BuildRequires:  mjpegtools-devel
52 %ifarch %{ix86}
53 BuildRequires:  nasm >= 0.98.34
54 %endif
55 %{?with_quicktime:BuildRequires:        quicktime4linux-devel >= 1.5.5}
56 BuildRequires:  xvid-devel
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         specflags       -fomit-frame-pointer
60
61 %description
62 Linux Video Stream Processing Tool.
63
64 %description -l pl
65 Linuksowe narzêdzie do obróbki strumieni video.
66
67 %package avilib
68 Summary:        library to handle avi files from transcode
69 Summary(pl):    biblioteka do obróbki plików avi pochodz±ca z transcode
70 Group:          Development/Libraries
71
72 %description avilib
73 Avilib is part of transcode made accessible for other programs that
74 require it. So far I know of one such program - ogmtools.
75
76 %description avilib -l pl
77 Avifile jest czê¶ci± programu transcode udostêpnion± dla innych
78 programów, które jej wymagaj±. Jak na razie znam jeden taki program -
79 ogmtools.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 # ac_cv_* to avoid detection of libdivxdecore as divx4linux (leading to errors)
94 # or divx4linux itself (make bcond_with if you want it)
95 %configure \
96         ac_cv_header_decore_h=no \
97         ac_cv_header_encore2_h=no \
98 %ifarch ppc
99         --disable-altivec \
100 %endif
101 %ifarch %{ix86}
102 %ifarch i386 i486 i586 \
103         --disable-cmov-extension \
104 %else
105         --enable-cmov-extension \
106 %endif
107 %endif
108         --with-a52 \
109         --with-a52-include=%{_prefix} \
110         --with-a52-libs=%{_prefix} \
111         --with-avifile-mods \
112         --with-avifile-exec-prefix=%{_prefix} \
113         --with-dv \
114         --with-dv-includes=%{_prefix} \
115         --with-dv-libs=%{_prefix} \
116         --with-dvdread \
117         --with-dvdread-includes=%{_prefix} \
118         --with-dvdread-libs=%{_prefix} \
119         --with-gtk-prefix=%{_prefix} \
120         --with-gtk-exec-prefix=%{_prefix} \
121         --with-lame \
122         --with-lame-includes=%{_prefix} \
123         --with-lame-libs=%{_prefix} \
124         --with-libfame-prefix=%{_prefix} \
125         --with-libfame-exec-prefix=%{_prefix} \
126         --with-libjpeg-mods \
127         --with-libmpeg3 \
128         --with-libmpeg3-includes=%{_prefix} \
129         --with-libmpeg3-libs=%{_prefix} \
130         --with-magick-mods \
131         --with-magick-exec-prefix=%{_prefix} \
132         --with-mod-path=%{_libdir}/transcode \
133         --with-ogg \
134         --with-ogg-includes=%{_prefix} \
135         --with-ogg-libs=%{_prefix} \
136         --with-qt \
137         --with-qt-includes=%{_prefix} \
138         --with-qt-libs=%{_prefix} \
139         --with-sdl-prefix=%{_prefix} \
140         --with-sdl-exec-prefix=%{_prefix} \
141         --with-vorbis \
142         --with-vorbis-includes=%{_prefix} \
143         --with-vorbis-libs=%{_prefix} \
144         --with-x \
145         --without-pvm3
146
147 %{__make}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install -D avilib/avilib.h $RPM_BUILD_ROOT%{_includedir}/avilib.h
156 install -D avilib/libavi.a $RPM_BUILD_ROOT%{_libdir}/libavi.a
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files
162 %defattr(644,root,root,755)
163 %doc README ChangeLog docs/README* docs/*.txt docs/html
164 %attr(755,root,root) %{_bindir}/*
165 # todo: split it into subpackages export-*, import-* and filter-*
166 %dir %{_libdir}/%{name}
167 %attr(755,root,root) %{_libdir}/%{name}/*.so*
168 %attr(755,root,root) %{_libdir}/%{name}/*.awk
169 %{_libdir}/%{name}/*.la
170 %{_libdir}/%{name}/*.conf
171 %{_libdir}/%{name}/*.cfg
172 %{_mandir}/man1/*
173
174 %files avilib
175 %defattr(644,root,root,755)
176 %doc avilib/README.avilib
177 %{_includedir}/avilib.h
178 %{_libdir}/libavi.a
This page took 0.036842 seconds and 2 git commands to generate.