]> git.pld-linux.org Git - packages/traceroute.git/blob - traceroute.spec
- x32 rebuild
[packages/traceroute.git] / traceroute.spec
1 #
2 # Conditional build:
3 %bcond_without  idn     # IDN support
4 #
5 %if "%{pld_release}" == "ac"
6 # too old glibc (no AI_IDN support) in Ac
7 %undefine       with_idn
8 %endif
9 Summary:        Traces the route taken by packets over a TCP/IP network
10 Summary(de.UTF-8):      Verfolgt die Route von Paketen über ein TCP/IP-Netzwerk
11 Summary(es.UTF-8):      Enseña la ruta que los paquetes usan a través de una red TCP/IP
12 Summary(fr.UTF-8):      Détermine le route empruntée par les paquets sur un réseau TCP/IP
13 Summary(pl.UTF-8):      Program do śledzenia trasy pakietów przez sieć TCP/IP
14 Summary(pt_BR.UTF-8):   Mostra a rota que os pacotes usam através de uma rede TCP/IP
15 Summary(ru.UTF-8):      Показывает трассу, по которой проходят пакеты в TCP/IP сети
16 Summary(tr.UTF-8):      TCP/IP ağlarında paketlerin rotasını izler
17 Summary(uk.UTF-8):      Показує трасу, якою проходять пакети по TCP/IP мережі
18 Summary(zh_CN.UTF-8):   [系统]检查网络联通路径的工具
19 Name:           traceroute
20 Version:        2.0.20
21 Release:        2
22 License:        BSD
23 Group:          Networking/Utilities
24 Source0:        http://downloads.sourceforge.net/traceroute/%{name}-%{version}.tar.gz
25 # Source0-md5:  559f104e155e0e14ee0c717776a745fa
26 Patch0:         %{name}-AI_IDN.patch
27 URL:            http://traceroute.sourceforge.net/
28 BuildRequires:  rpm >= 4.4.9-56
29 Obsoletes:      traceroute-nanog
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The traceroute utility displays the route used by IP packets on their
34 way to a specified network (or Internet) host. Traceroute displays the
35 IP number and host name (if possible) of the machines along the route
36 taken by the packets. Traceroute is used as a network debugging tool.
37 If you're having network connectivity problems, traceroute will show
38 you where the trouble is coming from along the route.
39
40 %description -l de.UTF-8
41 Traceroute druckt die Route, die von den Paketen über ein TCP/IP
42 eingeschlagen wird. Die Namen (bzw. die IP-Nummern, wenn keine Namen
43 verfügbar sind) der Maschinen, die beim Routing beteiligt sind,
44 angefangen vom Rechner, auf dem Tracerout läuft, bis zum Ziel, werden
45 ausgedruckt, zusammen mit der Zeit bis zum Erhalt der
46 'Empfangsbestätigung'. Dieses Tool kann bei der Diagnose von
47 Netzwerkproblemen gute Dienste leisten.
48
49 %description -l es.UTF-8
50 Traceroute imprime la ruta que los paquetes hacen a través de una red
51 TCP/IP. Son impresos los nombres (o números de IP si los nombres no
52 están disponibles) de las máquinas que están en ruta en paquetes de la
53 máquina traceroute, junto con el tiempo que ha llevado para que la
54 máquina reciba el reconocimiento (ack) del paquete. Esta herramienta
55 puede ser muy útil para diagnosticar problemas de red.
56
57 %description -l fr.UTF-8
58 traceroute affiche la route que les paquets prennent avec TCP/IP. Il
59 affiche les noms (ou les numéros IP si les noms ne sont pas
60 disponibles) des machines qui routent les paquets de la machine sur
61 laquelle traceroute s'exécute jusqu'à la machine destination, ainsi
62 que le temps qu'il a fallu pour recevoir un accusé reception de cette
63 machine. Cet outil est très pratique pour diagnostiquer les problèmes
64 réseau
65
66 %description -l pl.UTF-8
67 traceroute wyświetla trasę pakietów do podanego komputera.
68
69 %description -l pt_BR.UTF-8
70 Traceroute imprime a rota que os pacotes fazem através de uma rede
71 TCP/IP. São impressos os nomes (ou números de IP se os nomes não
72 estiverem disponíveis) das máquinas que estão roteando pacotes da
73 máquina traceroute, junto com o tempo que levou para a máquina receber
74 o reconhecimento (ack) do pacote. Esta ferramenta pode ser muito útil
75 para diagnosticar problemas de rede.
76
77 %description -l ru.UTF-8
78 Traceroute выводит путь, который пакеты проходят по сети TCP/IP. Имена
79 (или IP-адреса, если имена недоступны) машин, через которые прошли
80 пакеты по дороге до точки назначения вместе со временем, которое
81 потребовалось для получения подтверждения о получении пакета от этих
82 машин. Эта утилита может быть очень полезна для диагностики сетевых
83 проблем.
84
85 %description -l tr.UTF-8
86 Traceroute, bir TCP/IP ağı boyunca paketlerin izledikleri rotanın
87 dökümünü çıkarır. Çalıştığı makineden hedef makineye kadar olan yol
88 boyunca paketleri yönlendiren her makinenin ismi (ya da IP
89 numaraları), bu makinelerden alındı bilgisinin alınmasına kadar geçen
90 süreyle birlikte listelenir. Ağ sorunlarının belirlenmesinde oldukça
91 yardımcı olabilir.
92
93 %prep
94 %setup -q
95 %{!?with_idn:%patch0 -p1}
96
97 %build
98 %{__make} \
99         CC="%{__cc}" \
100         CPPFLAGS="%{rpmcflags} -D_GNU_SOURCE=1" \
101         LDFLAGS="%{rpmldflags}"
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man8}
106
107 install traceroute/traceroute $RPM_BUILD_ROOT%{_bindir}
108 ln -s traceroute $RPM_BUILD_ROOT%{_bindir}/traceroute6
109 ln -s traceroute $RPM_BUILD_ROOT%{_bindir}/tracert
110
111 cp -a */*.8 $RPM_BUILD_ROOT%{_mandir}/man8
112 echo ".so traceroute.8" > $RPM_BUILD_ROOT%{_mandir}/man8/traceroute6.8
113 echo ".so traceroute.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tracert.8
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc CREDITS ChangeLog README TODO
121 %attr(4754,root,adm) %{_bindir}/traceroute
122 %attr(755,root,root) %{_bindir}/traceroute6
123 %attr(755,root,root) %{_bindir}/tracert
124 %{_mandir}/man8/traceroute.8*
125 %{_mandir}/man8/traceroute6.8*
126 %{_mandir}/man8/tracert.8*
This page took 0.06712 seconds and 3 git commands to generate.