]> git.pld-linux.org Git - packages/tpm2-abrmd.git/blob - tpm2-abrmd.spec
- updated to 3.0.0
[packages/tpm2-abrmd.git] / tpm2-abrmd.spec
1 # TODO: handle selinux policy (--with-sepolicy)
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # unit/emulated integration tests
6
7 Summary:        TPM2 Access Broker and Resource Management Daemon
8 Summary(pl.UTF-8):      Broker dostępu i demon zarządzający zasobami TPM2
9 Name:           tpm2-abrmd
10 Version:        3.0.0
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 #Source0Download: https://github.com/tpm2-software/tpm2-abrmd/releases
15 Source0:        https://github.com/tpm2-software/tpm2-abrmd/releases/download/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  4fd91ea71a48c8ee4d63ab77eb1f17ac
17 URL:            https://github.com/tpm2-software/tpm2-abrmd
18 BuildRequires:  glib2-devel >= 2.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  tpm2-tss-devel >= 2.4.0
22 %if %{with tests}
23 BuildRequires:  cmocka-devel >= 1.0
24 # ss (real iproute2 package required, not the false one provided by vserver-packages)
25 BuildRequires:  /sbin/ss
26 BuildRequires:  iproute2
27 # or ibmswtpm2
28 BuildRequires:  swtpm
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is a system daemon implementing the TPM2 access broker (TAB) &
34 Resource Manager (RM) spec from the TCG. The daemon (tpm2-abrmd) is
35 implemented using GLib and the GObject system.
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera demona będącego implementacją spefycikacji
39 brokera dostępowego TPM2 (TAB) oraz zarządcy zasobów (RM) pochodzących
40 z TCG. Demon jest zaimplementowany przy użyciu bibliotek GLib i
41 GObject.
42
43 %package devel
44 Summary:        Header files for tpm2-abrmd library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki tpm2-abrmd
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 2.0
49 Requires:       tpm2-tss-devel
50
51 %description devel
52 Header files for tpm2-abrmd library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki tpm2-abrmd.
56
57 %package static
58 Summary:        Static tpm2-abrmd library
59 Summary(pl.UTF-8):      Statyczna biblioteka tpm2-abrmd
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static tpm2-abrmd library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka tpm2-abrmd.
68
69 %prep
70 %setup -q
71
72 # set VERSION properly when there is no .git directory
73 %{__sed} -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/%{version}/' configure.ac
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__automake}
80 # PATH for /sbin/ss
81 export PATH=${PATH:+$PATH:}/sbin
82 %configure \
83         %{?with_tests:--enable-integration} \
84         --disable-silent-rules \
85         %{!?with_static_libs:--disable-static-libs} \
86         %{?with_tests:--enable-unit} \
87         --with-dbuspolicydir=%{_datadir}/dbus-1/system.d \
88         --with-systemdpresetdir=/lib/systemd/system-preset \
89         --with-systemdsystemunitdir=%{systemdunitdir}
90
91 %{__make}
92
93 %if %{with tests}
94 %{__make} check
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # obsoleted by pkg-config
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtss2-tcti-tabrmd.la
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS CHANGELOG.md LICENSE README.md
112 %attr(755,root,root) %{_sbindir}/tpm2-abrmd
113 %attr(755,root,root) %{_libdir}/libtss2-tcti-tabrmd.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libtss2-tcti-tabrmd.so.0
115 %{_datadir}/dbus-1/system-services/com.intel.tss2.Tabrmd.service
116 %{_datadir}/dbus-1/system.d/tpm2-abrmd.conf
117 /lib/systemd/system-preset
118 %{systemdunitdir}/tpm2-abrmd.service
119 %{_mandir}/man8/tpm2-abrmd.8*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libtss2-tcti-tabrmd.so
124 %{_includedir}/tss2/tss2-tcti-tabrmd.h
125 %{_pkgconfigdir}/tss2-tcti-tabrmd.pc
126 %{_mandir}/man3/Tss2_Tcti_Tabrmd_Init.3*
127 %{_mandir}/man7/tss2-tcti-tabrmd.7*
128
129 %if %{with static_libs}
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/libtss2-tcti-tabrmd.a
133 %endif
This page took 0.135346 seconds and 3 git commands to generate.