]> git.pld-linux.org Git - packages/tora.git/blob - tora.spec
300890028c0deb8a247aa6e11f4193c807f86351
[packages/tora.git] / tora.spec
1 #
2 # Conditional build:
3 %bcond_with     oracle          # build with oracle support
4 %bcond_with     instantclient   # build oracle support with oracle-instantclient
5 #
6 Summary:        A graphical toolkit for database developers and administrators
7 Summary(pl.UTF-8):      Zestaw graficznych narzędzi dla programistów i administratorów baz danych
8 Name:           tora
9 Version:        2.1.3
10 Release:        2
11 License:        GPL v2
12 Group:          Applications/Databases/Interfaces
13 Source0:        http://downloads.sourceforge.net/tora/%{name}-%{version}.tar.gz
14 # Source0-md5:  ea4a75a9daeaf58492413e3f7fe40293
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-postgresql.patch
17 Patch1:         %{name}-gcc.patch
18 Patch2:         %{name}-build.patch
19 URL:            http://tora.sourceforge.net/
20 BuildRequires:  QtCore-devel
21 BuildRequires:  QtGui-devel
22 BuildRequires:  QtNetwork-devel
23 BuildRequires:  QtSql-devel
24 BuildRequires:  QtXml-devel
25 BuildRequires:  cppunit-devel
26 %{?with_instantclient:BuildRequires:    oracle-instantclient-devel}
27 BuildRequires:  pcre-devel
28 BuildRequires:  postgresql-devel
29 BuildRequires:  qscintilla2-devel
30 BuildRequires:  qt4-build
31 BuildRequires:  qt4-linguist
32 BuildRequires:  xorg-lib-libICE-devel
33 Suggests:       QtSql-pgsql
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %if %{with oracle}
37 # ORACLE_HOME is required for oracle
38 %define _preserve_env %_preserve_env_base ORACLE_HOME
39 %endif
40
41 %description
42 TOra features a schema browser, SQL worksheet, PL/SQL editor and
43 debugger, storage manager, rollback segment monitor, instance manager,
44 and SQL output viewer. Via qt3 it can access PostgreSQL and MySQL
45 directly. Any other database systems can be accessed via ODBC.
46
47 %description -l pl.UTF-8
48 TOra zawiera przeglądarkę schematów, arkusz roboczy SQL, edytor i
49 debugger PL/SQL, zarządcę danych, monitor segmentów wycofań, zarządcę
50 instancji i przeglądarkę wyjścia SQL. Poprzez qt3 może współpracować
51 bezpośrednio z bazami PostgreSQL i MySQL. Inne systemy baz danych mogą
52 być obsługiwane poprzez ODBC.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59
60 rm -f src/moc_*
61
62 %build
63 %{__libtoolize}
64 %{__aclocal} -I config/m4
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --libdir=%{_datadir}/%{name} \
69         --with-qt-libraries=%{_libdir} \
70 %if %{with oracle}
71     %if %{with instantclient}
72         --with-instant-client \
73         --with-oracle-includes=%{_includedir}/oracle/client \
74         --with-oracle-libraries=%{_libdir} \
75     %endif
76         --with-oracle
77 %else
78         --without-oracle
79 %endif
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
91 install src/icons/tora.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
92 cp -a src/templates $RPM_BUILD_ROOT%{_datadir}/%{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc BUGS NEWS README TODO
100 %attr(755,root,root) %{_bindir}/*
101 %dir %{_datadir}/%{name}
102 %{_datadir}/%{name}/help
103 %{_datadir}/%{name}/templates
104 %{_datadir}/%{name}/*.qm
105 %{_desktopdir}/*.desktop
106 %{_pixmapsdir}/*
107 %{_infodir}/tora*
This page took 0.104949 seconds and 2 git commands to generate.