]> git.pld-linux.org Git - packages/tomahawk.git/blob - tomahawk.spec
6ed5c10a9052fe944442f396b511b1781c1e2d60
[packages/tomahawk.git] / tomahawk.spec
1 #
2 # Conditional build:
3 %bcond_without  crashreporter           # crashreporter support
4 # requires post recent qxt additions including qxtsslserver
5 %bcond_with     system_qxt              # use system libqxt package
6
7 %ifarch %{arm} aarch64
8 %undefine       with_crashreporter
9 %endif
10
11 %global libechonest_version %(pkg-config --modversion libechonest 2>/dev/null || echo 1.1.7)
12 %global phonon_version %(pkg-config --modversion phonon 2>/dev/null || echo 4.5.0)
13
14 Summary:        The Social Media Player
15 Name:           tomahawk
16 Version:        0.8.4
17 Release:        0.1
18 License:        GPL v2+
19 Group:          X11/Applications/Multimedia
20 Source0:        http://download.tomahawk-player.org/%{name}-%{version}.tar.bz2
21 # Source0-md5:  04832abe1786edcc55805875b5882445
22 Patch50:        %{name}-0.8.4-taglib_version.patch
23 Patch0:         %{name}-0.8.0-system_qxt.patch
24 URL:            http://tomahawk-player.org/
25 BuildRequires:  QtDBus-devel
26 BuildRequires:  QtGui-devel
27 BuildRequires:  QtNetwork-devel
28 BuildRequires:  QtWebKit-devel
29 BuildRequires:  QtXmlPatterns-devel
30 BuildRequires:  attica-devel >= 0.4.0
31 BuildRequires:  boost-devel
32 BuildRequires:  clucene-core-devel >= 2.3
33 BuildRequires:  gnutls-devel
34 BuildRequires:  kde4-kdelibs-devel
35 BuildRequires:  libechonest-devel >= 2.2
36 BuildRequires:  liblastfm-devel >= 1.0
37 BuildRequires:  phonon-devel >= 4.5.0
38 BuildRequires:  pkgconfig(libjreen) >= 1.1.1
39 BuildRequires:  pkgconfig(liblucene++)
40 BuildRequires:  qca-devel
41 BuildRequires:  qjson-devel >= 0.8.1
42 BuildRequires:  qtkeychain-devel
43 BuildRequires:  qtweetlib-devel >= 0.4
44 BuildRequires:  quazip-devel
45 BuildRequires:  rpmbuild(macros) >= 1.596
46 BuildRequires:  sparsehash-devel
47 BuildRequires:  taglib-devel
48 BuildRequires:  telepathy-qt4-devel
49 BuildRequires:  websocketpp-devel
50 %if %{with system_qxt}
51 BuildRequires:  libqxt-devel >= 0.7
52 %else
53 Provides:       bundled(libqxt) = 0.7
54 %endif
55 Requires:       %{name}-libs = %{version}-%{release}
56 Requires:       desktop-file-utils
57 Requires:       gtk-update-icon-cache
58 Requires:       hicolor-icon-theme
59 Requires:       libechonest >= %{libechonest_version}
60 Requires:       phonon >= %{phonon_version}
61 Requires:       qca-cyrus-sasl
62 Requires:       qca-ossl
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Stop chasing your music across different machines, services and
67 websites. It's time to take the work out of "play". If the song you
68 want to listen to is in your local library, it just plays. If the song
69 is on a remote machine, it just plays. If the song is on the web, or
70 available from your subscription service, it just plays. By
71 abstracting a piece of content's metadata from its file location,
72 users can easily share playlists, listening history and more. It's
73 sort of like Wonka Vision, Tomahawk will reassemble it on the other
74 side. OK, maybe that's not a good analogy... but it's just as
75 delicious.
76
77 %package libs
78 Summary:        Runtime libraries for %{name}
79 Group:          Libraries
80
81 %description libs
82 Runtime libraries for %{name}
83
84 %package devel
85 Summary:        Development files for %{name}
86 Requires:       %{name}-libs = %{version}-%{release}
87
88 %description devel
89 Development files for %{name}
90
91 %prep
92 %setup -q -n %{name}-%{version}%{?pre}
93
94 %if %{with system_qxt}
95 %patch0 -p1
96 rm -rv thirdparty/qxt
97 %endif
98
99 %patch50 -p1
100
101 %build
102 install -d build
103 cd build
104 %cmake \
105         -DBUILD_RELEASE:BOOL=ON \
106         -DBUILD_WITH_QT4:BOOL=ON \
107         -DCMAKE_BUILD_TYPE:STRING="RelWithDebInfo" \
108         -DBUILD_HATCHET:BOOL=ON \
109         -DWITH_CRASHREPORTER:BOOL=%{?with_crashreporter:ON}%{!?with_crashreporter:OFF} \
110         ..
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} -C build install/fast \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 # unpackaged files (fixme?)
120 rm -v $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/tomahawk.svg
121
122 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/tomahawk.desktop
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 %update_desktop_database
129 %update_icon_cache hicolor
130
131 %postun
132 %update_desktop_database
133 %update_icon_cache hicolor
134
135 %post   libs -p /sbin/ldconfig
136 %postun libs -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS LICENSE.txt
141 %attr(755,root,root) %{_bindir}/tomahawk
142 %{_libdir}/libtomahawk_*.so
143 %{_desktopdir}/tomahawk.desktop
144 %{_iconsdir}/hicolor/*/apps/tomahawk.*
145
146 %files libs
147 %defattr(644,root,root,755)
148 %{_libdir}/libtomahawk.so.%{version}
149 %{_libdir}/libtomahawk-playdarapi.so.%{version}
150 %{_libdir}/libtomahawk-widgets.so.%{version}
151
152 %files devel
153 %defattr(644,root,root,755)
154 %{_includedir}/libtomahawk/
155 %{_libdir}/libtomahawk.so
156 %{_libdir}/libtomahawk-playdarapi.so
157 %{_libdir}/libtomahawk-widgets.so
158 %{_libdir}/cmake/Tomahawk/
This page took 0.081916 seconds and 2 git commands to generate.