]> git.pld-linux.org Git - packages/tix.git/blob - tix.spec
- updated to 8.4.3
[packages/tix.git] / tix.spec
1 %define         major 8.4
2 Summary:        Many metawidgets (such as notepads) for Tk
3 Summary(de.UTF-8):      Zahlreiche Metawidgets (wie etwa Notepads) für Tk
4 Summary(fr.UTF-8):      Nombreux meta-widgets (comme les bloc-notes) pour Tk
5 Summary(pl.UTF-8):      Wiele widgetów (takich jak notepad) dla Tk
6 Summary(tr.UTF-8):      Tk için ek arayüz elemanları (not defterleri v.b.)
7 Name:           tix
8 Version:        %{major}.3
9 Release:        1
10 Epoch:          1
11 License:        BSD
12 Group:          Development/Languages/Tcl
13 Source0:        http://download.sourceforge.net/tix/Tix%{version}-src.tar.gz
14 # Source0-md5:  2b8bf4b10a852264678182652f477e59
15 Patch0:         %{name}-scriptpaths.patch
16 Patch2:         fixInterpResult.patch
17 URL:            http://tix.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  tcl-devel >= 8.4.6
21 BuildRequires:  tk-devel >= 8.4.6
22 BuildRequires:  which
23 BuildRequires:  xorg-lib-libX11-devel
24 Requires:       tcl >= 8.4.6
25 Requires:       tk >= 8.4.6
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Tix is a add on for the Tk widget set which adds many complex widgets
30 which are built from Tk building blocks. The extra widgets include
31 combo box, file selection, notebooks, paned windows, spin controls,
32 and hierarchical list boxes.
33
34 %description -l de.UTF-8
35 Tix ist ein Zusatzprogramm für den 'Tk widget set', das viele komplexe
36 Widgets hinzufügt, die aus Tk-Bausteinen bestehen, z.B.
37 Kombinationsfelder, Dateiauswahl, Notizblöcke, überlappende Fenster,
38 Drehknöpfe und hierarchische Listenfelder.
39
40 %description -l fr.UTF-8
41 tix est un ajout à l'ensemble des widgets Tk qui apporte de nombreux
42 widgets complexes construits à partir des briques de Tk. Les widgets
43 supplémentaires incluent les combo box, la sélection de fichiers, les
44 notebooks, les fenêtres « paned » et les listes hiérarchisées.
45
46 %description -l pl.UTF-8
47 Tix jest dodatkiem dla Tk, zawierającym wiele interesujących widgetów.
48
49 %description -l tr.UTF-8
50 Tix, Tk yapıtaşları kullanılarak oluşturulmuş bir çok karmaşık arayüz
51 elemanı bulunduran bir eklemedir. Bu yeni elemanlar arasında çoktan
52 seçmeli kutular, dosya seçim kutuları, not defterleri, çok kısımlı
53 pencereler yer almaktadır.
54
55 %package devel
56 Summary:        Tix development documentation
57 Summary(pl.UTF-8):      Dokumentacja programisty do rozszerzenia Tix
58 Group:          Development/Languages/Tcl
59 Requires:       %{name} = %{epoch}:%{version}-%{release}
60
61 %description devel
62 Tix development documentation.
63
64 %description devel -l pl.UTF-8
65 Dokumentacja programisty do rozszerzenia Tix.
66
67 %package demo
68 Summary:        Tix - demo programs
69 Summary(pl.UTF-8):      Tix - programy demostracjne
70 Group:          Development/Languages/Tcl
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72
73 %description demo
74 Tix - demo programs.
75
76 %description demo -l pl.UTF-8
77 Tix - programy demostracjne.
78
79 %prep
80 %setup -q -n Tix%{version}
81 %patch0 -p1
82 %patch2 -p1
83
84 %build
85 %{__aclocal} -I tclconfig
86 %{__autoconf}
87 %configure \
88         --enable-shared
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_mandir},%{_examplesdir}/%{name}-%{version}}
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install -d $RPM_BUILD_ROOT%{_mandir}/mann
100 install man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
101
102 install -d $RPM_BUILD_ROOT%{_datadir}/groff/current/tmac
103 sed -i -e 's/.so man.macros/.mso tix.tmac/g' $RPM_BUILD_ROOT%{_mandir}/mann/*.n
104 install man/man.macros $RPM_BUILD_ROOT%{_datadir}/groff/current/tmac/tix.tmac
105
106 cp -af demos $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
107
108 rm -f $RPM_BUILD_ROOT%{_libdir}/Tix%{major}/bitmaps/mktransgif.tcl*
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc ABOUT.html ChangeLog README.txt index.html license.terms docs/FAQ.html
116 %dir %{_libdir}/Tix%{version}
117 %attr(755,root,root) %{_libdir}/Tix%{version}/libTix%{version}.so
118 %{_libdir}/Tix%{version}/*.tcl
119 %{_libdir}/Tix%{version}/bitmaps
120 %{_libdir}/Tix%{version}/pref
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc docs/*.txt docs/{pdf,tix-book}
125 %{_mandir}/mann/*
126 %{_datadir}/groff/current/tmac/tix.tmac
127
128 %files demo
129 %defattr(644,root,root,755)
130 %dir %{_examplesdir}/%{name}-%{version}
131 %dir %{_examplesdir}/%{name}-%{version}/demos
132 %{_examplesdir}/%{name}-%{version}/demos/Mk*.tcl
133 %{_examplesdir}/%{name}-%{version}/demos/bitmaps
134 %{_examplesdir}/%{name}-%{version}/demos/samples
135 %{_examplesdir}/%{name}-%{version}/demos/tclIndex
136 %{_examplesdir}/%{name}-%{version}/demos/widget
137 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/demos/tixwidgets.tcl
This page took 0.079426 seconds and 3 git commands to generate.