]> git.pld-linux.org Git - packages/thefuck.git/blob - thefuck.spec
python3.spec hack
[packages/thefuck.git] / thefuck.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 Summary:        App that corrects your previous console command
6 Name:           thefuck
7 Version:        3.2
8 Release:        1
9 License:        MIT
10 Group:          Applications/Shells
11 Source0:        https://github.com/nvbn/thefuck/archive/%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  b2012c223a0ae15cecaa384aa8bbae32
13 URL:            https://github.com/nvbn/thefuck
14 BuildRequires:  python3-devel >= 1:3.4
15 BuildRequires:  python3-pip
16 BuildRequires:  python3-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  sed >= 4.0
20 %if %{with tests}
21 BuildRequires:  python3-colorama
22 BuildRequires:  python3-decorator
23 BuildRequires:  python3-mock
24 BuildRequires:  python3-psutil
25 BuildRequires:  python3-pytest
26 BuildRequires:  python3-six
27 %endif
28 Requires:       python3
29 Requires:       python3-colorama
30 Requires:       python3-psutil
31 Requires:       python3-six
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # provided by python3.spec
36 %define _noautoreq_py3egg pathlib
37
38 %description
39 This application corrects your previous console command.
40
41 See README.md how to setup for your shell.
42
43 %prep
44 %setup -q
45
46 sed -i -e '/^#!\//, 1d' *.py
47
48 %build
49 %py3_build %{?with_tests:test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %py3_install
54
55 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/tests
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README.md LICENSE.md
63 %attr(755,root,root) %{_bindir}/thefuck
64 %attr(755,root,root) %{_bindir}/fuck
65 %attr(755,root,root) %{_bindir}/thefuck-alias
66 %{py3_sitescriptdir}/thefuck
67 %{py3_sitescriptdir}/thefuck-%{version}-*egg-info
This page took 0.087967 seconds and 3 git commands to generate.