]> git.pld-linux.org Git - packages/tevent.git/blob - tevent.spec
- updated to 0.9.22
[packages/tevent.git] / tevent.spec
1 Summary:        An event system library
2 Summary(pl.UTF-8):      Biblioteka systemu zdarzeń
3 Name:           tevent
4 Version:        0.9.22
5 Release:        1
6 License:        LGPL v3+
7 Group:          Libraries
8 Source0:        http://www.samba.org/ftp/tevent/%{name}-%{version}.tar.gz
9 # Source0-md5:  a526afa69137d660f9885ffcb6dea8ac
10 URL:            http://tevent.samba.org/
11 BuildRequires:  talloc-devel >= 2:2.1.1
12 BuildRequires:  python-devel >= 1:2.4.2
13 BuildRequires:  python-talloc-devel >= 2:2.1.1
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Tevent is an event system based on the talloc memory management
20 library. It is the core event system used in Samba.
21
22 The low level tevent has support for many event types, including
23 timers, signals, and the classic file descriptor events.
24
25 Tevent also provide helpers to deal with asynchronous code providing
26 the tevent_req (tevent request) functions.
27
28 %description -l pl.UTF-8
29 Tevent to system zdarzeń oparty na bibliotece zarządzającej pamięcią
30 talloc. Jest to główny system zdarzeń używany w Sambie.
31
32 Niskopoziomowo tevent obsługuje wiele rodzajów zdarzeń, w tym
33 zegary, sygnały i zdarzenia związane z klasycznymi deskryptorami
34 plików.
35
36 Tevent udostępnia także funkcje pomocnicze tevent_req (żądanie tevent)
37 dla kodu asynchronicznego.
38
39 %package devel
40 Summary:        Header files for tevent library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki tevent
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       talloc-devel >= 2:2.1.1
45
46 %description devel
47 Header files for tevent library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki tevent.
51
52 %package -n python-tevent
53 Summary:        Python bindings for tevent
54 Summary(pl.UTF-8):      Pythonowy interfejs do tevent
55 Group:          Libraries/Python
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       python-talloc >= 2.0.8
58 %pyrequires_eq  python-libs
59
60 %description -n python-tevent
61 Python bindings for tevent.
62
63 %description -n python-tevent -l pl.UTF-8
64 Pythonowy interfejs do tevent.
65
66 %prep
67 %setup -q
68
69 %build
70 # note: configure in fact is waf call
71 CC="%{__cc}" \
72 CFLAGS="%{rpmcflags}" \
73 PYTHONDIR=%{py_sitedir} \
74 ./configure \
75         --prefix=%{_prefix} \
76         --libdir=%{_libdir}
77
78 %{__make} \
79         V=1
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
88 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
89 %py_postclean
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libtevent.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libtevent.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libtevent.so
105 %{_includedir}/tevent.h
106 %{_pkgconfigdir}/tevent.pc
107
108 %files -n python-tevent
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{py_sitedir}/_tevent.so
111 %{py_sitedir}/tevent.py[co]
This page took 0.066711 seconds and 3 git commands to generate.