]> git.pld-linux.org Git - packages/test.git/blob - test.spec
check AT_SECURE value on builders
[packages/test.git] / test.spec
1 # skeleton for rpm testing.
2 # create your own test in separate branch, keep master branch clean
3 #
4 # git checkout -b test/feature
5 # git push origin -u test/feature
6 Summary:        testing something
7 Name:           test
8 Version:        1
9 Release:        7
10 License:        GPL
11 Group:          Applications/System
12 URL:            http://www.pld-linux.org/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 testing something
17
18 %prep
19 %setup -qcT
20 cat > test.c <<EOF
21 #include <stdio.h>
22 #include <sys/auxv.h>
23
24 int main() {
25   printf("%lu\n", getauxval(AT_SECURE));
26 }
27 EOF
28 %{__cc} test.c -o test
29 ./test
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT
34
35 %clean
36 rm -rf $RPM_BUILD_ROOT
37
38 %files
39 %defattr(644,root,root,755)
This page took 0.05173 seconds and 3 git commands to generate.