]> git.pld-linux.org Git - packages/test-kitchen.git/blob - test-kitchen.spec
new, version 1.0.0.beta.3
[packages/test-kitchen.git] / test-kitchen.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define         rel             1
6 %define         subver  beta.3
7 Summary:        A Chef convergence integration test harness
8 Name:           test-kitchen
9 Version:        1.0.0
10 Release:        0.%{subver}.%{rel}
11 License:        Apache v2.0
12 Group:          Development/Languages
13 Source0:        http://rubygems.org/downloads/%{name}-%{version}.%{subver}.gem
14 # Source0-md5:  f93168613f72fcca512a0e23d546461f
15 URL:            https://github.com/opscode/test-kitchen
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.656
18 BuildRequires:  sed >= 4.0
19 %if %{with tests}
20 BuildRequires:  ruby-aruba < 1
21 BuildRequires:  ruby-aruba >= 0.5
22 BuildRequires:  ruby-bundler < 2
23 BuildRequires:  ruby-bundler >= 1.3
24 BuildRequires:  ruby-cane
25 BuildRequires:  ruby-countloc
26 BuildRequires:  ruby-fakefs
27 BuildRequires:  ruby-guard-cucumber
28 BuildRequires:  ruby-guard-minitest
29 BuildRequires:  ruby-maruku
30 BuildRequires:  ruby-minitest < 5
31 BuildRequires:  ruby-minitest >= 4.7
32 BuildRequires:  ruby-mocha
33 BuildRequires:  ruby-rake
34 BuildRequires:  ruby-simplecov
35 BuildRequires:  ruby-tailor
36 BuildRequires:  ruby-yard
37 %endif
38 Requires:       ruby-celluloid
39 Requires:       ruby-mixlib-shellout
40 Requires:       ruby-net-scp
41 Requires:       ruby-net-ssh
42 Requires:       ruby-pry
43 Requires:       ruby-rubygems > 1.3.1
44 Requires:       ruby-safe_yaml < 0.10
45 Requires:       ruby-safe_yaml >= 0.9.5
46 Requires:       ruby-thor
47 BuildArch:      noarch
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 A Chef convergence integration test harness.
52
53 %prep
54 %setup -q
55 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
60 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
61 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README.md CHANGELOG.md LICENSE
69 %attr(755,root,root) %{_bindir}/kitchen
70 %{ruby_vendorlibdir}/kitchen.rb
71 %{ruby_vendorlibdir}/kitchen
72 # FIXME should be in subdir of this package, or unvendored
73 %dir %{ruby_vendorlibdir}/vendor
74 %{ruby_vendorlibdir}/vendor/hash_recursive_merge.rb
This page took 0.110827 seconds and 3 git commands to generate.