]> git.pld-linux.org Git - packages/telepathy-qt4.git/blob - telepathy-qt4.spec
- updated to 0.9.5
[packages/telepathy-qt4.git] / telepathy-qt4.spec
1 #
2 # Conditional build:
3 %bcond_without  qt4     # Qt4 interface
4 %bcond_without  qt5     # Qt5 interface
5
6 # "telepathy_qt" name is occupied by earlier work under the same name from different project;
7 # thus spec and repo stick to original "telepathy-qt4" name of this project (used before 0.9.0 release)
8 %define         orgname telepathy-qt
9 %define         qt4_ver         4.8.2
10 %define         qt5_ver         5.0.0
11
12 Summary:        Library for Qt4-based Telepathy clients
13 Summary(pl.UTF-8):      Biblioteka dla klientów Telepathy opartych na Qt4
14 Name:           telepathy-qt4
15 Version:        0.9.5
16 Release:        1
17 License:        LGPL v2.1+
18 Group:          Libraries
19 Source0:        http://telepathy.freedesktop.org/releases/telepathy-qt/%{orgname}-%{version}.tar.gz
20 # Source0-md5:  22c0daa7e4f7e48e779f703c9b27b816
21 URL:            http://telepathy.freedesktop.org/wiki/Telepathy-Qt4
22 BuildRequires:  cmake >= 2.6
23 BuildRequires:  dbus-devel
24 BuildRequires:  dbus-glib-devel
25 BuildRequires:  farstream-devel >= 0.2.0
26 BuildRequires:  glib2-devel >= 2.0
27 BuildRequires:  libxml2-devel >= 2.0
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-dbus
30 BuildRequires:  python-devel >= 1:2.5
31 BuildRequires:  python-modules >= 1:2.5
32 BuildRequires:  python-pygobject
33 BuildRequires:  rpmbuild(macros) >= 1.293
34 BuildRequires:  telepathy-farstream-devel >= 0.6.0
35 BuildRequires:  telepathy-glib-devel >= 0.18.0
36 %if %{with qt4}
37 BuildRequires:  QtCore-devel >= %{qt4_ver}
38 BuildRequires:  QtDBus-devel >= %{qt4_ver}
39 BuildRequires:  QtGui-devel >= %{qt4_ver}
40 BuildRequires:  QtHelp >= %{qt4_ver}
41 BuildRequires:  QtNetwork-devel >= %{qt4_ver}
42 BuildRequires:  QtXml-devel >= %{qt4_ver}
43 BuildRequires:  QtTest-devel >= %{qt4_ver}
44 BuildRequires:  qt4-build >= %{qt4_ver}
45 BuildRequires:  qt4-qmake >= %{qt4_ver}
46 %endif
47 %if %{with qt5}
48 BuildRequires:  Qt5Core-devel >= %{qt5_ver}
49 BuildRequires:  Qt5DBus-devel >= %{qt5_ver}
50 BuildRequires:  Qt5Gui-devel >= %{qt5_ver}
51 BuildRequires:  Qt5Network-devel >= %{qt5_ver}
52 BuildRequires:  Qt5Test-devel >= %{qt5_ver}
53 BuildRequires:  Qt5Widgets-devel >= %{qt5_ver}
54 BuildRequires:  Qt5Xml-devel >= %{qt5_ver}
55 BuildRequires:  qt5-assistant >= %{qt5_ver}
56 BuildRequires:  qt5-build >= %{qt5_ver}
57 BuildRequires:  qt5-qmake >= %{qt5_ver}
58 %endif
59 Requires:       QtCore >= %{qt4_ver}
60 Requires:       QtDBus >= %{qt4_ver}
61 Requires:       QtNetwork >= %{qt4_ver}
62 Requires:       QtXml >= %{qt4_ver}
63 Requires:       telepathy-farstream >= 0.6.0
64 Requires:       telepathy-glib >= 0.18.0
65 Obsoletes:      telepathy-qt4-yell
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Library for Qt4-based Telepathy clients.
70
71 %description -l pl.UTF-8
72 Biblioteka dla klientów Telepathy opartych na Qt4.
73
74 %package devel
75 Summary:        Header files for telepathy-qt4 library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki telepathy-qt4
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       QtCore-devel >= %{qt4_ver}
80 Requires:       QtDBus-devel >= %{qt4_ver}
81 Requires:       QtNetwork-devel >= %{qt4_ver}
82 Requires:       QtXml-devel >= %{qt4_ver}
83 Obsoletes:      telepathy-qt4-yell-devel
84
85 %description devel
86 Header files for telepathy-qt4 library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki telepathy-qt4.
90
91 %package apidocs
92 Summary:        API documentation for telepathy-qt4 and telepathy-qt5 libraries
93 Summary(pl.UTF-8):      Dokumentacja API bibliotek telepathy-qt5 i telepathy-qt5
94 Group:          Documentation
95
96 %description apidocs
97 API documentation for telepathy-qt4 and telepathy-qt5 libraries.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API bibliotek telepathy-qt5 i telepathy-qt5.
101
102 %package -n telepathy-qt5
103 Summary:        Library for Qt5-based Telepathy clients
104 Summary(pl.UTF-8):      Biblioteka dla klientów Telepathy opartych na Qt5
105 Group:          Libraries
106 Requires:       Qt5Core >= %{qt5_ver}
107 Requires:       Qt5DBus >= %{qt5_ver}
108 Requires:       Qt5Network >= %{qt5_ver}
109 Requires:       Qt5Xml >= %{qt5_ver}
110 Requires:       telepathy-farstream >= 0.6.0
111 Requires:       telepathy-glib >= 0.18.0
112
113 %description -n telepathy-qt5
114 Library for Qt5-based Telepathy clients.
115
116 %description -n telepathy-qt5 -l pl.UTF-8
117 Biblioteka dla klientów Telepathy opartych na Qt5.
118
119 %package -n telepathy-qt5-devel
120 Summary:        Header files for telepathy-qt5 library
121 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki telepathy-qt5
122 Group:          Development/Libraries
123 Requires:       telepathy-qt5 = %{version}-%{release}
124 Requires:       Qt5Core-devel >= %{qt5_ver}
125 Requires:       Qt5DBus-devel >= %{qt5_ver}
126
127 %description -n telepathy-qt5-devel
128 Header files for telepathy-qt5 library.
129
130 %description -n telepathy-qt5-devel -l pl.UTF-8
131 Pliki nagłówkowe biblioteki telepathy-qt5.
132
133 %prep
134 %setup -q -n %{orgname}-%{version}
135
136 %build
137 %if %{with qt4}
138 install -d build-qt4
139 cd build-qt4
140 %cmake .. \
141         -DENABLE_FARSTREAM:BOOL=ON \
142         -DQT_QMAKE_EXECUTABLE_FINDQT=%{_libdir}/qt4/bin/qmake
143
144 %{__make}
145 cd ..
146 %endif
147
148 %if %{with qt5}
149 install -d build-qt5
150 cd build-qt5
151 %cmake .. \
152         -DENABLE_FARSTREAM:BOOL=ON \
153         -DQT_QMAKE_EXECUTABLE_FINDQT=%{_libdir}/qt5/bin/qmake
154
155 %{__make}
156 cd ..
157 %endif
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %if %{with qt4}
163 %{__make} -C build-qt4 install \
164         DESTDIR=$RPM_BUILD_ROOT
165 %endif
166
167 %if %{with qt5}
168 %{__make} -C build-qt5 install \
169         DESTDIR=$RPM_BUILD_ROOT
170 %endif
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %post   -n telepathy-qt5 -p /sbin/ldconfig
179 %postun -n telepathy-qt5 -p /sbin/ldconfig
180
181 %if %{with qt4}
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog NEWS README
185 %attr(755,root,root) %{_libdir}/libtelepathy-qt4.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4.so.2
187 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farstream.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4-farstream.so.2
189
190 %files devel
191 %defattr(644,root,root,755)
192 %doc doc/html
193 %attr(755,root,root) %{_libdir}/libtelepathy-qt4.so
194 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farstream.so
195 %{_libdir}/libtelepathy-qt4-service.a
196 %{_libdir}/cmake/TelepathyQt4
197 %{_libdir}/cmake/TelepathyQt4Farstream
198 %{_libdir}/cmake/TelepathyQt4Service
199 %{_includedir}/telepathy-qt4
200 %{_pkgconfigdir}/TelepathyQt4.pc
201 %{_pkgconfigdir}/TelepathyQt4Farstream.pc
202 %{_pkgconfigdir}/TelepathyQt4Service.pc
203 %endif
204
205 %files apidocs
206 %defattr(644,root,root,755)
207 %doc doc/html/*
208
209 %if %{with qt5}
210 %files -n telepathy-qt5
211 %defattr(644,root,root,755)
212 %doc AUTHORS ChangeLog NEWS README
213 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so.*.*.*
214 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5.so.0
215 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so.*.*.*
216 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5-farstream.so.0
217
218 %files -n telepathy-qt5-devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so
221 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so
222 %{_libdir}/libtelepathy-qt5-service.a
223 %{_libdir}/cmake/TelepathyQt5
224 %{_libdir}/cmake/TelepathyQt5Farstream
225 %{_libdir}/cmake/TelepathyQt5Service
226 %{_includedir}/telepathy-qt5
227 %{_pkgconfigdir}/TelepathyQt5.pc
228 %{_pkgconfigdir}/TelepathyQt5Farstream.pc
229 %{_pkgconfigdir}/TelepathyQt5Service.pc
230 %endif
This page took 0.042819 seconds and 4 git commands to generate.