]> git.pld-linux.org Git - packages/telepathy-glib.git/blob - telepathy-glib.spec
Update to 0.20.4
[packages/telepathy-glib.git] / telepathy-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  vala            # do not build Vala API
5 #
6 Summary:        A GLib library to ease writing telepathy clients
7 Summary(pl.UTF-8):      Biblioteka oparta na GLib dla aplikacji służących do komunikacji
8 Name:           telepathy-glib
9 # NOTE: 0.20.x is stable, 0.21.x will be unstable
10 Version:        0.20.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://telepathy.freedesktop.org/releases/telepathy-glib/%{name}-%{version}.tar.gz
15 # Source0-md5:  78be56307d2da7c580cf6df33a225ba0
16 URL:            http://telepathy.freedesktop.org/wiki/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  dbus-devel >= 0.95
20 BuildRequires:  dbus-glib-devel >= 0.90
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  glib2-devel >= 1:2.32.0
23 BuildRequires:  gobject-introspection-devel >= 1.30.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.17}
25 BuildRequires:  libtool
26 BuildRequires:  libxslt-progs
27 BuildRequires:  pkgconfig >= 1:0.21
28 BuildRequires:  python-modules >= 1:2.5
29 %{?with_vala:BuildRequires:     vala >= 2:0.16.0}
30 Requires:       dbus-libs >= 0.95
31 Requires:       dbus-glib >= 0.90
32 Requires:       glib2 >= 1:2.32.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 telepathy-glib is a D-Bus framework for unifying real time
37 communication, including instant messaging, voice calls and video
38 calls. It abstracts differences between protocols to provide a unified
39 interface for applications.
40
41 %description -l pl.UTF-8
42 telepathy-glib jest szkieletem opartym na D-Bus ujednolicającym
43 komunikację w czasie rzeczywistym, włączając w to komunikatory oraz
44 komunikację głosową i za pośrednictwem wideo. Zasłania warstwą
45 abstrakcji różnice pomiędzy protokołami dostarczając jednolity
46 interfejs dla aplikacji.
47
48 %package devel
49 Summary:        Header files for telepathy-glib library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki telepathy-glib
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       dbus-devel >= 0.95
54 Requires:       dbus-glib-devel >= 0.90
55 Requires:       glib2-devel >= 1:2.32.0
56
57 %description devel
58 Header files for telepathy-glib library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki telepathy-glib.
62
63 %package static
64 Summary:        Static telepathy-glib library
65 Summary(pl.UTF-8):      Statyczna biblioteka telepathy-glib
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static telepathy-glib library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka telepathy-glib.
74
75 %package apidocs
76 Summary:        telepathy-glib API documentation
77 Summary(pl.UTF-8):      Dokumentacja API telepathy-glib
78 Group:          Documentation
79 Requires:       gtk-doc-common
80
81 %description apidocs
82 telepathy-glib API documentation.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API telepathy-glib.
86
87 %package -n vala-telepathy-glib
88 Summary:        telepathy-glib API for Vala language
89 Summary(pl.UTF-8):      API telepathy-glib dla języka Vala
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92 Requires:       vala >= 2:0.16.0
93
94 %description -n vala-telepathy-glib
95 telepathy-glib API for Vala language.
96
97 %description -n vala-telepathy-glib -l pl.UTF-8
98 API telepathy-glib dla języka Vala.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         %{__enable_disable apidocs gtk-doc} \
112         --enable-introspection \
113         %{__enable_disable vala vala-bindings} \
114         --with-html-dir=%{_gtkdocdir}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README
134 %attr(755,root,root) %{_libdir}/libtelepathy-glib.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-glib.so.0
136 %{_libdir}/girepository-1.0/TelepathyGLib-0.12.typelib
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libtelepathy-glib.so
141 %{_libdir}/libtelepathy-glib.la
142 %dir %{_includedir}/telepathy-1.0
143 %dir %{_includedir}/telepathy-1.0/telepathy-glib
144 %dir %{_includedir}/telepathy-1.0/telepathy-glib/_gen
145 %{_includedir}/telepathy-1.0/telepathy-glib/*.h
146 %{_includedir}/telepathy-1.0/telepathy-glib/_gen/*.h
147 %{_pkgconfigdir}/telepathy-glib.pc
148 %{_datadir}/gir-1.0/TelepathyGLib-0.12.gir
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libtelepathy-glib.a
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %{_gtkdocdir}/telepathy-glib
158 %endif
159
160 %if %{with vala}
161 %files -n vala-telepathy-glib
162 %defattr(644,root,root,755)
163 %{_datadir}/vala/vapi/telepathy-glib.deps
164 %{_datadir}/vala/vapi/telepathy-glib.vapi
165 %endif
This page took 0.109974 seconds and 3 git commands to generate.