]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
c7bf2ef18f739e35782fb3fead0072d2af6f9858
[packages/tdb.git] / tdb.spec
1 Summary:        TDB - Trivial Database
2 Summary(pl.UTF-8):      TDB - prosta baza danych
3 Name:           tdb
4 Version:        1.4.7
5 Release:        2
6 Epoch:          2
7 License:        LGPL v3+
8 Group:          Libraries
9 Source0:        https://www.samba.org/ftp/tdb/%{name}-%{version}.tar.gz
10 # Source0-md5:  bc27d5b20c7f013305c40b3bced43b3a
11 URL:            https://tdb.samba.org/
12 BuildRequires:  libbsd-devel
13 BuildRequires:  python3-devel >= 1:3.2
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.507
16 Obsoletes:      tdb-extras < 1.1
17 # tdb 1.4+ dropped python2 suport
18 Obsoletes:      python-tdb < 2:1.4
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 TDB is a Trivial Database. In concept, it is very much like GDBM, and
23 BSD's DB except that it allows multiple simultaneous writers and uses
24 locking internally to keep writers from trampling on each other. TDB
25 is also extremely small.
26
27 %description -l pl.UTF-8
28 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
29 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
30 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
31 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
32 ekstremalnie mała.
33
34 %package devel
35 Summary:        Header files for TDB library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
37 Group:          Development/Libraries
38 Requires:       %{name} = %{epoch}:%{version}-%{release}
39 Obsoletes:      tdb-static < 2:1.2
40
41 %description devel
42 Header files for TDB library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki TDB.
46
47 %package -n python3-tdb
48 Summary:        Python 3 bindings for TDB
49 Summary(pl.UTF-8):      Interfejs Pythona 3 do TDB
50 Group:          Libraries/Python
51 Requires:       %{name} = %{epoch}:%{version}-%{release}
52 Requires:       python3-libs >= 1:3.2
53
54 %description -n python3-tdb
55 Python 3 bindings for TDB.
56
57 %description -n python3-tdb -l pl.UTF-8
58 Interfejs Pythona 3 do TDB.
59
60 %prep
61 %setup -q
62
63 %build
64 export JOBS=1
65
66 CC="%{__cc}" \
67 CFLAGS="%{rpmcflags}" \
68 PYTHONHASHSEED=1 \
69 %{__python3} buildtools/bin/waf configure \
70         --prefix=%{_prefix} \
71         --libdir=%{_libdir} \
72         --disable-rpath
73
74 %{__make} \
75         V=1
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
84 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %triggerpostun -p /sbin/postshell -- tdb < 2:1.2.9-2
93 -rm -f %{_libdir}/libtdb.so.1
94 /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc docs/{README,mutex.txt,tracing.txt}
99 %attr(755,root,root) %{_bindir}/tdbbackup
100 %attr(755,root,root) %{_bindir}/tdbdump
101 %attr(755,root,root) %{_bindir}/tdbrestore
102 %attr(755,root,root) %{_bindir}/tdbtool
103 %attr(755,root,root) %{_libdir}/libtdb.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libtdb.so.1
105 %{_mandir}/man8/tdbbackup.8*
106 %{_mandir}/man8/tdbdump.8*
107 %{_mandir}/man8/tdbrestore.8*
108 %{_mandir}/man8/tdbtool.8*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/libtdb.so
113 %{_includedir}/tdb.h
114 %{_pkgconfigdir}/tdb.pc
115
116 %files -n python3-tdb
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{py3_sitedir}/tdb.cpython-*.so
119 %{py3_sitedir}/_tdb_text.py
120 %{py3_sitedir}/__pycache__/_tdb_text.cpython-*.py[co]
This page took 0.024757 seconds and 2 git commands to generate.